Het forum

POL ne se lance plus depuis le passage a la 2.0

Auteur Antwoorden
Gagaro Woensdag 7 November 2007 om 21:20
GagaroAnonymous

Bonjour,

J'ai installer POL 2.0 puis 2.0.1 mais quand j'essaye de le lancer rien ne se passe.
Quand je le lance depuis un terminal il me marque ceci :


PlayOnLinux v2.0
----------------
Checking python : [ Ok ]
Traceback (most recent call last):
File "/usr/share/playonlinux/python/mainwindow.py", line 22, in <module>
import wxversion, os, getopt, sys, urllib, signal, socket
ImportError: No module named wxversion


Merci de m'aider
Quentin PÂRIS Woensdag 7 November 2007 om 21:27
Quentin PÂRIS
Admin

Quelle distribution ?

Install le paquet python-wxgtk2.8
Gagaro Woensdag 7 November 2007 om 21:53
GagaroAnonymous

Je suis sous Kubuntu 7.04, le paquet python-wxgtk2.8 est déjà installé :s
Quentin PÂRIS Woensdag 7 November 2007 om 22:13
Quentin PÂRIS
Admin

Alors install

python-wxversion

Sinon, tape python --version dans une console

Aangepast door Tinou

Aymeric P. Woensdag 7 November 2007 om 23:36
Aymeric P.
Admin

Tinou je certifie tu as oublier la dépendance vers python-wxversion dans le .deb

Former member.
Quentin PÂRIS Donderdag 8 November 2007 om 13:01
Quentin PÂRIS
Admin

python-wxversion est une dépendance de python-wxgtk2.8
Gagaro Donderdag 8 November 2007 om 17:44
GagaroAnonymous

python-wxversion est également déjà installer.

Lorsque je tape python --version, il me marque :

Python 2.5.1

Apparemment j'aurai une mauvaise version ?!?
Quentin PÂRIS Donderdag 8 November 2007 om 18:17
Quentin PÂRIS
Admin

Tape

python
> import wxversion
> quit()

python2.4
> import wxversion
> quit()
Gagaro Donderdag 8 November 2007 om 18:21
GagaroAnonymous

Voila ce que sa me donne :

gagaro@gagaro-desktop:~$ python
Python 2.5.1 (r251:54863, May 2 2007, 16:56:35)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wxversion
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named wxversion
>>> quit()
gagaro@gagaro-desktop:~$ python2.4
Python 2.4.4 (#2, Apr 12 2007, 21:03:11)
[GCC 4.1.2 (Ubuntu 4.1.2-0ubuntu4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wxversion
>>> quit()
Traceback (most recent call last):
File "<stdin>", line 1, in ?
TypeError: 'str' object is not callable
>>>
Quentin PÂRIS Donderdag 8 November 2007 om 18:34
Quentin PÂRIS
Admin

Ok

Essais d'installer python2.5-wxgtk2.8
Gagaro Donderdag 8 November 2007 om 19:25
GagaroAnonymous

Je n'ai pas de paquet de ce nom la, j'ai juste :

Quentin PÂRIS Donderdag 8 November 2007 om 19:26
Quentin PÂRIS
Admin

Bon, solution radicale.

Tu modifies /usr/share/playonlinux/lib/variables.
Tu remplaces
export PYTHON="python"
par
export PYTHON="python2.4"
Gagaro Donderdag 8 November 2007 om 19:35
GagaroAnonymous

Sa marche, merci beaucoup ^^
HotTux Vrijdag 15 Februari 2008 om 17:13
HotTuxAnonymous

Bonjour,
pardon de relancer ce poste mais je rencontre le meme probleme sous openSUSE et je n'ai pas python2.4 (je peux meme pas l'installe, il manque le paquet dans Yast)

Y a-t-il une autre solution?
Ghostofkendo Vrijdag 15 Februari 2008 om 17:54
Ghostofkendo

Salux HotTux,

Je suis également sous openSUSE (la 10.3) et POL est tout à fait installable.
Et au cas où tu n'aurais pas fait ainsi, il est disponible dans le dépôt Packman. (pour en savoir plus, va voir ICI.)
Quant à la dépendance python, il suffit d'installer le paquet wxGTK (disponible dans le DVD de la 10.3 ou dans le dépôt OSS : http://download.opensuse.org/repositories/openSUSE:10.3/standard/ )
Il me semble qu'il n'y a pas besoin d'autres dépôts pour POL.

Au pire, il y a toujorus le One Click Install. Avec ça, tu ne devrais pas avoir de problèmes

@+
HotTux Zondag 17 Februari 2008 om 9:38
HotTuxAnonymous

Merci pour votre aide, la seule chose qui me manquait c'est le paquet wxGTK. Maintenant qu'il est installe POL marche impec.

Encore merci, @+