Het forum

Problems with Fallout 2

Auteur Antwoorden
actionjohnson Vrijdag 19 October 2012 om 7:21
actionjohnsonAnonymous

So I'm trying to play the GOG version of Fallout 2, the first problem I had was during the installation, I kept getting an error crash right when it started to download, no big deal I just downloaded the exe of GOG and used that.
Now along with the problem I've always had with everything playonmac, I cant play fullscreen, if I don't go to config and set up a virtual desktop I just get into the game with a black screen with sound.
The third problem I'm having is, after I launch fallout 2 in the windowed version, I almost immediately get a crash and this error message, "The instruction at 460acbbe referenced memory at 00000000a the memory could not be read from"

What is with all these problems I'm having? I need help!
I am running mac version 10.7.5 and playonmacs latest version.
petch Vrijdag 19 October 2012 om 8:14
petch
Developer

Hi,
I can confirm the first issue, it seems that with the introduction of Mac support on GOG the download URLs (at least) changed, so our automatic download is now broken.
Don't know about the two others.
petch Vrijdag 19 October 2012 om 9:03
petch
Developer

actionjohnson Vrijdag 19 October 2012 om 23:37
actionjohnsonAnonymous

I uninstalled it to try the download, I still get that same error.
Error in POL_System_wget
POL_System_wget failed, error 1 !
petch Zaterdag 20 October 2012 om 9:18
petch
Developer


Works for me, send a bug report maybe the installation log will reveal something.
actionjohnson Zondag 21 October 2012 om 8:49
actionjohnsonAnonymous

Man, I'm having problems, I can't send an error report either. After I go through all the steps of writing the problem and signing in, I get this error "Error this script seems to be no longer existing in our database."
petch Zondag 21 October 2012 om 9:31
petch
Developer


I can confirm the issue :(

Filing out a bug report about the bug reporting...

Ah oops, there's one already, that got lost in the heap:
http://www.playonlinux.com/en/issue-1251.html

Aangepast door petch

actionjohnson Zaterdag 27 October 2012 om 7:55
actionjohnsonAnonymous

Was this issue ever resolved? I get the same download error message with Baulders Gate 2, and I'd bet that it's the same with the others.
I'm using the 4.1.8 that is available on the site, should I be using a developer version or something? If so, where would I get that, the only one I can find is for Linux.
petch Zaterdag 27 October 2012 om 8:24
petch
Developer


Maybe you shouldn't get me started on whether I did something I said, not today.
The fix is in the download script, not PlayOnLinux itself, so no need to upgrade anything it's automatic.
POL_GoG_download script changelog

Works for me, just checked again.

Aangepast door petch

petch Zaterdag 27 October 2012 om 11:29
petch
Developer


Ok, it seems there was a second problem, specific to Macs, on top of the first; Tinou just fixed it, so you can give it a try.
Again, nothing to update.