Fora

X-fi/Intel-HDA - Need help

Autor Odpowiedzi
sarka Wednesday 11 December 2013 at 8:15
sarkaAnonymous

So I have an integrated Intel HD audio chip on my motherboard and I also have Creative PCI Express X-Fi Titanium Fatal1ty Champion Series (monster of a name).


I've read that Ubuntu "should" support X-fi natively (EMU20k2) but not the front panel. So no downmixing from 5.1 to headphones, no muting for headphones, no volume control (which is quite useless anyway).


So I tried Intel HD Audio. Got the sound working OK, but no sound from headphones. Got sound from headphones, but no muting when headphones are plugged in. Found some topics with alsa-base mods and that really made it. If I don't have headphones plugged in, I get awful lot of noise and whining from the card :D And still when headphones are plugged in, also speakers play sound.


I read that there was some kernel bug causing this, but it was some time ago and is patched in current kernels?


If I could get either of the cards work with headphones so that speakers are 5.1 and headphones 2.0 with speaker muting, I would be quite happy. But I'm all out of ideas :I

Daerandin Sunday 15 December 2013 at 3:34
DaerandinAnonymous

I think you will have better luck finding help on the Ubuntu forums, since a lot of people here probably don't even use Ubuntu.

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com