Fora

AION online problem. Freezes when trying to use portal.

Autor Odpowiedzi
Arkzyw Wednesday 18 March 2015 at 22:21
ArkzywAnonymous

Hello. After some time I could use some help again. I would be really grateful if you could provide some info.

Linux Mint 17.1 64

POL 4.2.6

Wine 1.7.36

Game: AION Online EU-Gameforge version.

Problem: Game freezes when trying to use non-instance portals. Even hovering with cursor over it makes game freeze. I'm attaching screenshot, and some debug output.

http://postimg.org/image/yj5li2o03/




err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

fixme:heap:RtlSetHeapInformation 0x110000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x2e300000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x29750000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x27a60000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x277d0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x29ce0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x27280000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x103a0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x39f0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x38e0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x28f0000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x930000 0 0x33cbfc 4 stub
fixme:heap:RtlSetHeapInformation 0x6e0000 0 0x33cbfc 4 stub
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:imm:ImmGetOpenStatus (0x1852e8): semi-stub
fixme:imm:ImmReleaseContext (0x200e4, 0x1852e8): stub
fixme:d3d9:Direct3DShaderValidatorCreate9 stub
err:winediag:IcmpCreateFile Failed to use ICMP (network ping), this requires special permissions.
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:iphlpapi:NotifyAddrChange (Handle 0x363ae7bc, overlapped 0x299423a0): stub
err:heap:HEAP_CreateSystemHeap system heap base address 0x80000000 not available
wine: Unhandled page fault on read access to 0xf68fc900 at address 0x2a902cf3 (thread 005a), starting debugger..
fixme:win:FlashWindowEx 0x8ecb8c
fixme:win:FlashWindowEx 0x8eca6c
 

I'm really like a blind man walking through the mist, but what made me suspicious was: "err:winediag:IcmpCreateFile Failed to use ICMP (network ping), this requires special permissions."

Then I gave priviliges to wine-preloader

sudo setcap cap_net_raw+epi

, but that makes even the launcher crash, and more errors:




wine: Unhandled page fault on execute access to 0x00000000 at address (nil) (thread 000f), starting debugger...
err:wineboot:start_services_process Unexpected termination of services.exe - exit code 0
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku anifixme:system:SetProcessDPIAware stub!
fixme:win:FlashWindowEx 0x6de91c
wine: Unhandled page fault on read access to 0x00000000 at address (nil) (thread 0009), starting debugger...
Can't attach process 0008: error 5
wine client error:9: write: Wrong file descriptor.
 

Now I really don't know what can I do/try.

I am not even sure, if my approach is correct, but ANY ideas would be highly appreciated.

Thanks in advance.

 

 

 

Edytowane przez Arkzyw

Ronin DUSETTE Wednesday 18 March 2015 at 22:42
Ronin DUSETTE
Admin

For the p11-kit error:

http://wiki.playonlinux.com/index.php/Troubleshooting_Common_Problems

Also, what are is your graphics card, and what drivers do you have installed? If not, turn off the setcap thing, get your drivers set up correctly (complete with the 32-bit libraries for them), delete the virtual drive for that game, and attempt the install again, and let's see if that makes a difference. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Arkzyw Wednesday 18 March 2015 at 23:29
ArkzywAnonymous

Graphic card Radeon HD6870 with Omega 14.12 proprietary driver.

Fixed p11-kit error - thank you.

But unfortunately that doesn't resolve this issue. I may add that every other feature in game(tested up to my current lvl-21) works correctly. There are some graphical bugs of course, but there is no solution for them yet.

Only this kind of portals - instance portals work correctly.

What about these errors ?

err:winediag:IcmpCreateFile Failed to use ICMP (network ping), this requires special permissions.

err:heap:HEAP_CreateSystemHeap system heap base address 0x80000000 not available.

Not sure what, or why it tries to ping, but these are the errors just after the freeze.

 

 

Ronin DUSETTE Thursday 19 March 2015 at 0:21
Ronin DUSETTE
Admin

I don't know. I am just covering the bases first.

Take a look at this. I found this from a couple of years ago:

https://www.playonlinux.com/en/topic-10753-Cant_ping_out_from_virtual_drive.html


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Thursday 19 March 2015 at 0:48
Ronin DUSETTE
Admin

Actually, I think I figured it out. 

That command you are running is for regular Wine. Not POL WineBuilds. So, what we need to do is tell it to use the Wine version that is in POL's folders, not the regular one.

All Wine installs are stored in ~/.PlayOnLinux/wine

In your case, the Wine version that you want is located here:

~/.PlayOnLinux/wine/linux-x86/1.7.36/bin/wine

So the full command you want to run is:

sudo setcap cap_net_raw+epi /home/username/.PlayOnLinux/wine/linux-x86/1.7.36/bin/wine

or

sudo setcap cap_net_raw+epi /home/username/.PlayOnLinux/wine/linux-x86/1.7.36/bin/wine-preloader

Obviously, replacing "username" with your current user name. Try that, and run it and see if it works now. 

Edytowane przez RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Arkzyw Thursday 19 March 2015 at 10:55
ArkzywAnonymous

Thanks for answers.

sudo setcap cap_net_raw+epi /home/username/.PlayOnLinux/wine/linux-x86/1.7.36/bin/wine

Doesn't give any visible results.

sudo setcap cap_net_raw+epi /home/username/.PlayOnLinux/wine/linux-x86/1.7.36/bin/wine-preloader

Produces more errors:

err:wineboot:start_services_process Unexpected termination of services.exe - exit code 0

anifixme:system:SetProcessDPIAware stub!
fixme:win:FlashWindowEx 0x6de91c
wine: Unhandled page fault on read access to 0x00000000 at address (nil) (thread 0009), starting debugger...
Can't attach process 0008: error 5
wine client error:9: write: Wrong file descriptor.

I also tried to give capabilities after running the launcher, but when trying to run game I get various errors about missing files.

 

When I have some time I will look at the topic you gave before, and maybe that will help. Anyway it looks worth trying.

 

Ronin DUSETTE Thursday 19 March 2015 at 16:24
Ronin DUSETTE
Admin

Delete the virtual drive for that game, reinstall it, and try again. That should work. If it doesn't, you should file a bug report with WineHQ.


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Thursday 19 March 2015 at 16:27
Ronin DUSETTE
Admin

A bug report has been opened for this with us, because apparently our POL WineBuilds fail to work with this command. You can follow the report here:

https://www.playonlinux.com/en/issue-5021.html

Once this is fixed with our WineBuilds, that command that I gave for wine-preloader should work fine. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts