Fora

ati & wine

Autor Odpowiedzi
Mimosa Tuesday 6 May 2008 at 11:50
MimosaAnonymous

Bonjour,

Je suis sur Debian Etch avec une ati (HD2400 avec 256Mo & drivers proprios). Les jeux natifs linux utilisant la 3d fonctionnent nickel.

Par contre, sous wine, c'est une autre histoire. C'est lent a mourir. J'ai chercher un peu sur internet et il semblerait qu'il faille que je passe sur nvidia.

Y a t il un autre moyen?


Cordialement
BeberKing Tuesday 6 May 2008 at 14:31
BeberKing

Bonjour,

Quelle est la version de tes drivers proprios ? Ceux qui sont fournis dans Etch sont un peu vieux. La dernière version (que tu trouveras sur le site d'ATI) pourrait régler ton problème...

Moi j'ai une vieille ATI sur une Debian Lenny et wine fonctionne très bien.
Mimosa Wednesday 7 May 2008 at 14:32
MimosaAnonymous

Merci de ta réponse. Pour les drivers, j'ai le:
ati-driver-installer-8.42.3-x86.x86_64.run

J'ai essayé d'installer le dernier :ati-driver-installer-8-4-x86.x86_64.run mais je n'arrive pas à avoir la 3d.

Pour info, je l'installe de cette manière:

je supprime les drivers existants sous synaptic

./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Debian/etch

dpkg -i fglrx-amdcccle_8.42.3-1_i386.deb fglrx-driver_8.42.3-1_i386.deb fglrx-kernel-src_8.42.3-1_i386.deb

cd /usr/src

rm *fglrx*

module-assistant prepare

module-assistant update

module-assistant build fglrx-kernel

module-assistant install fglrx-kernel

Quelques modifs dans /etc/X11/xorg.conf:
Section "Module"
...
Load "GLcore"
Load "glx"
Load "dri"
...
# Charge "extmod" mais sans DGA extension
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
...
EndSection

Section "Device"
Identifier "ATI"
Driver "fglrx" # La partie importante

# Si X refuse de se charger à la résolution spécifiée,
# essayez de dé-commenter l'option suivante.
#Option "NoDDC"

# === Video Overlay for the Xv extension ===
Option "VideoOverlay" "on"
# === OpenGL Overlay ===
# Note: quand OpenGL Overlay est activé, Video Overlay
# est automatiquement désactivé.
Option "OpenGLOverlay" "off"
# === Use internal AGP GART support? ===
# Si l'accélération OpenGL ne marche pas, essayez de mettre "yes" ici
# et désactivez le module agpgart du noyau.
Option "UseInternalAGPGART" "no"
EndSection

Section "Screen"
Identifier "your screen"
Device "ATI"
Monitor "your monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x960" # juste un exemple,
# mettez votre résolution préférée ici
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection


la version de wine que j'utilise est la 0.9.58


malgré tout ça , ça rame, ça rame


merci de votre attention
Mimosa Wednesday 7 May 2008 at 14:34
MimosaAnonymous

au fait, ça devient lent dès que le jeux est compliqué.

Par exemple, pour san andreas, c'est nickel dans les menus mais injouable car trop lent dans le jeux.
BeberKing Wednesday 7 May 2008 at 15:08
BeberKing

Ta méthode d'installation me semble tout à fait correcte, tu pourrais juste aller un peu plus vite avec la commande suivante (ça fait build et install) :#m-a a-i fglrx
Je pense que je n'ai pas de solution miracle à ton problème. Sur ma X600 je peux jouer à HL1 sans le moindre soucis. Mais par contre j'ai des problèmes avec Trackmania (et vu que tout le monde a l'air de dire que ça marche, ça doit être du à mes drivers).

Je pense que tu devrais réessayer de mettre les derniers drivers (8.4). Si ça ne marche pas c'est qu'il y'a un problème quelque part, et le régler pourrait aussi régler ton problème avec Wine...

Enfin si ça t'interesse, je te joins mon xorg.conf, qui fait marcher la 3D avec les derniers drivers (8.4), et qui me permet de faire marcher compiz

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
     Identifier "Default Layout"
     Screen 0 "aticonfig-Screen[0]" 0 0
     InputDevice "Generic Keyboard"
     InputDevice "Configured Mouse"
     InputDevice "Synaptics Touchpad"
     Option      "AIGLX" "True"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
     Identifier "Generic Keyboard"
     Driver "kbd"
     Option      "CoreKeyboard"
     Option      "XkbRules" "xorg"
     Option      "XkbModel" "pc105"
     Option      "XkbLayout" "fr"
     Option      "XkbVariant" "latin9"
EndSection

Section "InputDevice"
     Identifier "Configured Mouse"
     Driver "mouse"
     Option      "CorePointer"
     Option      "Device" "/dev/input/mice"
     Option      "Protocol" "ImPS/2"
     Option      "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
     Identifier "Synaptics Touchpad"
     Driver "synaptics"
     Option      "SendCoreEvents" "true"
     Option      "Device" "/dev/psaux"
     Option      "Protocol" "auto-dev"
     Option      "HorizScrollDelta" "0"
EndSection

Section "Monitor"
     Identifier "aticonfig-Monitor[0]"
     Option      "VendorName" "ATI Proprietary Driver"
     Option      "ModelName" "Generic Autodetecting Monitor"
     Option      "DPMS" "true"
EndSection

Section "Device"
     Identifier "aticonfig-Device[0]"
     Driver "fglrx"
     Option      "XAANoOffscreenPixmaps" "true"
     Option "VideoOverlay" "on"
     Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
     Identifier "aticonfig-Screen[0]"
     Device "aticonfig-Device[0]"
     Monitor "aticonfig-Monitor[0]"
     DefaultDepth 24
     SubSection "Display"
          Viewport 0 0
          Depth 24
     EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
     Option      "Composite" "Enable"
EndSection
Aymeric P. Wednesday 7 May 2008 at 20:11
Aymeric P.
Admin

Essaye avec les derniers pilotes ati pour ta carte normalement du devrais avoir la 3d (mais bon je reconnais pour avoir eu une carte ATI que c'est souvent casse c*l)

Former member.
Yimboka Thursday 8 May 2008 at 8:47
YimbokaAnonymous

Boarf, personnellement je n'ai jamais eu de soucis à installer les modules fglrx, en 30 secondes chrono. Suffit de bien comprendre comment il fonctionne dans la distrib.

Sinon tu dis que ça rame, ça rame, mais tu as regardé si ton module fglrx est bien lancé? c'est certainement la le problème.

Ce qui serait bien c'est de virer tous les paquets fglrx, virer les traces de fglrx dans /usr/src, et recréer tes paquets avec le .run de ATI. Si tu suis une logique d'installation, il ne devrait pas avoir de soucis. Par contre pendant l'installation, vérifié bien que ton serveur X est bien fermé, cela peut poser des problèmes parfois pour le lancement du module.

Edytowane przez Yimboka

Mimosa Thursday 8 May 2008 at 22:24
MimosaAnonymous

Perso, l'installation des drivers me prend aussi 30 secondes. La seule différence avec toi est que je ne quitte pas l'X-windows. Je vais essayer de faire en le quittant et je vous tiens au courant.

Mimosa Thursday 8 May 2008 at 23:32
MimosaAnonymous

Je ne comprends pas. Je n'arrive pas a avoir la 3d avec les drivers Catalyst.

remy@allopilij:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

Yimboka Saturday 10 May 2008 at 8:54
YimbokaAnonymous

Essaye un lsmod pour voir si le module est lancé, ce dont je doute d'après ton fglrxinfo. Si il ne l'ai pas, modprobe fglrx.
Mimosa Saturday 10 May 2008 at 12:43
MimosaAnonymous

J'ai enfin réussi à installer le driver catalyst 8-4. Il me manquait le tmpfs sur /dev/shm.

Par contre, c'est toujours aussi lent.
Yimboka Saturday 10 May 2008 at 18:50
YimbokaAnonymous

Ah ça, il va falloir attendre les RadeonHD si tu comptes avec quelque chose de rapide
Mimosa Monday 12 May 2008 at 7:01
MimosaAnonymous

Je pense plutôt investir dans une Gforce 8600 gts. Est-ce une bonne idée?
Yimboka Monday 12 May 2008 at 8:16
YimbokaAnonymous

Je pense que ça peut être un bon investissement si tu n'as pas trop les moyens en ce moment et que tu recherches un minimum de puissance.
Jesteś tutaj: Index > PlayOnLinux > ati & wine