centOS winbind not detected by PlayOnLinux

Autor Odpowiedzi
Stepes Monday 30 January 2017 at 15:22

Hi, I'm trying to install MS Office 2010/2013 which requires winbind. However on centOS there is no winbind package, only samba-winbind which I've installed:


[xxx@yyy zzz]$ yum list | grep "winbind"
samba-winbind.x86_64                     4.2.10-6.el7_2               @updates  
samba-winbind-modules.x86_64             4.2.10-6.el7_2               @updates  
mod_auth_ntlm_winbind.x86_64             0.0.0-0.15.20070129svn713.el7
samba-winbind.x86_64                     4.4.4-12.el7_3               updates   
samba-winbind-clients.x86_64             4.4.4-12.el7_3               updates   
samba-winbind-krb5-locator.x86_64        4.4.4-12.el7_3               updates   
samba-winbind-modules.i686               4.4.4-12.el7_3               updates   
samba-winbind-modules.x86_64             4.4.4-12.el7_3               updates   
sssd-winbind-idmap.x86_64                1.14.0-43.el7_3.11           updates 


At the beginning of the installation PlayOnLinux complains that it can't find winbind. Is there some trick to this? 

Error in main
Please install winbind before installing Microsoft Office 2013

Many thanks!

Edytowane przez Stepes

Quentin PÂRIS Monday 30 January 2017 at 17:45
Quentin PÂRIS

Hi, can you type "which winbind" in a terminal please?

Stepes Tuesday 31 January 2017 at 10:25

[xxx@yyy ~]$ which winbind
/usr/bin/which: no winbind in (...)

Can't find it in /usr/bin/ or /bin/ either.

Edytowane przez Stepes

Stepes Tuesday 31 January 2017 at 10:35

[sdoerr@loro ~]$ systemctl status winbind.service
● winbind.service - Samba Winbind Daemon
   Loaded: loaded (/usr/lib/systemd/system/winbind.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Seems like the winbind service is installed and working though


There is also a winbindd executable in /usr/sbin/

[xxx@yyy ~]$ rpm -qil samba-winbind
Name        : samba-winbind
Epoch       : 0
Version     : 4.2.10
Release     : 6.el7_2
Architecture: x86_64
Install Date: Wed 08 Jun 2016 10:46:28 AM CEST
Group       : Applications/System
Size        : 1457726
License     : GPLv3+ and LGPLv3+
Signature   : RSA/SHA256, Wed 13 Apr 2016 04:03:04 AM CEST, Key ID 24c6a8a7f4a80eb5
Source RPM  : samba-4.2.10-6.el7_2.src.rpm
Build Date  : Wed 13 Apr 2016 02:36:28 AM CEST
Build Host  :
Relocations : (not relocatable)
Packager    : CentOS BuildSystem <>
Vendor      : CentOS
URL         :
Summary     : Samba winbind
Description :
The samba-winbind package provides the winbind NSS library, and some
client tools.  Winbind enables Linux to be a full member in Windows
domains and to use Windows user and group accounts on Linux.


Edytowane przez Stepes

Stepes Monday 6 February 2017 at 9:48

No further ideas on this? (sorry for bumping, but I assume the solution might be easy considering the service is instealled)

Edytowane przez Stepes

Quentin PÂRIS Saturday 11 February 2017 at 16:11
Quentin PÂRIS

Just ensure that you have winbind in your path and POL will detect it fine

Stepes Friday 17 February 2017 at 14:23

I tried to "fake" the winbind executable:

ln -s /usr/sbin/winbindd winbind
export PATH=/home/myname/:$PATH

Still doesn't detect it. Maybe because I'm not sudo? But I don't see the problem in that

Edytowane przez Stepes