Steam Games Don\'t Work all

Autor Odpowiedzi
irockyou Saturday 31 May 2008 at 22:00

- I use Ubuntu 8.04
- The latest version of Play On Linux, I think 3
- Gnome

Let me just say that I tried installing Steam with wine and I got the same problem, so then I installed Play On Linux and was presently surprised at how easy everything was. This is wonderful software!

I haven't tried installing any other games or programs except for Steam. It installed OK, and it runs OK (a little bit of lag every couple of seconds; a button might not highlight unless I hover or something, or something dumb like that, not a big problem). The problem comes when I load a game. I can't really describe it, so here's a screenshot of me trying to run Audiosurf:

I have 3D acceleration installed (and I restarted my computer afterwards). Can anyone help? Thanks in advance! Steam is the only thing keeping me from booting linux every time.

- Your computer configuration.

I'm not sure what you mean by computer configuration... but it's a Dell, with a Pentium D 2.8 GHz, an ATI Radeon x1950 Pro, and 2 GB of DDR2 Ram. Is that enough info?

Thanks again.
irockyou Tuesday 8 July 2008 at 1:53

Can anyone help?
scoubidou Monday 11 August 2008 at 15:17


I'm also running Ubuntu 8.04 POLv3 & Gnome and my Steam does work. I could play Counter-Strike on Steam without a problem.

Do you have Compiz or Compiz-Fusion installed?

I'm running Compiz-Fusion and I've installed Emerald Window decorator.
Maybe that's what missing? I haven't try playing on Metacity.

Just an Idea. Have you tried any other game?

Good luck

Your video card : GeForce 8800 GT/PCI/SSE2
Your distribution : Ubuntu
Your distribution version : 8.04
Wine version installed : wine-1.0
Wine version used by PlayOnLinux : wine-1.0
Mota_boy Sunday 24 August 2008 at 12:37

Hi all.

Bit offtopic but, how goodly have you get the some games work on steam e.x HL2? how good fps did you get?
i get something like 15-30 only , and setups are medium, i have amd phenom 9850 and tested with 8800GTS,( g80 ) and with 9600GT with same result, i`m i missing something, or should i do some advanced configurations with wine perhaps?
Thanks by all tips and hints for advance
amd-linux Sunday 24 August 2008 at 13:48

Here is what I get when I want to run the Steam script:

/usr/share/playonlinux/playonlinux --run "Steam"
PlayOnLinux v3.0.8

Checking python :                     [ Ok ]
Steam: line 5: cd: /home/user/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/: No such file or directory
wine: could not load L"C:\\windows\\system32\\steam.exe": Modul nicht gefunden
Kafre Sunday 31 August 2008 at 11:17


I had a similar problem with the directory. Since my Windows folder is in spanish (yours will be in German I presume). Try editing the Steam link with gedit and change the folder. EG:

cd: /home/user/.PlayOnLinux/wineprefix/Steam/drive_c/Program Files/Steam/:


cd: /home/user/.PlayOnLinux/wineprefix/Steam/drive_c/Archivos de Programa/Steam/: