Can't launch Battlefield 2 exe

Directx problem

Autor Odpowiedzi
caps Monday 13 April 2020 at 20:00

Hello all,

I have a game folder taken from my windows PC, which I can copy to other windows computers and double click the BF2.exe to play. On my linux computer, I have playonlinux installed, but when I set my virtual drive with a shortcut to the game exe and click "run" I get the message: "DirectX version 9.0c or higher is required to run BF2. Your system seems to have DirectX 0.0 installed."

I have clicked "install" on every one of the directx options in the install components menu. They all run and nothing else happens. When I run the one called "directx9" it runs an installer and exits quickly.

I went into the "configure wine" screen, and in the "libraries" tab I changed all of the directx dlls overrides to "builtin" from "native". WHen I do that the game launches and immediately crashes with the message saying it's either a problem in the app or a deficiency with wine.

I honsetly have no idea what I'm doing. All my other games simply run when I add them as shortcuts. Any help would be very appreciated.



Dadu042 Monday 13 April 2020 at 22:59

caps Wednesday 15 April 2020 at 20:29


Brian_Black Monday 11 October 2021 at 0:20

I am having issues with Battlefield 2 as well.  I have narrowed it down to a WINE error, so far no one is answering my calls on this one.  Please bare with me.

BF2 was working before something changed this year, it was not BF2, since the game is so old my CD is grown some moss on it.  Before anyone asks, yes I have reinstalled the game but preserved my old version because I like to mod this game.  Modding it was allowed by the developer as it came with a mods folder.  The mods are not the issue and the game hasn't been altered in the fresh install in any way.

I tried WineHQ 6.0.1 stable and I get "0228:err:vulkan:wine_vk_init Failed to load"  the problem with that is; I never installed Vulkan, don't run Vulkan, and my Nvidia card is pretty old GT 700 series. I tried rolling back the driver. I tried Winetricks since the game uses d3dx9_24.dll but all the time I had this game, it never gave me any issue until sometime this year.  I am on the verge of shelfing the game along with my other relics of the past.

I decided to check here, I know POL uses multiple versions on WINE with a Python UI, thought maybe someone here could shed some light on what is going on with BF2.  I am not keen on the idea of running another install of WINE version on my system for just one game.  I know I might not get an answer here, since I am not running the POL system.  I figure at least I would spread the word on what is stopping my BF2 game from working.

I was already given all the snarky answers on other forums, such as buy a new graphics card, and you should try Windows 11.  Let's be gentlemen and be civil to each other.

Thank you, I will check back next weekend.

Brian_Black Thursday 28 October 2021 at 20:26

Over the last weekend, I ran some tests.  Battlefield 2 is the only game on my system giving me this Vulkan error message.  I  parititioned a new drive and installed Lubuntu 18.04 on it, sudo apt install wine added version 3.0 and winetricks d3dx9 the game executed from that partition with the WINE 3.0.  I am not going to retrograde my system for just one game. I thought my findings might be useful information to anyone browsing this thread in the future.  Apparently somewhere between WINE 3.0 to 6.0 we have a Vulkan issue.

v010dya Friday 3 December 2021 at 14:57

Hello. You can actually change the Wine version. Go to Configure, selecte the drive of the game, and you will see 'Wine version' dropdown menu. If the version you are looking for (3.0) is not showing up, press the button that that a little line, that is located to the right of the dropdown menu.