Error while moving the PlayOnMac folder to an external drive

(2020 - MacOS Catalina - Extended MacOS filesystem)

Autor Odpowiedzi
federicoC Thursday 12 November 2020 at 13:46

Hello everybody, 

I've tried following the official PlayOnLinux guide for moving the PlayOnMac folder to an external drive, and followed the advice found in the forum (e.g. hereherehere, here, here ..mostly dated posts where the issue was solved by following the official guide), but nothing seems to be working, what happens is:

  • if I move and symlink the whole PlayOnMac folder, when I run PlayOnmac and confirm\reject my intention to send anonymous data, the process becomes completely irresponsibe until I kill it.
  • if I only move the wineprefix folder the app runs, but as soon as I try to intall a piece of SW, a modal saying Wine crashed will start popping up, blocking me to that step
  • in all cases, no files are written or edited in the symlink source folder placed on the external drive, opposite to what happens in the case I keep the folder in my local drive. If i navigate in and out the symlink with the Terminal, everything seems to be working fine, as I can succefully touch new and existing files.

My system is macOS catalina, the internal drive is one single APFS partition, while I tried to format the external drive both as a single MacOS Extended filesystem partition, and as an APFS partition inside a single disk container, but the problem is exactly the same.

Can anyone help me?

Thanks in advance.

particlefeever Saturday 24 April 2021 at 15:32

Well I am looking for an answer to this situation. I moved the folder, created the symlink, but the app does not follow it, as it seems. It just creates a new wineprefix folder instead and the games wont find their virtual disks.

It seems this issue is about newer PlayOnMac versions, there is a lot of tutorials but to older versions, years ago.

Hope somebody find an answer to this, this is a common task, is usual wanting to store games elsewhere than home.

xmarat Sunday 3 October 2021 at 18:07

I solved this problem like this:


1. * unmount external hdd


2. cd ~


3. mkdir hdd
* you can name the folder your way


4. diskutil list
* find your disk in the list and see its name, in my case it is /dev/disk4s2


5. sudo diskutil mount -mountPoint ~/hdd /dev/disk4s2
* here you need sudo (password) because normal user does not have permission to mount


6. cd ~/Library


7. mv PlayOnMac ~/hdd


8. ln -s /Users/username/hdd/PlayOnMac PlayOnMac


P. S. hope this helps someone

Edytowane przez xmarat