Eror Downloading D3DX9

Autor Odpowiedzi
orangbaru Friday 12 February 2021 at 19:45

when i try download d3dx9 on playonliux it just error.

An error happened during download


it just keep showing up. anyone have solution for this? i am new to linux, so ihope you guys can help me

Edytowane przez orangbaru

nicogarcia9881 Friday 19 February 2021 at 2:14

I'm getting this same error, never happened before. I haven't found any solution so far

rico1 Saturday 20 February 2021 at 17:24

The reason this is happening is that Microsoft have closed that link.  I got it from cnet :

BTW the POL install options using the old link could usefully be updated ....



suds45 Thursday 25 February 2021 at 18:51

I'm receiving the same or similar error, the file downloads but I'm receiving a file mismatch


Nominup Sunday 28 February 2021 at 1:29


Edytowane przez Nominup

Quentin PÂRIS Sunday 28 February 2021 at 20:08
Quentin PÂRISAnonymous

Which script are you talking about exactly? d3dx9 seems fine to me

suds45 Wednesday 10 March 2021 at 16:34

I'll attempt it again and let you know but any of the directx I attempted, downloaded the same file  (directx_Jun2010_redist.exe). The one I actually need is POL_Installd3compliler_47


Update: I attempted it again on March 10 and had same results

Edytowane przez suds45

james-cnz Saturday 13 March 2021 at 8:45

I'm getting the same error as suds45 (identical, same file name, same hash codes) when trying to install d3dx10 or d3dx11.  d3dx9 seems to install OK (although I haven't tried using it with anything).

Quentin PÂRIS Saturday 13 March 2021 at 13:42
Quentin PÂRISAnonymous

I fixed few of them yesterday

james-cnz Tuesday 16 March 2021 at 3:45

Hi Quentin,

I had a look here: but there don't seem to be any updates since Jan 25.  Have you not uploaded the fixes yet, or am I looking in the wrong place?


Quentin PÂRIS Tuesday 16 March 2021 at 9:14
Quentin PÂRISAnonymous

Looking at the wrong place :)

Changes are here:

james-cnz Friday 19 March 2021 at 23:15

OK, thanks.  I think I've got a bit further with this, but haven't solved it yet.  It looks like you've updated the d3dx9 and d3dcompiler_47 scripts, but not the d3dx10 or d3dx11 scripts yet.  I tried downloading the d3dx11 script and updating with the new hashsum, copying what you did with the d3dx9 and d3dcompiler_47scripts, then running the result via Tools > Run a local script.  I'm getting errors like this in the console, though:
POL_Download_Resource: command not found

master123 Saturday 3 April 2021 at 15:55

I also find the problem with the checksum of this one "POL_Install_dxfullsetup"
The file still download, but the warning mensage show up on PlayOnLinux.

I try at least 3 times with the same result on stable internet connection, don't look like a corrupted file download.. but i did not did a manualy checksum on the file.

Quentin PÂRIS Tuesday 6 April 2021 at 14:06
Quentin PÂRISAnonymous


james-cnz Thursday 8 April 2021 at 12:06

Thanks, it's working for me now.  :-)

alekseyst Friday 6 May 2022 at 12:31

Got a similar problem when installing Microsoft Office 2010.

The error: Error ! Files Mismatch occurred.

The link file was downloaded from:

Edytowane przez alekseyst