Fora

Dependencies for playonlinux?

Attempting to run on Alpine Linux

Autor Odpowiedzi
SugarRay Thursday 18 February 2021 at 2:53
SugarRayAnonymous

Hi. I'm a newbie to Alpine Linux and to Linux in general. I'm an amateur programmer and mobile and so mostly use my iPad and dowloaded the iSH app which is an x86 Alpine Linux emulator. It comes with the Alpine Linux package manager, and I can download multiple packages that way. Alpine Linux has a wine package, but it doesn't run in the emulator, so I'm trying to see if maybe playonlinux might. I downloaded the general distribution and tried to run the ./playonlinux executable file from there but got an error message about not being able to find python despite having multiple versions of python successfully installed in my Alpine Linux shell. I see on the internet that that error is common and multiple people have indicated that error is because I don't have one certain package or the other. I've added many of the packages people have mentioned on the web, but it still doesn't recognize that I have python installed. I suspect that might be because it depends on a specific package (e.g. wxPython) that I can't download yet from the Alpine LInux package manager since it is still in the testing phase at Alpine Linux. 

It would be helpful if a community member could point me to a list of know dependencies for playonlinux so that I can be sure I've downloaded them and perhaps wait until Alpine linux finishes testing any other additional package dependencies that I might need to successfully run playonlinux.

Thank you. 

Dadu042 Thursday 18 February 2021 at 8:55
Dadu042
Moderator

I hope this can help (it's for POL v4.3.4, on Kubuntu 18.04):



apt-cache depends playonlinux 
playonlinux
 Dépend: unzip
   unzip:i386
 Dépend: wget
   wget:i386
|Dépend: xterm
   xterm:i386
 Dépend: <x-terminal-emulator>
   kterm
   lxterminal
   vala-terminal
   deepin-terminal
   eterm
   gnome-terminal:i386
   gnome-terminal
   konsole
   lilyterm
   mate-terminal:i386
   mate-terminal
   mlterm
   mlterm-tiny
   pterm
   qterminal
   rxvt-unicode
   sakura
   stterm
   terminator
   terminology
   termit
   tilix
   xfce4-terminal
   xiterm+thai
   xterm:i386
   xterm
   xvt
 Dépend: python
|Dépend: <python-wxgtk2.8>
 Dépend: python-wxgtk3.0
 Dépend: imagemagick
   graphicsmagick-imagemagick-compat
   imagemagick:i386
   imagemagick-6.q16:i386
   imagemagick-6.q16
 Dépend: cabextract
   cabextract:i386
 Dépend: icoutils
   icoutils:i386
 Dépend: p7zip-full
 Dépend: curl
   curl:i386
 Dépend: jq
   jq:i386
 Est en conflit avec: <playonlinux-beta>

Edytowane przez Dadu042

SugarRay Friday 19 February 2021 at 2:46
SugarRayAnonymous

Perfect, Dadu042, I'll try all of those! :-)