Fora

Error launching PlayOnMac

Autor Odpowiedzi
Jump to the page: 1 - 2
wapimdv Tuesday 2 November 2010 at 18:17
wapimdvAnonymous

Hi !

I've just downloaded and installed PlayOnMac ver. 3.2 on a iMac with OS X 10.6.4 It seems to run ok, my apps (i.e. VisualSourcesafe) are working fine.. but everytime I launch PlayOnMac i get the error: PlayOnMac Error: Cannot set locale to es_AR ... I close this dialog box by clicking ok and I can launch apps without any other error.... Under PlayOnMac Settings -> System I get:

Your system :
Your kernel : Darwin 10.4.1
System language : es_ES.utf-8

wich is correct because Im in Spain and my system is spanish..... any idea ?

TIA !!!!


Quentin PÂRIS Tuesday 2 November 2010 at 22:35
Quentin PÂRIS
Admin

I'm really sorry, I tried to solve the bug but I can't reproduce it :-S

Can you type echo $LANG in a terminal ?
What are your system settings ?
wapimdv Wednesday 3 November 2010 at 8:35
wapimdvAnonymous

Hi !

the result of a echo $LANG is: es_ES.UTF-8
that's the same I get when I go to PlayOnMac Settings -> System

Thanks a lot you for your answer !!!

Greetings from BCN !


Quentin PÂRIS Wednesday 3 November 2010 at 11:20
Quentin PÂRIS
Admin

Everything seems to be ok

What is your system settings (Mac) in settings panel ?

Language and Place, (in format)

(BCN ?) :)
wapimdv Wednesday 3 November 2010 at 12:08
wapimdvAnonymous

In System Prefereces -> Languages Ive 1st selected: Language: Español (Spanish) and under Format: Region/Place: España (Spain)

Sorry... BCN = Barcelona.... (greetings from here.. hehehehe)

TIA
Quentin PÂRIS Wednesday 3 November 2010 at 12:14
Quentin PÂRIS
Admin

That's strange, with the same settings I can't reproduce the bug :-S

And PlayOnMac is usable ?
wapimdv Wednesday 3 November 2010 at 12:19
wapimdvAnonymous

yes it is !!!! in fact im running now a MsSourcesafe client without problem (please avoid comments about Soucesafe I know how bad it is... hehehehehehehe).... Actually I think PlayOnMac is a GREAT product and It runs fine ... the only trouble Ive found is this error dialog on launching...
Quentin PÂRIS Wednesday 3 November 2010 at 12:48
Quentin PÂRIS
Admin

That's weird.

Unfortunately, until I can't reproduce the bug, it will be very hard to fix it :-S

Is POM in english or in spanish ?
wapimdv Wednesday 3 November 2010 at 12:53
wapimdvAnonymous

It is in english... but some (a few) messages are in spanish....
Quentin PÂRIS Wednesday 3 November 2010 at 13:05
Quentin PÂRIS
Admin

What happen if you run

cd /Applications/PlayOnMac.app/Contents/MacOS/
./playonmac

in a terminal ?
wapimdv Wednesday 3 November 2010 at 14:34
wapimdvAnonymous

when I run such command I get in the console window:

./playonmac

cat: /Users/pep/Library/PlayOnMac/configurations/options/applex: No such file or directory
launch_msg("CheckIn") IPC failure: Operation not permitted
Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Xquartz: X11.app = /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11
Xquartz: Starting X server: /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11 --listenonly
X11.app: DISPLAY does not look like a launchd set variable, unsetting.
X11.app: main(): argc=2
     argv[0] = /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11.bin
     argv[1] = --listenonly
Waiting for startup parameters via Mach IPC.
X11.app: No launchd socket handed off, unsetting DISPLAY
X11.app: do_start_x11_server(): argc=1
     argv[0] = /Applications/PlayOnMac.app/Contents/Resources/playonlinux//../X11/opt/X11/bin/XQuartz
fakebuttons: Unknown modifier "comando"
Xquartz starting:
X.Org X Server 1.9.0.902
Build Date: 20101016
PlayOnMac repository need to be updated

and PlayOnMac GUI is started (with the error dialog 'Cannot set locale to es_AR') and then continues normally...
Quentin PÂRIS Wednesday 3 November 2010 at 14:46
Quentin PÂRIS
Admin

Ok,

I would try something else :

cd /Applications/PlayOnMac.app/Contents/MacOS/
export DYLD_LIBRARY_PATH="$PWD"
./playonmac.real

(It will prevent PlayOnMac from settings LANG variable, I want to see if it works better. Then, quit PlayOnMac because it won't be able to use XQuartz when you run it like this)
wapimdv Wednesday 3 November 2010 at 15:00
wapimdvAnonymous

Now Ive executed:
pep$ export DYLD_LIBRARY_PATH="$PWD"
pep$ ./playonmac.real

and I get:

launch_msg("CheckIn") IPC failure: Operation not permitted
Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Xquartz: X11.app = /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11
Xquartz: Starting X server: /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11 --listenonly
X11.app: DISPLAY ("/tmp/launch-2OE7uu/org.x:0") does not match our id ("org.macosforge.xquartz"), unsetting.
X11.app: main(): argc=2
     argv[0] = /Applications/PlayOnMac.app/Contents/Resources/X11/Applications/Utilities/PlayOnMac XQuartz.app/Contents/MacOS/X11.bin
     argv[1] = --listenonly
Waiting for startup parameters via Mach IPC.
X11.app: No launchd socket handed off, unsetting DISPLAY
X11.app: do_start_x11_server(): argc=1
     argv[0] = /Applications/PlayOnMac.app/Contents/Resources/playonlinux//../X11/opt/X11/bin/XQuartz
fakebuttons: Unknown modifier "comando"
Xquartz starting:
X.Org X Server 1.9.0.902
Build Date: 20101016
another window manager is running; exiting

the POM GUI is started and the dialog error is still show. :-(

Quentin PÂRIS Wednesday 3 November 2010 at 15:36
Quentin PÂRIS
Admin

Ok ..., so the problem does not seem to come from PlayOnMac.

What

defaults read -g AppleLocale

in a terminal answers you ?
wapimdv Wednesday 3 November 2010 at 15:40
wapimdvAnonymous

This is what i get:

pep$ defaults read -g AppleLocale
es_ES

Quentin PÂRIS Wednesday 3 November 2010 at 15:46
Quentin PÂRIS
Admin

It's strange. There is no reason why python tries to find es_AR


Try this :

cd /Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale
ln -s es es_AR

Then, restart PlayOnMac
wapimdv Wednesday 3 November 2010 at 16:08
wapimdvAnonymous

After executing ln -s es es_AR :

pep$ ls
ar          es          it          pt          sv
ast          es_AR          ja          pt_BR          templates
cs          fi          ko          ro          tr
da          fr          lt          ru          uk
de          he          nl          sk          zh_CN
el          hu          pl          sr

then restarting POM and ... same result... i get the cannot set locale error... then continues normally...
Quentin PÂRIS Wednesday 3 November 2010 at 16:38
Quentin PÂRIS
Admin

Really I don't understand ...

Can you post a screenshot of the window error ? Maybe it could help me
wapimdv Wednesday 3 November 2010 at 17:00
wapimdvAnonymous

Here there are 2 screenshots:

first:



and then:



Quentin PÂRIS Wednesday 3 November 2010 at 17:16
Quentin PÂRIS
Admin

Very strange.

How long have you used PlayOnMac ?
Jesteś tutaj: Index > > Error launching PlayOnMac