Fora

Guild Wars

Des amateurs?

Autor Odpowiedzi
Jump to the page: 1 - 2 - 3
tycale Wednesday 25 July 2007 at 14:37
tycaleAnonymous

http://img249.imageshack.us/my.php?image=capture1nc8.png

Voilà, toujours pas de pointeur et c'est assez moche. Regardez par vous même...
Aymeric P. Wednesday 25 July 2007 at 18:47
Aymeric P.
Admin

Ah oui en effet !
Essaye de mettre les effets graphique au minimun

Former member.
mectx Wednesday 25 July 2007 at 22:35
mectxAnonymous

bonsoir moi ça marche plus de soucis de touche (falait juste touché aux options)
par contre moi j'ais des bugs de texture quand suis loin de certains objet (screen a venir)
vonklichten Saturday 28 July 2007 at 0:59
vonklichtenAnonymous

Bonsoir. J'ai installé GW sous ma debian a l'aide de wine et de vos script trés pratique et qui rende ça trés simple. Mon problèmes viendrais plustot de l'ips qui dépasse pas les 14 ... et ce malgré tous les détails graphiques au minimum alors que la configuration du Pc doit accepter plus j'en suis sur (amd 2400+ avec une FX 5600 256Mo et 1 Go RAM) La carte graphique est installer correctement beryl fonctionne trés bien même si c'est pas top en même temps que les jeux

la version de wine que j'utilise est la 0.9.36

la version est elle mauvaise ?
ou il y a un réglage préci à apporter ?

Merci.
Gkar Saturday 28 July 2007 at 19:06
GkarAnonymous

Bonjour,

bon dans mon cas ca marche pas ... beau plantage et avec consommation effréné de CPU !!

Pour info :

ubuntu 7.04 AMD 64
Wine 0.9.41 version Dépot
Nvidia 6600 GT avec drivers 1.0-9631
Noyaux

Je fais tourner habituellement Beryl mais dans ce cas j'ai préféré le desactivé.

Quelqu'un a t il une idée ?? une version de drivers peut etre ?
mectx Wednesday 1 August 2007 at 10:42
mectxAnonymous

petit up pour vous dire que sous wine0.9.42 plus aucin bug a part la souris capricieuse mais c'est rien du tout
vonklichten Wednesday 1 August 2007 at 22:05
vonklichtenAnonymous

J'ai beau avoir fait une mise à jour vers la version 0.9.42 je n'ai pas constaté d'amélioration sur les perfromances du jeux, je suis toujours entre 15 et 17 ips

donc le problème reste entié
lateo Friday 10 August 2007 at 23:25
lateo

Gkar> tu veux dire au lancement? ça m'arrive par fois ; j'ai rien trouvé de mieux que killer le proc et relancer... jusqu'à ce que ça passe, ce qui peut etre long ^^ (le pire pour moi ça a du etre 5 ou 6 lancements avant que ça passe)
à noter que ça passe bcp mieux depuis la 0.9.42

von> c'est bizarre ton truc, p'tet tu devrais poster les détails ailleurs dans le forum pour avoir un peu d'aide.


bon, j'vais tester avec la 0.9.43
helijah Friday 17 August 2007 at 17:50
helijah

bonjours,
J'ai néanmoins un petit bug un peu embêtant visiblement mon clavier est mal reconnus pendant que je joue:
quand j'écris dans la fenêtre de chat pas de soucis AZERTY pawa.
Par contre quand je veux utiliser AZES pour bouger (vieux reste de Fps et quasiment obligatoire en pvp pour éviter les coups... ) je me retrouve avec les touches n'importe comment un mix de qwerty mais avec le w qui correspond a x enfin n'importe quoi. Si quelqu'un a un retour (une moddif de Xmod map?)

Quote from mectx


Hé hé c'est le seul problèle auquel j'ai eu à faire face avec GW. Mais résolu en 3 minutes en allant des la configuration du jeu et en donnant les bonne touches au bonnes actions Ni plus ni moins

Amicalement Emmanuel
papygourbi Tuesday 28 August 2007 at 19:52
papygourbi

ca y ai j y joue aussi sans probleme a GW.
je suis sous ubuntu feasty, drivers video nvidia natifs installé avec envy pour ma geforce 5600. et wine 0.9.44

P4 1.5 Ghz - 1Go Ram - Nvidia geforce 5600 - drivers via envy
ubuntu feisty 7.04
wine 0.9.44
PlayonLinux 1.7.5
Aymeric P. Wednesday 5 September 2007 at 15:21
Aymeric P.
Admin

Salut a tous,
J'ai apporté quelques petites modificationssur le script de GW, lors de l'installation.
Qui permettentde supprimer le "kill" sur le processus (ce qui fait aussi que le jeu ne risque pas de se lancer en freezant lors de l'installation)

EDIT 2 :
Voilà le script modifié, il est disponible là : Version ok (passe par mes tuyaux) ou là : Version ok (normalement c'est le bon cette fois çi)
J'utilise des clefs de registre (qui sont inclues dans le fichiers zip, et pour des problèmes d'espace (qui m'ontun peu pris la tête) du coup le jeu se retrouve dans c:\\GW\\GW.exe (enfin précisement dans ~/.PlayOnLinux/wineprefix/GuildWars/drive_c/GW/Gw.exe)
le lanceur est créé avec l'option -dsound (par une subtilité biscornue, mais a priori ça fonctionne !)
Avant dernière chose, ne soyez pas surpris de ne plus voir de fenêtre de Guild Wars pendant l'installation, c'est moi (enfin le bash, le script quoi) qui fait tout (comme un grand)

Dernière chose, (@tinou, @goku) je n'ai pas eu le temps de me relire sur les phrases donc il se peut qu'il y ai des "pheautes de phrenssé" où des phrases qui ne veulent rien dire

FIXME : Il semblerait que les scripts une fois téléchargés subissent des modifications au niveau des \\ lorsqu'il y a des "
A confirmer, notamment au niveau des jeux basés sur des clefs de registre ! (faire un grep .reg * dans le dossiers jeux)[/color]

edit Controlsetup: efféctivement, il y a des fautes ;-)

Edytowane przez Controlsetup


Former member.
Aymeric P. Thursday 6 September 2007 at 22:48
Aymeric P.
Admin

Bon le script a été mis a jours sur le serveur, il est fonctionnel, on peu jouer ça marche nickel
Mais je vient de repérer une bourde, la ligne creer_lanceur, il faut remplacer -nosound par -dsound
J'ai mis nosound car chez moi si je mais le son ça plante, mais (heureusement) c'est pas tous le monde comme ça (de toute façon au niveau matos, j'ai jamais de bol moi, de la CG, a la carte son en passant par les disques ...)
Donc voilà.

ATTENTION : Tout les scripts qui on un truc qui touche au registre (peut être pas tous, mais beaucoup, je n'ai pas la liste précise (pas encore)), on subis une défiguration (ou on mal été écrit je ne sais pas), ce qui a pour effets de rendre les fonctions de registre inefficace (le script de GW n'en fait pas parti, car la clef registre est dans le .zip)
Par exemple, pour le script de HalfLife1, ceci est fait :
48 echo "[HKEY_CURRENT_USERSoftwareWineX11 Driver]" > $REPERTOIRE/tmp/managed.reg
49 echo ""Managed"="N"" >> $REPERTOIRE/tmp/managed.reg
50 regedit $REPERTOIRE/tmp/managed.reg

au lieu de ceci (enfin a approximativement car je connais pas ce qu'il doit être écrit) !

48-1 echo REGEDIT > $REPERTOIRE/tmp/managed.reg
48-2 echo "" >> $REPERTOIRE/tmp/managed.reg
48 echo "[HKEY_CURRENT_USER\\\\Software\\\\Wine\\\\X11 Driver]" >> $REPERTOIRE/tmp/managed.reg
49 echo "\"Managed\"=\"N\"" >> $REPERTOIRE/tmp/managed.reg
50 regedit $REPERTOIRE/tmp/managed.reg

car le fichiers .reg qui doit être utiliser doit contenir ça
REGEDIT4

[HKEY_CURRENT_USER\Software\Wine\X11_Driver]
"Managed"="n"

Edytowane przez MulX


Former member.
Quentin PÂRIS Friday 7 September 2007 at 9:14
Quentin PÂRIS
Admin

Non

Il y a une commande PlayOnLinux

[code=console]Set_Managed On | Off[/code>

Lool
Aymeric P. Friday 7 September 2007 at 10:43
Aymeric P.
Admin

Ok pour le Set_Managed ON/Off mais dans le script de HalfLife1 c'est pas utilisé.
Prend le script de ElderScroll4_Oblivion vers la ligne 40
Il y a ça :
Set_Managed "On"
Set_DXGrab "On"
Set_GLSL "On"

tout ça ca fonctionne car le code de registre est inclus dans POL (au plus profond de lui), par contre ce qui est apres ne peut pas marcher.
echo "[HKEY_CURRENT_USERSoftwareWineDirectSound]" > $REPERTOIRE/tmp/directsound.reg
echo ""DefaultBitsPerSample"="16"" >> $REPERTOIRE/tmp/directsound.reg
echo ""DefaultSampleRate"="44100"" >> $REPERTOIRE/tmp/directsound.reg
echo ""EmulDriver"="Y"" >> $REPERTOIRE/tmp/directsound.reg
echo ""HardwareAcceleration"="Emulation"" >> $REPERTOIRE/tmp/directsound.reg
regedit $REPERTOIRE/tmp/directsound.reg
echo "[HKEY_CURRENT_USERSoftwareWineDrivers]" > $REPERTOIRE/tmp/drivers.reg
echo ""Audio"="alsa"" >> $REPERTOIRE/tmp/drivers.reg
regedit $REPERTOIRE/tmp/drivers.reg
echo "[HKEY_CURRENT_USERSoftwareWineDirect3D]" > $REPERTOIRE/tmp/d3d.reg
echo ""OffscreenRenderingMode"="fbo"" >> $REPERTOIRE/tmp/d3d.reg
echo ""PixelShaderMode"="enabled"" >> $REPERTOIRE/tmp/d3d.reg
echo ""VertexShaderMode"="enabled"" >> $REPERTOIRE/tmp/d3d.reg
regedit $REPERTOIRE/tmp/d3d.reg

Car il manque des "\" (au moins pour les [HKEY_****] )
prend l'exemple que j'ai donnée au dessus est fait un essai tu verra, que le premier cas ne plait pas a regedit
regedit: setValue failed to open key HKEY_CURRENT_USERSoftwareWineX11 Driver

Edytowane przez MulX


Former member.
Znuf Sunday 9 September 2007 at 18:38
ZnufAnonymous

bonjours tous le monde.

Je viens d'installer Gw sur une config fraiche d'ubuntu Feisty et ça marche super bien. ou presque.

Détaille a fond, ombres. tout est bon sauf le son...

J'ai regardé par ci par là, mais je ne sais pas comment m'y prendre. j'ai lu qu'il fallait rajouter -dsound mais ou?

Et j'utilisais le -image pour mettre a jour mon jeu sous windows, ici sous linux, quand je modifie mon raccourcis, il ne se passe rien. le jeu se lance normalement.

Merci de votre aide et votre excellent travail.

[résolu]


En cherchant un peu j'ai trouvé se répertoire :
/home/user/.PlayOnLinux/configurations/installed

Il y avait le fichier guildWars qui contenait

#!/bin/bash
export WINEPREFIX="/home/user/.PlayOnLinux/wineprefix/GuildWars"
export WINEDEBUG="-all"
cd "/home/user/.PlayOnLinux/wineprefix/GuildWars//drive_c/GW/"
wine ""Gw.exe -nosound""


J'ai créé deux autre fichier :

GuildWars_Sound

#!/bin/bash
export WINEPREFIX="/home/user/.PlayOnLinux/wineprefix/GuildWars"
export WINEDEBUG="-all"
cd "/home/user/.PlayOnLinux/wineprefix/GuildWars//drive_c/GW/"
wine ""Gw.exe -dsound""


GuildWars_MàJ
#!/bin/bash
export WINEPREFIX="/home/user/.PlayOnLinux/wineprefix/GuildWars"
export WINEDEBUG="-all"
cd "/home/user/.PlayOnLinux/wineprefix/GuildWars//drive_c/GW/"
wine ""Gw.exe -image""


Voilà ^^.

Le son est un peu haché mais c'est p-e a cause du download.

Edytowane przez Znuf

Quentin PÂRIS Sunday 9 September 2007 at 18:55
Quentin PÂRIS
Admin

Merci pour l'astuce :-)
Znuf Monday 10 September 2007 at 10:44
ZnufAnonymous



Il manque juste l'anti aliasing pour que se soit parfait. Mais je chipote.

Wine 0.9.44
Ubuntu 7.04 "Compiz-Fusion activé"
Geforce go 7600
Core Duo 1.8ghz
2048 de ram

Edytowane przez Znuf

Nibeck Monday 24 September 2007 at 21:56
NibeckAnonymous

Test OK sur l'install
Pour les parametres technique de ma configurations voir signature

Comme beaucoup, les graphique pour ma part son devenu tout pale, meme en augmentant le rendu

pour le probleme de souris faire plusieurs clique droit et on le récupére

Probléme aussi d'IPS mais du à la carte graphique ati, je pense

Voila

Encore merci à la team pour ce programme

Nibeck

PCLINUXOS 2007
Guild Wars
Wine 0.9.45-1
Ati Radeon Xpress 200M
Harmy Wednesday 26 September 2007 at 13:07
HarmyAnonymous

J'ai réussi a faire fonctionner le son, mais il a juste un décalage par rapport à l'image et il y a des bugs d'affichage de certains éléments qui se changent en carré qui disparaissent quand on s'approche.

Wine 0.9.45
Ubuntu Feisty Fawn
GeForce 7600GT

Edytowane przez Harmy

dlzerocool Wednesday 26 September 2007 at 18:34
dlzerocool

Chez moi le son ne marche pas, mais le jeu marche très bien. J'ai pourtant rajouté -dsound et configuré wine......

Wine 0.9.45
Ubuntu Feisty Fawn
GeForce 7600GT

Quote from Harmy


Vérifie ta configuration GW avec playonlinux -> expert -> config -> GuildWars.
Dans audio tu as peut-être OSS si tel est le cas vérifie que tu n'as pas d'autre application qui utiliserais OSS comme skype ou teamspeak.
Tu peux également passer en Alsa << (décocher OSS et cocher Alsa)
En alsa essaye l'acceleration materiel compléte, et sinon essaye en émulation. Et au pire
coche la croix de l'émulation.
Bref tu as de quoi t'amuser un moment ^_^.

Sinon essaye avec wineversion une autre version de wine pour jouer à GW.

Bon jeu!

Drum & Bass - Dev - Beer and more... What else ?
Jesteś tutaj: Index > PlayOnLinux > Guild Wars