Fora

Empire Earth I - script

Wine mouse not working

Autor Odpowiedzi
realta_taisteal Thursday 12 January 2012 at 0:17
realta_taistealAnonymous

Wine version: 1.3.36
Distribution: Suse 12.1 updated
POL: 4.0.14
Graphics card: Nvidia, geforce 9800gt
Graphics card driver: updated

Comments:

Petch and myself have a working script. With the latest version of wine, it has sound and maybe music. I'v tried to make a modified wine to fix it, but have been unsuccessfull.

The mouse movement is based on the speed you move it. I'v been unable to find where wine sends it's data to EE. No, it's not "mouse.c". Why I haven't a clue. Anyone else know about wine-linux mouse coding.



realta_taisteal Sunday 15 January 2012 at 3:17
realta_taistealAnonymous

See this link for complete notes:

http://forums.opensuse.org/english/other-forums/development/programming-scripting/470918-empire-earth-i-playonlinux-wine-mouse-fix-code-opensuse-12-1-kde-64bit.html

My logic should be right. Anyone else feel free to comment. I'm stuck. :p



petch Tuesday 17 January 2012 at 12:00
petch
Developer

From what I remember from mouse pointer behavior in EE1, it's not only slow but also "erratic": if you move the mouse slowly, the pointer may not move at all, or just sometimes...
I'm not sure that just adding a multiplier will solve this kind of issue, I feel that it could only solve "linear" issues.
Either the game somehow "loses" mouse events, and something totally different is needed, or at best there's a division somewhere that filters out too small mouse movements, and the depending on whether it happens before of after your multiplication, it may or may not be solved that way... Dealing with integers, 20 * (1 / 20) = 0...
I'm just as clueless as you about how mouse support works, that's just my thought about this problem "as a black box"...

Edytowane przez petch

realta_taisteal Tuesday 17 January 2012 at 21:22
realta_taistealAnonymous

Large fast movements move the mouse small amounts. I also get random mouse clicking. Windows handles the mouse movement. So, wine can. It just doing the emulation wrong.

I can't get in or out going mouse values. So, I can't find the problem. I need to make changes to the downloaded POL wine and recompile it. No changes are doing anything. I have to figure out why that isn't working first.

Jesteś tutaj: Index > > Empire Earth I - script