Jesteś tutaj


League Of Legends

Autor Odpowiedzi
Jump to the page: 1 - 2 - 3 - 4 - 5
samiscool30 Tuesday 15 May 2012 at 23:07

Wine version: 1.5.3
Distribution: Ubuntu
Distribution version: 11.10
When I start League of Legends it starts out fine, then when i either decide to spectate or play a game, a black sqaure is in the middle of my screen where the League of legennds logo is supposed to be appears.  Nothing happens at all i left it there at time but it still doesn't do anything.
extbase Sunday 20 May 2012 at 21:08

Wine version : 1.5.3-LeagueOfLegends
Distribution: Ubuntu
Distribution version: 12.04
For me the installation of League Of Legends worked fine.(testing beta script). i could join a game and had no problems (except from poor frame rate of 15-20) yesterday.
But today the gamelauncher first time crashed and from then on is stuck on "calculating differences"...

edit: restarting the launcher a couple of times solved the problem.
so only problem that is still there: shop does not load and poor frame rate. anybody any tips for fixing this?

Edytowane przez extbase

titibandit Wednesday 23 May 2012 at 11:49

Wine version : 1.5.3-LeagueOfLegends
Distribution: Ubuntu
Distribution version: 12.04
Just like extbase, everything is fine, except the shop which doesn't appear at all, no matter how long you wait for it, and poor framerate. The game indicates a 30~40 FPS (I'm 60 FPS constantly in windows) but It appears to me really poor for a 35 FPS, I would say it is only 20 FPS.
Could we know what patches, fixes, etc ... the 1.5.3-LeagueOfLegends wine version did receive ? Because on wineapp db, there is a whole bunch of patch you could apply to makes things better (especially concerning the FPS issue), but I can't figure out what has been done on this wine version.
Also, a little trick to gain some FPS (found on wineapp db) : when the game is launched, you can run this command : taskset -p 1 1234

where "1234" is the process number (PID) of the "League of Legends.exe". You can get the PID with a proccess explorer or just with the command: pidof "League of Legends.exe".
Thanks a lot !
titibandit Friday 25 May 2012 at 10:53

Another way of increasing the FPS
Use metacity instead of compiz !
Juste before lauching a game, open a terminal en launch : metacity --replace

Afterwards, you can go back and launch : compiz --replace to get back compiz !
parpel Saturday 26 May 2012 at 23:32

Wine version : 1.5.3-LeagueOfLegends
Distribution: Archlinux

The installation worked fine but I can't login :(
I got the error "Connection Failure: Unable to connect to the server."

Any of you have the same problem?

titibandit Sunday 27 May 2012 at 12:13

Yes I had the same problem, each time I try to log in I get this error, but trying a second, or a third time and I succed to log in.
parpel Sunday 27 May 2012 at 17:22

It has not worked. I tried to log in several times and nothing happened.
psytic Wednesday 30 May 2012 at 11:45

Same thing I can't login the server is busy. Does the 1.5.3 Wine distro have Gnutls in it?
Quentin PÂRIS Wednesday 30 May 2012 at 12:46
Quentin PÂRISAnonymous

Nope for GNUTLS. Wine is compiled to support it, but you have to have it installed on your system (32bits lib)
psytic Wednesday 30 May 2012 at 13:37

K so I tried it with the new 1.5.5 Wine on PlayonLinux and it works but then runs into the degrading frame rate issue since it is unpatched. I then tried it with 1.5.3 lol-patched again and it still doesn't go past login so there is something inbetween the two versions that is different ( I don't know anything about Linux I just know the new wine version seems to work). Any chance of a 1.5.5-patched wine being uploaded to playonlinux?
Quentin PÂRIS Wednesday 30 May 2012 at 19:24
Quentin PÂRISAnonymous

What about 1.5.3 heap_allocation_v2 avoid deadlock?
psytic Thursday 31 May 2012 at 2:12

What about 1.5.3 heap_allocation_v2 avoid deadlock?

Quote from Tinou

This one gets past login to, so I guess it is just the 1.5.3-lol one that doesn't work for me. The store doesn't work on this one or 1.5.5 but the fps seems rock solid on the 1.5.3 heap_allocation_v2 avoid deadlock one.

Edytowane przez psytic

nicoxxl Monday 25 June 2012 at 21:58

parple: I've the same bug.
I can't connect to, it's a fresh install with a script, I'm on archlinux 32bit with gnutls.
nicoxxl Monday 25 June 2012 at 22:48

For store, use a friend's computer!

Edytowane przez nicoxxl

nicoxxl Monday 25 June 2012 at 23:05

I try with:
* 1.5.3-LeagueOfLegends
* 1.5.3
* 1.5.3-heap_allocation_v2-avoid_deadlock
* 1.4
* 1.5.0
* 1.5.2
* 1.5.5-LeagueOfLegends
* 1.5.7
And nothings works!
I don't know how can I help, please tell me!
(I make a new topic on french forum)

Edytowane przez nicoxxl

iamoverrated Monday 30 July 2012 at 8:33

Having the same problem - Running on Mageia 2 32bit with GnuTLS installed and I keep getting the login error. Is there a workaround or are we forced to compile from source?
zanches Wednesday 8 August 2012 at 21:54

installing "IE6" by the Playonlinux the store appears.
drfred79 Thursday 9 August 2012 at 1:26

I've tried WINE 1.5.5-LeagueofLegends 32bit and 1.5.3-heap_allocation_v2-avoid_deadlock 32bit I am running Ubuntu 12.10 During the load game screen after a successful queue the characters aren't shown, neither are pings. Then when the real game is about to start League of Legends crashes. Is there a better tutorial for me to tweak setting on PlayOnLinux so that I can get the game to work and then make it run well?
petch Thursday 9 August 2012 at 1:29

drfred79: did you use the installation script?
drfred79 Thursday 9 August 2012 at 2:17

drfred79: did you use the installation script?

Quote from petch

Thanks for your quick reply.  I assume I haven't.  My steps have been, from a clean install of Ubuntu:

Install Playonlinux
Switch Wine to Windows 7
Download Multiple versions of WINE
Install League of Legends
Try Multiple WINE environments.

If you can direct me to the installation script I will attempt to run it.
Jesteś tutaj: Index > > League Of Legends