Fora

League of Legends - LOW FPS?

Autor Odpowiedzi
Jump to the page: 1 - 2
sebastian Wednesday 11 July 2012 at 10:16
sebastianAnonymous

I installed LoL from the testing section and everything works  pretty well as advertised except the FPS is always at like 11ish. Which makes it pretty impossible to play :(

Anyone know of a fix?
Deleted Wrong topic
xpander Thursday 12 July 2012 at 21:03
xpander

tell us ur hardware and drivers u are using.

i myself running all high(including shadows) anmd getting 60 fps cap all the time..except rare occaions in bigger mass battles drops to 45 or so.

Processor:AMD Phenom II X4 955 , ~3.2GHz
Memory:8 GB (2x4GB) DDR3 Kingston Hyper-Z (1600Mhz)
Hard Drive:1TB WD + 320GB Seagate +160GB WD
Video Card:Asus Geforce 560 Ti DirectCU 1GB - nvidia 302.17 prop drivers
Monitor:     ViewSonic VA2431 24" + LG Flatron L1953S, 19"
Sound Card:Realtek ALC889
Operating System:Linux Mint 13 64bit, MATE Desktop Environment, kernel 3.2..0-lowlatency
Motherboard:Gigabyte GA-970A-D3
Computer Case:Compucase Silver/Black, 650W Chieftec
LightBuster Friday 20 July 2012 at 8:22
LightBusterAnonymous

I also have the same problem. I've installed it like two months ago and everything was fine, but about a week ago I've been experiencing a very, VERY, low FPS ingame. At best 8 FPS.

I'm running it on two machines, over Kubuntu 12.04.

First on a Apple MacBook Pro 5.1:
     Processor: Intel Core 2 Duo P8600 (2.4Ghz)
     Memory: 4GB (2x2GB) DDR3 1066Mhz
     Hard Drive: 320 GB Toshiba HDD
     Video Card: NVidia 9600GT 512MB + NVidia 9400M - nvidia 295.40 propietary driver
     OS: Kubuntu 12.04 64bit, KDE 4.8.4, kernel 3.2.0-26-generic

And the second machine is a desktop generic computer with:
     Processor: AMD Phenom II B60 ~ 3.5 GHZ (O.C.)
     Memory: 4GB (2x2GB) DDR3 1536Mhz (O.C.)
     Hard Drive: 2.3 TB LVM setup
     Video Card: ATI Radeon HD 4290 with ATI propietary drivers
     OS: Kubuntu 12.04 64bit, KDE 4.8.4, kernel 3.2.0-26-generic
     Motherboard: ASUS M4A89GTD PRO

On both setups I've experienced the same very low FPS issue, so, I guess, it's not a hardware problem... I've been experimenting a bit with packages and plasmoids, so it could be a dependency problem, but I have no error report.

Thanks for helping us.
xpander Saturday 21 July 2012 at 9:48
xpander

ur mac hardware is fine and should be able to play with better fps. so probably some issue with ur desktop environment or similar.
i installed the game about 2 months ago also and havent experienced any framrate drops with the latest updates of the game.

ur second machine however has ati card, which is known to have issues under linux with wine.
deini Monday 23 July 2012 at 9:19
deiniAnonymous

I got the same problem, just installed today. Getting 20-30s when in Winlol I get constant 60

Hers my info
Ubuntu 12.04 64 bit
AMD FX(tm)-8120 Eight-Core Processor × 8
16 GB DDR3
Nvidia GForce 570 GTX
Drivers: nvidia-current

xpander Tuesday 24 July 2012 at 18:47
xpander

unity desktop with 3d stuff enabled?

i myself running MATE desktop without compiz..
maybe try unity without compiz (without 3d) if thats possible.
LightBuster Thursday 9 August 2012 at 15:44
LightBusterAnonymous

I've found that turning off KWin effects the game runs a bit more smoothly, although it is still on the 10FPS mark.
petch Thursday 9 August 2012 at 16:28
petch
Developer

As I said in another (less well named) thread,
There's tons of tips in the AppDB already:
http://appdb.winehq.org/objectManager.php?sClass=version&iId=19141
Look for "Increasing FPS"
gotoone Saturday 11 August 2012 at 12:44
gotooneAnonymous

Petch The tutturiol that is there does not work proplerly for some reason League of Legends.exe is not found. And yes i have i running... The next thing i tried was the command:
ps aux witch still didnt show it running the only exe i seen was the lollauncher.exe with i was logged in and is a test match to check if changing that to one core worked the launcer.exe.

Shure would be nice to get it at 60fps
gotoone Saturday 11 August 2012 at 12:47
gotooneAnonymous

Nothing seems to work!!!!!!!

Scripteur Try this out for us its in test packeges for simple installasion?
gotoone Monday 13 August 2012 at 13:23
gotooneAnonymous

ok so ive just gave up this game has a season 3 so another year someone will get this and post a tut when its stable. I do get crashing the video driver have to command restart pc as its all bugged up.
xpander Saturday 18 August 2012 at 8:15
xpander

strange issues u getting there.. never experienced those..probably u have something wrong in ur system (drivers and whatnot)
to increase framerate a little u can try to run regedit of ur LoL wine and add the UseGLSL disable.(works with nvidia and prop drivers only afaik)

head to winehq wiki how to do it in regedit
petch Saturday 18 August 2012 at 9:40
petch
Developer

You can change that setting straight from POL interface:
Configure button > (select virtual drive) > Display tab > GLSL Support: disabled
MLTN Wednesday 22 August 2012 at 20:11
MLTNAnonymous

One of the solutions (and the one that worked for me) is to DISABLE SHADOWS, DISABLE VERTICAL SYNCHRONIZATION(or something like that) and put the FPS in HIGH, in the video options on the in-game window.
As you I was getting 5-8 fps and without shadows and stuff I get 40-50 fps. Though I've got another problem already reported: http://www.playonlinux.com/en/topic-9095.html :/ I can see the "silhouettes" only, at 40-50 fps...
Good luck!
MLTN
gotoone Thursday 23 August 2012 at 5:24
gotooneAnonymous

Ive dont all those up there except disable glsl witch iam on ati so i guess if it is there it wouldnt change a thing. 40-50 still isnt my smooth 60fps thats on windows witch takes me a min to swtch over so when this does get to 60fps good. Vertical sync must be on with ati dont really know why
sebastian Saturday 25 August 2012 at 6:52
sebastianAnonymous

I went to attempt some of your suggestions, but now I have a new issue that MLTN mentioned. I posted in his thread about it though. I may have to come back to see if any of these work once I can actually see whats going on in the game :)
gotoone Sunday 26 August 2012 at 0:35
gotooneAnonymous

My grammer looks bad but anyways im going to reinstall all this and give it another shot!
Im running Ati radeon hd 4200 driver 11.8 Ubuntu 32bit 10.10 was running 20-30 max fps going to try disable glsl if that dont work ill figure out the one core pid run app try that then if that dont work ill try update my video driver come back here and just keep posting!
gotoone Sunday 26 August 2012 at 0:38
gotooneAnonymous

Amd 64x2 6000+
4gb ram

Pc getting outdated fast!
gotoone Sunday 26 August 2012 at 7:02
gotooneAnonymous

Nothing fixed fps tried disable glsl, found the pid finnaly as windowed mode has to be on and ps aux command dosnt find the pid so you have to use pid of "League of Legends.exe" finnaly last not least tried updating video driver to 12.6 from 11.8 and very buggy so slow i didnt even give the game a chance to run. Didnt try tinkering with compiz