Форум

Playonlinux 4.1.9 fails after downloading packages for install

Traceback (most recent call last):

Автор Replies
ikunat33 Thursday 21 February 2013 at 19:17
ikunat33Anonymous

Hey,


New to all this and I need some help.

I installed Python2.6 and wxPython2.8 in Ubuntu 8.04 from source in order to get Playonlinux working.

Well it works right up until it finishes downloading the appropriate
wine to install for my game and then I get the following again and
again:


Traceback (most recent call last):

  File "/usr/share/playonlinux/python/guiv3.py", line 275, in TimerAction

    self.gauge.SetValue(self.downloader.nb_blocs)

  File "/opt/python2.6/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 900, in SetValue

    return _controls_.Gauge_SetValue(*args, **kwargs)

wx._core.PyAssertionError: C++ assertion "pos <= m_rangeMax"
failed at ../src/gtk/gauge.cpp(94) in SetValue(): invalid value in
wxGauge::SetValue()

Traceback (most recent call last):

  File "/usr/share/playonlinux/python/guiv3.py", line 275, in TimerAction

    self.gauge.SetValue(self.downloader.nb_blocs)

  File "/opt/python2.6/lib/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 900, in SetValue

    return _controls_.Gauge_SetValue(*args, **kwargs)

wx._core.PyAssertionError: C++ assertion "pos <= m_rangeMax"
failed at ../src/gtk/gauge.cpp(94) in SetValue(): invalid value in
wxGauge::SetValue()



Suggestions?


Thanks,


Sean.

     
     
     
     
booman Friday 22 March 2013 at 0:39
booman

You might want to try using a newer version of Ubuntu
How are you installing PlayOnLinux? from a Package Manager GUI or sudo apt-get?

From your error I'm guessing sudo apt-get

Are you following all of the recommended instructions from the website?
Ubuntu PlayOnLinux download

† Booman †
Mint 19.3 64-bit | Nvidia 450 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Friday 22 March 2013 at 5:38
Ronin DUSETTE
Admin

I would for SURE recommend upgrading to at least 12.04. There are a lot of fixes since that release.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Friday 22 March 2013 at 5:39
Ronin DUSETTE
Admin

I would be willing to be the correct versions of those are not available on your version, which is probably why you compiled from source, correct?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts