Вы находитесь здесь

Форум

Warframe problem on pol

Автор Replies
Levan Wednesday 25 February 2015 at 1:49
Levan

Ok I have a problem with warframe on pol but not on system wine. On pol warface launcher crashes even after I install ie8 but on system wine I do not need to install anything and the launcher does not crashes and you can play the game.

 

Here is the system wine terminal output

http://paste2.org/_pYJcsMM5

here is pol output

http://paste2.org/_gdw5Kphm

last two lines

[0225/043930:ERROR:audio_output_device.cc(261)] IO loop going away before the audio device has been stopped

fixme:advapi:UnregisterTraceGuids 0: stub

 

Both are 32 bit

 

Is there a way to fix this ???

 

 

Ronin DUSETTE Wednesday 25 February 2015 at 2:04
Ronin DUSETTE
Admin

What version is your system wine?

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Levan Wednesday 25 February 2015 at 12:11
Levan

What version is your system wine?

[POL_Wine] [1;34mMessage:[0m Wine return: 0
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

 

again all of this works on system wine without any problem

 

 

One more interesting thing, If i triy to run warframe.msi installer in a prefix where steam is installed I do not know why but it works . so what are the changes that steam script does to prefix ??

Edited by Levan

booman Wednesday 25 February 2015 at 23:27
booman

Are you able to run any other games in Linux?

Do you have the 32-bit libraries installed for your 64-bit operating system?


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Levan Thursday 26 February 2015 at 0:18
Levan

 

Are you able to run any other games in Linux?

Do you have the 32-bit libraries installed for your 64-bit operating system?

 

Edited by Levan

booman Thursday 26 February 2015 at 0:23
booman

Ok, I was asking because of the x86 errors.  Sometimes that indicates missing 32-bit libraries (multi-arch)

This error:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory


When running in PlayOnLinux you are still using the 32-bit Wine correct?


† Booman †
Mint 19.3 64-bit | Nvidia 440 | GeForce GTX 1060
Linux for Beginners | List of Linux Games | My Games
PlayOnLinux Guides | PlayOnLinux Explained
Ronin DUSETTE Thursday 26 February 2015 at 0:26
Ronin DUSETTE
Admin

 

 

Are you able to run any other games in Linux?

Do you have the 32-bit libraries installed for your 64-bit operating system?

 

 

That is not what he is asking. Do you have the 32-bit graphics drivers for your graphics card installed on your system? 

How did you install that latest version of Wine? Did you use winetricks for anything at any time? The POL builds are built from Wine's vanilla source, unless specified in the name that it is patched, so there shouldn't be any compatibility issues between POL and your regular Wine version. There has to be something else missing. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Levan Thursday 26 February 2015 at 0:46
Levan

 

Ok, I was asking because of the x86 errors.  Sometimes that indicates missing 32-bit libraries (multi-arch)

This error:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory


When running in PlayOnLinux you are still using the 32-bit Wine correct?

 

Yes I use x32 bit wine in pol

 

 

Are you able to run any other games in Linux?

Do you have the 32-bit libraries installed for your 64-bit operating system?

 

 

That is not what he is asking. Do you have the 32-bit graphics drivers for your graphics card installed on your system? 

How did you install that latest version of Wine? Did you use winetricks for anything at any time? The POL builds are built from Wine's vanilla source, unless specified in the name that it is patched, so there shouldn't be any compatibility issues between POL and your regular Wine version. There has to be something else missing. 

Edited by Levan

Ronin DUSETTE Thursday 26 February 2015 at 1:34
Ronin DUSETTE
Admin

 

about nvidia 32 bit drivers I am not sure I am using xorg-edgers ppa.
But I do not understand if the drivers work on system wine (can run game) why will the drivers fail in the pol wine version.

That has nothing to do with the proprietary Nvidia drivers. That is fine and all, but if we request some info, can you just give us the info instead of explaining why it doesn't matter? I am trying to cover all bases, and the more I know about your system, the easier I can help you. 

If you simply create a new virtual drive, 32-bit, with Wine 1.7.37, and try to install it, can you show me the debug output from that? Again, we build directly from Wine's source code, so there should not be a difference between them. 

Also, if you delete ~/.wine, and attempt to reinstall Warframe to the system Wine (not through POL), does it still work? 

There has to be something that is not working right, but without debug logs from both POL and the system Wine, it is hard to tell why exactly it is doing that. Unless you are using Winetricks for something, I can't think of what would be different.

 

on interesting thing i noticed on different systems sometimes i have the same isue where I could run software on my system wine and could not run it on pol.

There are a LOT of different variables that could cause that (broken/outdated script, missing component that winetricks has the we don't, etc.). I personally don't experience that, and actually have far more success using POL as opposed to regular ol' Wine. 

 

It worked. so I guess it is not the drivers.

Well, it is something on your system that is causing this. Can you reproduce this exact situation on a different system? 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Levan Thursday 26 February 2015 at 2:22
Levan

Ronin DUSETTE Thursday 26 February 2015 at 2:33
Ronin DUSETTE
Admin

I don't have the game nor play it, so it is not something that I can do. I will look at the logs thoroughly and see if there is something wrong with our compiler or something. Thanks for sharing that info. I will let you know what I find. :D


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Thursday 26 February 2015 at 2:50
Ronin DUSETTE
Admin

OK. So, let's try to clear up some errors first. Let's get rid of the p11-kit error:

sudo apt-get install p11-kit-modules:i386
 

 Now, from the logs, I can see that you use POL for the system Wine, instead of actually using Wine (not through POL). That is what I wanted to see. All of the logs show crashes, so I am not sure what you meant by it worked with the system Wine, because they all end with backtraces/crashes. 

That being said, I can see that something called "libcef" and "launcher" seem to be the culprits. Now, if Steam is installed, maybe the game is looking for something that Steam installs when installing through Wine? I am not sure. Really, all of the error logs don't say anything too different; they all show crashes, not it working. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Levan Thursday 26 February 2015 at 9:37
Levan

 

I don't have the game nor play it, so it is not something that I can do. I will look at the logs thoroughly and see if there is something wrong with our compiler or something. Thanks for sharing that info. I will let you know what I find. :D

 

$ sudo apt-get install p11-kit-modules:i386
[sudo] password for levan:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
p11-kit-modules:i386 is already the newest version.
p11-kit-modules:i386 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Edited by Levan

Levan Friday 27 February 2015 at 2:47
Levan

Bump

Ronin DUSETTE Friday 27 February 2015 at 3:14
Ronin DUSETTE
Admin

There is no need to bump. Your post was pretty much at the top. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Вы находитесь здесь: Index > PlayOnLinux > Warframe problem on pol