Вы находитесь здесь


Mac will not give 4.2.7 permissions to run

Автор Replies
tekukuno Wednesday 29 April 2015 at 23:27

I upgraded to 4.2.7 but no matter what I put the Mac OS X (latest, I always upgrade) security settings to, I cannot get permission to run, even when the security settings are set to "Anyone." I always get the message that the developer cannot be identified and the Mac will not allow the app to open. Fortunately I have a backup of 4.2.6 which runs fine. But 4.2.7 will not run at all.

Quentin PÂRIS Thursday 30 April 2015 at 0:02
Quentin PÂRISAnonymous

Can you try to run

codesign --verify --verbose=4 PlayOnMac.app/

On a terminal with PlayOnMac 4.2.7?


Many thanks

ThomasGr Wednesday 6 May 2015 at 10:37

Hi to all,

I have the same issue. Here's the output of the codesign command:

PlayOnMac.app/: valid on disk
PlayOnMac.app/: satisfies its Designated Requirement

Looks good to me, but I can not start the actual version of PlayOnMac.


With best regards,


underscoredot Wednesday 6 May 2015 at 13:56

Hey, all...

Same issue here, same output. Yosemite 10.10.4

Also to note- the uninstaller does open fine.

tekukuno Wednesday 13 May 2015 at 19:46

Same story on 4.2.8, app can't be opened because it's from an unidentified developer - even when security settings are set to "Anywhere." You can, however, open the app by right-clicking the icon in the Dock and choosing "Open" from there. That is the only way the app will run.

Quentin PÂRIS Wednesday 13 May 2015 at 20:36
Quentin PÂRISAnonymous

That is really weird .... Can you have a look at your system log file and see if there is something wrong?

ThomasGr Thursday 14 May 2015 at 12:51

Maybe this seems to be the relevant part of log messages:

14.05.15 11:48:06,036 CoreServicesUIAgent[483]: Error -60005 creating authorization
14.05.15 11:48:09,204 CoreServicesUIAgent[483]: File /Applications/PlayOnMac.app/Contents/Resources/unix/image_magick/bin/animate failed on loadCmd /ImageMagick-6.4.8/lib/libMagickCore.2.dylib
14.05.15 11:48:09,204 CoreServicesUIAgent[483]: Fails dylib check

These entries come up in log after open it from security plugin in settings.

Quentin PÂRIS Thursday 14 May 2015 at 20:40
Quentin PÂRISAnonymous

Maybe you can try to remove these two files from the package

ThomasGr Friday 15 May 2015 at 10:24

Which files do you mean? If I remove anything from the PlayOnMac package the integration test fails at start.

EvilAngelMD Friday 15 May 2015 at 14:11

After deleting these 2 files and core resigning...


15/05/15 14:08:10,100 CoreServicesUIAgent[21900]: unexpected message <OS_xpc_error: <error: 0x7fff79f83c60> { count = 1, contents =
    "XPCErrorDescription" => <string: 0x7fff79f83f70> { length = 18, contents = "Connection invalid" }


Quentin PÂRIS Saturday 16 May 2015 at 17:06
Quentin PÂRISAnonymous

Can you try

spctl --assess --verbose=4 --type execute PlayOnMac.app 

With the original POM bundle?

underscoredot Sunday 17 May 2015 at 17:58

Just downloaded 4.2.8

Moved app to /Applications; right click -> open: No Issues

double-click opened: No Issues

pinned to dock while running; single click open: No Issues


 # spctl --assess --verbose=4 --type execute PlayOnMac.app

PlayOnMac.app: accepted

source=Developer ID

override=security disabled

Edited by underscoredot

Quentin PÂRIS Sunday 17 May 2015 at 18:06
Quentin PÂRISAnonymous

So problem solved for you?

underscoredot Sunday 17 May 2015 at 18:08

Can't speak for the others, but mine is working fine. Thanks.

ThomasGr Tuesday 19 May 2015 at 10:56

tried it the same way underscoredot did and that worked. It is maybe a problem with Path Finder. I never tried to start it through pure Finder before. After the first successful start through Finder it works now also with Path Finder.

Вы находитесь здесь: Index > PlayOnMac > Mac will not give 4.2.7 permissions to run