Вы находитесь здесь


Starcraft/Starcraft Brood War problems

X11 problem (Solved) and performace issue (Solved)

Автор Replies
Kadas Monday 6 July 2015 at 10:16

Ok i istalled Starcraft and Starcraft: Brood War through PlayonMan. But when i lunch, it asks me to allow the X11 resolution mode and when i do it, the sreen goes black and there is only the backgrouds music. But i notied that actually the resolution is changed, becouse the mouse course is bigger. If i doesn't allow the RandR mode, the resolution is set on 600x480 and it is simply unplayable.

Please help me. How can i fix this problem?

PS: if you need some terminal log, please tell how to report it and i will do it.
PPS: I actually made another post alike (here https://www.playonmac.com/en/app-10-Starcraft.html), but now i think is was the wrong place, so if admin want delete him, no problem.
Quentin PÂRIS Monday 6 July 2015 at 20:53
Quentin PÂRISAnonymous

Try with Wine 1.7.46

Kadas Monday 6 July 2015 at 23:23

Thanks a lot for the reply. (merci beaucoup :D)
Now it works!!!
But now i have to face another problem: the game suffer of lag. I mean the game is really slow...at least the mouse cursor.
Any advise for that?
Kadas Tuesday 7 July 2015 at 12:33

Ok i solved the problem by myself.
To improve the performace with Wine 1.7.46 one has to download the ddraw.dll file (http://hifi.iki.fi/cnc-ddraw/). Copy it in the game folder. Override the ddl in Wine Settings/Libraries. This will create the ddraw.ini file. Just try out parameters and it will work perfectly :D

Edited by Kadas

Вы находитесь здесь: Index > PlayOnMac > Starcraft/Starcraft Brood War problems

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com