Вы находитесь здесь


World of Tanks intermittently crashes

Автор Replies
Woody1999 Thursday 23 July 2015 at 17:58

Hi all,

13" MacBook Pro (2.6GHz i5, 128GB SSD)

OS X Yosemite 10.10.4

PlayOnMac version 4.2.8

When installing World of Tanks through PlayOnMac, everything seems normal, and upon starting the game, everything appears normal. It very rarely crashes in the menu (or garage). However, if I try and load into a match, 9/10 times the game will crash, and will crash again after I restart the game. Sometimes it will load in just fine after a restart, but if not it will continue to crash every time I try. I can't seem to link any particular actions to the crashes - they seem completely random.

Another issue I have is with textures appearing multicoloured, and some sections of the tank models entirely missing. This doesn't seem to be related to the crashing, however.

I've tried various versions of Wine (1.7.22, 1.7.47 and 1.7.47-staging) and have tried reinstalling the game, but it always gives me this message in the debugger:

wine: cannot find L"C:\\windows\\system32\\ctfmon.exe"
wine: Unhandled page fault on read access to 0x00000000 at address 0x4776f744 (thread 002b), starting debugger...

Does anyone know how to fix this? It's becoming impossible to play. The official Mac Wrapper supplied by Codeweavers (with WG) doesn't seem to work for me.


Edited by Woody1999

13" MacBook Pro Mid-2014 (2.6GHz i5, 128GB SSD)
Mac OS X Yosemite 10.10.4 on a 105GB partition
Ubuntu 14.04 on a 15GB partition
petch Thursday 23 July 2015 at 18:49

ctfmon.exe is optional, this message is quite common, so I doubt it's related

Woody1999 Thursday 23 July 2015 at 18:57

I have to say, I've been having a lot of problems with this Mac in general, even when I installed Ubuntu 14.04. Unfortunately I don't have enough space on my Ubuntu partition for World of Tanks, and so OS X is my only option.

Here's a link to my entire log file: https://drive.google.com/file/d/0ByFXM8reiGIfWk9MRWJqY29NeE0/view?usp=sharing

I've got Samba installed (but according to SMBup it can't be started), but I keep getting this crash. I've tried to install SP3 by installing IE8 or whatever the solution was, to no effect.


Edit: I'm currently reinstalling World of Tanks, to see if that will fix it. When it brought up the launcher, however, I got an error with Wine. The launcher carries on as normal. Here's the log: https://drive.google.com/file/d/0ByFXM8reiGIfNmc5YXZqcDJ6cUE/view?usp=sharing

Edit2: After reinstalling, I still get crashes. However, I now get this error in the debug console:

err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 0414.
err:ntdll:RtlpWaitForCriticalSection section 0x427cd3c4 "time.c: TIME_cbcrst" wait timed out in thread 0009, blocked by 0037, retrying (60 sec)

Edited by Woody1999

13" MacBook Pro Mid-2014 (2.6GHz i5, 128GB SSD)
Mac OS X Yosemite 10.10.4 on a 105GB partition
Ubuntu 14.04 on a 15GB partition
Вы находитесь здесь: Index > PlayOnMac > World of Tanks intermittently crashes