Вы находитесь здесь

Форум

Accèlerateur Graphique

Автор Replies
Zaak Sunday 24 June 2007 at 16:49
ZaakAnonymous

Bonjour, je suis nouveau sur Ubuntu et je trouve le système de Play On Linux vraiment bien fait. Néanmoins, en lancant PoL on m'indique un message d'erreur me disant que l'accélération graphique n'est peut-être pas activée. Pourtant, quand je vais dans mon Gestionnaire de pilotes Propriétaires, j'ai "Pilote d'accélération graphique ATI Activé". Ce n'est pas moi qui ait installé cet Ubuntu, je demande donc vos services. ^_^

J'ai une carte graphique ATI Mobility Radeon 600.

Merci d'avance!
Quentin PÂRIS Sunday 24 June 2007 at 16:59
Quentin PÂRIS
Admin

Bonjour,

Alors, tu vas nous donner les informations suivante :

Tu va dans :
PlayOnLinux => Options => Informations

Et tu nous colle le rapport systeme et glxinfos.

Ensuite, fait le test "full" dans Options => Tests, et colle nous les résultats aussi
Zaak Sunday 24 June 2007 at 17:09
ZaakAnonymous

Informations systèmes

Votre système : GNU/Linux
Votre noyau : Linux 2.6.20-16-generic
Langue de votre système : fr_FR.UTF-8
Votre nom d'utilisateur : antoine
Nom de votre ordinateur : tonio-laptop
Votre carte vidéo : Mesa GLX Indirect
Votre distribution : Ubuntu
Version de votre distribution : 7.04
Version de wine installée : wine-0.9.39
Version de wine utilisée par PlayOnLinux : wine-0.9.39
Place restante sur vos disques :
Sys. de fich. Tail. Occ. Disp. %Occ. Monté sur


et

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x3c 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None


Resultat des tests

Test gears : 166 FPS
Test glxmulx : 17 FPS
Test glxmulx1.2 : 18 FPS
Vitesse de 0% avec une résolution de 640x480 avec le test glxtinou : 19 FPS
Vitesse de 20% avec une résolution de 640x480 avec le test glxtinou : 19 FPS
Vitesse de 40% avec une résolution de 640x480 avec le test glxtinou : 19 FPS
Vitesse de 60% avec une résolution de 640x480 avec le test glxtinou : 20 FPS
Vitesse de 80% avec une résolution de 640x480 avec le test glxtinou : 19 FPS
Vitesse de 100% avec une résolution de 640x480 avec le test glxtinou : 19 FPS
Vitesse de 0% avec une résolution de 800x600 avec le test glxtinou : 11 FPS
Vitesse de 20% avec une résolution de 800x600 avec le test glxtinou : 4 FPS
Vitesse de 40% avec une résolution de 800x600 avec le test glxtinou : 2 FPS
Vitesse de 60% avec une résolution de 800x600 avec le test glxtinou : 12 FPS
Vitesse de 80% avec une résolution de 800x600 avec le test glxtinou : 12 FPS
Vitesse de 100% avec une résolution de 800x600 avec le test glxtinou : 12 FPS
Vitesse de 0% avec une résolution de 1024x768 avec le test glxtinou : 8 FPS
Vitesse de 20% avec une résolution de 1024x768 avec le test glxtinou : 7 FPS
Vitesse de 40% avec une résolution de 1024x768 avec le test glxtinou : 7 FPS
Vitesse de 60% avec une résolution de 1024x768 avec le test glxtinou : 7 FPS
Vitesse de 80% avec une résolution de 1024x768 avec le test glxtinou : 2 FPS
Vitesse de 100% avec une résolution de 1024x768 avec le test glxtinou : 7 FPS


Merci beaucoup de cette aide si rapide.

Edited by Zaak

Quentin PÂRIS Sunday 24 June 2007 at 17:15
Quentin PÂRIS
Admin

Effectivement, tu n'as pas l'accélération 3D.

lspci | grep VGA donne quoi dans la console ?
Zaak Sunday 24 June 2007 at 17:16
ZaakAnonymous

antoine@tonio-laptop:~$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]
antoine@tonio-laptop:~$

Merci encore. :>
Quentin PÂRIS Sunday 24 June 2007 at 17:17
Quentin PÂRIS
Admin

Zaak Sunday 24 June 2007 at 17:19
ZaakAnonymous

Ouch ça a l'air d'être du gros, merci.

Si besoin d'aide pour ce tutoriel, je peu toujours vous demander ici ?
Quentin PÂRIS Sunday 24 June 2007 at 17:19
Quentin PÂRIS
Admin

Aucun soucis
Zaak Sunday 24 June 2007 at 17:38
ZaakAnonymous

J'arrive déjà avec un premier problème
Sur le site que tu m'as donné, j'ai essayé de respecter toute cette partie "Installation des pilotes

sudo apt-get install xorg-driver-fglrx fglrx-control libqt3-mt

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Il est nécessaire d'ajouter la section suivante à /etc/X11/xorg.conf sous Edgy (sous peine de ne pas avoir direct rendering (dri)):

(Faîtes ALT+F2 et entrez la ligne suivante : gksu gedit /etc/X11/xorg.conf)

Section "Extensions"
Option "Composite" "disable"
EndSection

Dans mon cas (Ati R300, 9500pro), le module fglrx n'était pas chargé au démarrage, j'ai du le rajouter au fichier /etc/modules ; cette étape n'est probablement pas nécessaire pour tous les modèles de cartes ATI, à faire seulement si vous en avez besoin :

gksudo gedit /etc/modules #puis de rajouter fglrx à la ligne.
#ou taper directement :
echo "fglrx"|sudo tee -a /etc/modules

Redémarrez et lancez fgl_glxgears, si le cube et les engrenages sont là, c'est gagné!
"
Or, je rentre fgl_glxgears dans ma console, et le résultat est
antoine@tonio-laptop:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
Xlib: extension "XFree86-DRI" missing on display ":0.0".
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 142 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 30
Current serial number in output stream: 30
antoine@tonio-laptop:~$

Ai-je sauté une étape ? (en effet, beaucoup de termes ci-dessus m'ont parus très étrangés... :x)
Quentin PÂRIS Sunday 24 June 2007 at 17:46
Quentin PÂRIS
Admin

cat /etc/X11/xorg.conf

Envoi le résultat de ceci
Zaak Sunday 24 June 2007 at 17:47
ZaakAnonymous

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "1"
EndSection

antoine@tonio-laptop:~$


Merci encore et encore.
Quentin PÂRIS Sunday 24 June 2007 at 17:51
Quentin PÂRIS
Admin

Voilà le problème !

Ouvre le fichier
gksudo gedit /etc/X11/xorg.conf

Remplace

Section "Extensions"
Option "Composite" "1"
EndSection

par

Section "Extensions"
Option "Composite" "disable"
EndSection

Et fait CTRL+ALT+RETOURARRIERE après avoir sauvé tout tes documents (ça va redémarrer X)

Edited by Tinou

Zaak Sunday 24 June 2007 at 17:54
ZaakAnonymous

En effet, les engrenages sont là... Un grand merci à toi, c'est vraiment mais alors vraiment sympathique de ta part!
Quentin PÂRIS Sunday 24 June 2007 at 17:56
Quentin PÂRIS
Admin

Aucuns soucis Je marque ton sujet résolu
Zaak Sunday 24 June 2007 at 19:28
ZaakAnonymous

Hop, je poste un nouveau petit problème, je ne sais pas si ça vient d'Ubuntu ou de WoW voilà pourquoi je ne crée pas d'autre topic inutile.

Je fais la MAJ normale avec Blizzard, ça la télécharge à fond et au moment de l'installer, là où il y a le listing de toutes les nouveautés, et bien la barre d'installation reste vide et au dessus clignotte : "Vous devez fermer tous les autres fichiers avant de continuer" (un truc similaire). J'ai tout essayé, redémarré, tout fermé mais rien n'y fait...
Quentin PÂRIS Sunday 24 June 2007 at 19:31
Quentin PÂRIS
Admin

La je sais pas.

Tout ce que je sais, c'est que les mises à jours de wow posent souvent problème
Zaak Sunday 24 June 2007 at 19:36
ZaakAnonymous

Je vais essayer de faire avec des MaJs exsternes via Clubic.
Quentin PÂRIS Sunday 24 June 2007 at 19:41
Quentin PÂRIS
Admin

Utilise Live Install Modifier => WorldOfWarcraft
Zaak Sunday 24 June 2007 at 19:47
ZaakAnonymous

La maj installé, le fichier cherché et j'ai indiqué son chemin à Liveinstall, WoW me met une boite de dialogue avec l'erreur : " Le fichier "WoW.exe" est introuvable. Si le problème persiste, vous pourrez peut-être le résoudre en lançant l?outil de réparation, ou en désinstallant puis en réinstallant le jeu. Si vous ne parvenez pas à corriger le problème, merci de contacter l?assistance technique de Blizzard.
" :?
Peut-être faut-il que le fichier update soit dans le dossier avec WoW.exe ?
Quentin PÂRIS Sunday 24 June 2007 at 20:17
Quentin PÂRIS
Admin

Essai de mettre le fichier dans $HOME/.PlayOnLinux/wineprefix/WorldOfWarcraft/drive_c/Program Files/World Of Warcraft/ et recommence l'opération.
Вы находитесь здесь: Index > PlayOnLinux > Accèlerateur Graphique