Форум

PlayOnLinux not authenticated (needs GPG or PGP key)

Linux Ubuntu Jaunty

Автор Replies
PaddyLandau Sunday 23 August 2009 at 13:22
PaddyLandauAnonymous

Hello,

I've added the repository for Linux Ubuntu Jaunty using your instructions.
http://www.playonlinux.com/en/download.html#ubuntu

However, my package manager complains that it is unauthenticated.

Where can I find the PGP or GPG key so that I can add it to the repository for authentication?

Thank you.
NSLW Wednesday 2 September 2009 at 17:44
NSLW

Hi,
I fear that there is no PGP GPG key
franko Tuesday 26 October 2010 at 13:47
frankoAnonymous

Anyway, it would be very cool if there was a key. There are two reasons for it:
1. security, of course, just to be sure what are we installing on our systems.
2. since Maverick the Ubuntu's gui system upgrade tool refuses to upgrade if there is a non-authenticated pacakage, which means it won't upgrade anything if there is a PlayOnLinux upgrade available.I have just experienced that a minute ago. I can always upgrade from terminal, with apt-get or aptitude, but most newbies don't know anything about it, they will just be unable to upgrade anything.

So, give us a key, please!
franko Wednesday 27 October 2010 at 19:17
frankoAnonymous

bump...
Quentin PÂRIS Wednesday 27 October 2010 at 21:26
Quentin PÂRIS
Admin

Yep it's planned
barfleur Saturday 30 October 2010 at 15:46
barfleur

Dear Admin, would you be able to tell us by when is it planned for Maverick? I wonder why I cannot use PlayOnLinux now, I was able to do so 6 days ago on Oct 24th
Salvatos Saturday 30 October 2010 at 18:37
SalvatosAnonymous
Moderator

That probably has to do with what we describe in our latest news. If you are using 3.8.3 or 3.8.4, please upgrade (manually) to 3.8.5.

Disclaimer: I'm a noob, not a dev; my advice is only a guess.
Attention : Je suis aussi noob que vous, prenez mes suggestions avec un grain de sel ;)
barfleur Sunday 31 October 2010 at 3:00
barfleur

Dear Modérateur Salvatos,

My operating system is Ubuntu 10.10 (Maverick Meerkat), and as far as I understand it (please advised me if such is not the case), under such operating system it is no possible to install POL version 3.8.5 unless the appropiate PGP or GPG key has been issued.

=======================================
Je suis également a nouv, merci de votre réponse
=======================================
Trilby Sunday 31 October 2010 at 9:13
TrilbyAnonymous

Until the keys for the PoL repository are established, I suppose you could use the linux "Generic" 3.8.5 download, simply extract it to location on your /home partition and run from there. It won't install it per se, but it is designed for use.
Aymeric P. Sunday 31 October 2010 at 11:55
Aymeric P.
Admin

Hi,

It's always possible to install unsigned package.
It's seem that Ubuntu Maverick didn't like non-authenticated package with graphical interface and repository, but downloading the Debian file from here and installing manually with graphical interface seem to work (work a least from a clean install of Maverick).
You can also use the generic package, simply extract files and execute playonlinux.

Former member.
franko Sunday 12 December 2010 at 17:02
frankoAnonymous

Also, from terminal, both apt-get and aptitude will ask you to confirm or reject the installation of an unsigned package. So, just like I said before, the upgrade IS possible from the repository. The problem is that most newbies will not know how to do it...

So, to upgrade from repository, just open a terminal and do:

sudo apt-get upgrade

...and then confirm with a "y" that you want to upgrade playonlinux, which is unsigned.

I am looking forward to the pgp key. :-)
kwill Thursday 23 December 2010 at 9:42
kwillAnonymous

For anyone wanting to follow this issue and be automatically notified when a fix is made, I have created the following tickets on the POL tracker and Launchpad:

No authentication key - http://bugs.playonlinux.com/en/issue-90.html and https://bugs.launchpad.net/playonlinux/+bug/693703

I think this issue could be solved by creating a Launchpad PPA for Ubuntu users. Added this feature request as http://bugs.playonlinux.com/en/issue-91.html and https://bugs.launchpad.net/playonlinux/+bug/693706
Quentin PÂRIS Thursday 23 December 2010 at 15:18
Quentin PÂRIS
Admin

Solved !