Форум

[TUTO] Installer le protocole steam dans firefox 3.5

Автор Replies
p_tony Friday 8 January 2010 at 19:03
p_tonyAnonymous

Bonjour,

pour que firefox 3.5 et supérieur reconnaisse le protocole steam.

Note: Pour les fous qui utiliseraient firefox 2, voir ici le tuto de bastien09 (http://www.playonlinux.com/fr/topic-549-TUTO_Installer_le_protocole_steam_dans_firefox.html)

Dans la barre d'adresse de firefox tapez about:config , validez et cliquez sur le bouton "je ferai attention (...)"

Faites un clic droit dans la liste des options qui s'affichent est sélectionnez "Nouvelle > Valeur booléenne".

Donnez lui network.protocol-handler.expose.steam comme nom et false comme valeur.

Cliquez sur le lien suivant : [url]steam://open/friends[/url]
Tapez dans la barre d'adresse: steam://open/friends et validez , une fenêtre apparait vous demandant de choisir l'application pour ouvrir ce protocole.

Cliquez sur le bouton Choisir et sélectionnez le fichier Steam qui doit ce trouver sous votre home dans .PlayOnLinux/configurations/installed .

Si tout est ok, steam devrait avoir ouvert la liste des amis.

Source: http://ubuntuforums.org/showthread.php?t=433548

Edited by p_tony


Portable Asus EeePC 1215B-SIV134M: ArchLinux Current x86_64 ~~ AMD E-450 ~~ AMD Radeon HD6320, pilote catalyst ~~ KDE desktop
BlondVador Friday 8 January 2010 at 20:17
BlondVador
Moderator

Merci, pour ma part ça ne fonctionne pas mais ce n'est pas bien grave ;).

p_tony Friday 8 January 2010 at 20:40
p_tonyAnonymous

a quelle niveau ca ne fonctionne pas, tu as la fenêtre de firefox qui s'ouvre pour choisir un programme ?

Edited by p_tony


Portable Asus EeePC 1215B-SIV134M: ArchLinux Current x86_64 ~~ AMD E-450 ~~ AMD Radeon HD6320, pilote catalyst ~~ KDE desktop
BlondVador Friday 8 January 2010 at 22:02
BlondVador
Moderator

Tapez dans la barre d'adresse: steam://open/friends et validez , une fenêtre apparait vous demandant de choisir l'application pour ouvrir ce protocole.

Quote


Je reçois une fenêtre d'alerte :

Firefox doesn't know how to open this address, because the protocol (steam) isn't associated with any program.

Quote

p_tony Saturday 9 January 2010 at 7:21
p_tonyAnonymous

Peux-tu vérifier dans about:config que tu as bien l'option network.protocol-handler.expose.steam avec une valeur à false, car c'est justement cette option qui permet d'associer le protocole steam.

Edited by p_tony


Portable Asus EeePC 1215B-SIV134M: ArchLinux Current x86_64 ~~ AMD E-450 ~~ AMD Radeon HD6320, pilote catalyst ~~ KDE desktop
BlondVador Saturday 9 January 2010 at 9:31
BlondVador
Moderator

Peux-tu vérifier dans about:config que tu as bien l'option network.protocol-handler.expose.steam avec une valeur à false, car c'est justement cette option qui permet d'associer le protocole steam.

Quote from p_tony


La valeur est bien à false. J'ai également essayé avec true, sans résultat.

EDIT : J'utilise Firefox 3.0 et non 3.5... Le problème vient certainement de là.

Je viens d'essayer avec Firefox 3.5, toujours pareil...

Edited by BlondVador


p_tony Wednesday 13 January 2010 at 20:42
p_tonyAnonymous

bon, je ne sais pas pourquoi cela ne fonctionne pas sur ta machine, alors que chez moi ça fonctionne. à ce moment je ne peux que te rediriger vers la source:
http://ubuntuforums.org/showthread.php?t=433548

sinon par hasard as tu dans about: config les options du tuto pour l'ancienne version ?

network.protocol-handler.external.steam
network.protocol-handler.app.steam
network.protocol-handler.warn-external.steam


Edited by p_tony


Portable Asus EeePC 1215B-SIV134M: ArchLinux Current x86_64 ~~ AMD E-450 ~~ AMD Radeon HD6320, pilote catalyst ~~ KDE desktop
BlondVador Thursday 14 January 2010 at 21:45
BlondVador
Moderator

bon, je ne sais pas pourquoi cela ne fonctionne pas sur ta machine, alors que chez moi ça fonctionne. à ce moment je ne peux que te rediriger vers la source:
http://ubuntuforums.org/showthread.php?t=433548

sinon par hasard as tu dans about: config les options du tuto pour l'ancienne version ?

network.protocol-handler.external.steam
network.protocol-handler.app.steam
network.protocol-handler.warn-external.steam


Quote from p_tony


Oui, je me suis renseigné sur ta source, j'ai tout essayé, rien n'y fait.

Je ne suis pas sur Ubuntu, c'est peut-être la source du problème...

p_tony Tuesday 9 February 2010 at 0:56
p_tonyAnonymous

Arf, ça fait longtemps que je ne suis pas passé.

Enfaite j'ai fais ça sous frugalware (current) et j'ai testé uniquement avec l'environnement gnome.

Portable Asus EeePC 1215B-SIV134M: ArchLinux Current x86_64 ~~ AMD E-450 ~~ AMD Radeon HD6320, pilote catalyst ~~ KDE desktop
BlondVador Friday 12 February 2010 at 15:40
BlondVador
Moderator

Arf, ça fait longtemps que je ne suis pas passé.

Enfaite j'ai fais ça sous frugalware (current) et j'ai testé uniquement avec l'environnement gnome.

Quote from p_tony


Il est possible que ce soit la source du problème... Je suis sous ArchLinux avec OpenBox comme environnement.