Вы находитесь здесь


Fallout 3

Failed to install

Автор Replies
rokstar Saturday 5 March 2011 at 20:00

I just tried to install Fallout 3, and just after the Gecko installation the script says "download.microsoft.com Server not available". So it is a problem with my internet connection (maybe a dns issue) or it is really changed the server? In that case the script have to be updated with the working server, because after this message the installation stop.
JSW Monday 7 March 2011 at 2:16

I'm getting the same problem. It looks like it's coming up when the script tries to download DirectX.

The actual download.microsoft.com site seems to be working fine so my guess is that the script is trying to use the wrong URL to download the file.
GNU_Raziel Monday 7 March 2011 at 11:45

JSW Tuesday 8 March 2011 at 3:58

I just tried again with the updated installer and, while it gets further into the installation than before, it still doesn't actually work.

A few minutes in to the actual copying-from-disc portion of the install the following error pops up:

This doesn't stop the installation, however, which continues to the end, but when the script then tries to launch the Fallout 3 Configurator it gets this error:

Unfortunately, it's not able to recover from that one and the configurator never loads.

I've attempted the installation twice and gotten the same result.
GNU_Raziel Tuesday 8 March 2011 at 12:02

Crap...I do not own this game so it's difficult to fix it...For the dxsetup error, forget it, POL install dx so nothing to worry.

We need to get rid of that nasty configurator error...I will try to find a friend who own this game and do some tests.
JSW Tuesday 8 March 2011 at 14:52

Is there any kind of log file I could send you that would help? I'm not sure how to turn on that sort of thing in PoL.
GNU_Raziel Wednesday 9 March 2011 at 1:09

Note for the moment, log system will be updated and easy to manage with newer PoL version.
rokstar Thursday 10 March 2011 at 21:24

I installed the game (same error with directx), then I set debug dll_all on the Fallout Launcher and this is the output:
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC90.CRT" (9.0.21022.8)
err:module:import_dll Library MSASN1.dll (which is needed by L"C:\\\\windows\\\\system32\\\\xlive.dll") not found
err:module:import_dll Library xlive.dll (which is needed by L"C:\\\\Programmi\\\\Bethesda Softworks\\\\Fallout 3\\\\Fallout3.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"C:\\\\Programmi\\\\Bethesda Softworks\\\\Fallout 3\\\\Fallout3.exe" failed, status c0000135

Now for the configurator:
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.VC80.CRT" (8.0.50727.762)
err:msvcrt:MSVCRT__invalid_parameter (null):0 (null): (null) 0
wine: Unhandled exception 0xc0000417 at address 0x7b83a9cb (thread 0009), starting debugger...

and then a full list of things that may have caused the "unhandled exception".

Hope this help to fix the game :)
Derringer81 Monday 2 May 2011 at 21:26

I am having a weird Issue with FO3 as well....
i go to install (digital copy) and it runs thru everything it needs....
wine version -> mono -> DX9 -> (select executable) (not sure about the order and im sure there's a few im missing, but its a pretty clean install....)

at this stage, every time, my whole system will freeze except the mouse, and i cannot interact with anything on the interface.... all i can do is restart..... sometimes the window pos up so i select the exe, sometimes it freeze while bringing it up, i've tried to put the path to the exe (If it gets to that window!)

what can i do?? (to help fix, troubleshoot, whatev)

out of shear frustration i got Steam to install after a few tries......once it is installed it is beautifully smooth....

(BTW - im running ubuntu 11, I hate the unity interface, so i might be switching that soon....)


Will work for game company as Level Designer.......plz?
GNU_Raziel Monday 2 May 2011 at 21:43

For you last problem, you can switch to "classic Gnome" in Ubuntu options to get rid of Unity (I too think it's crap) and switch back to real Gnome desktop.

For your freeze problem, it's the first time I see something like this...
Can you give some info about your hardware ?
It appened only with Fallout 3 ?
Have you tried with another game ?
Derringer81 Monday 2 May 2011 at 21:59

I have tried other games (UT3-disk, Portal-DD, KOTOR 1&2 - disks) and it happens at the same time (asks where am i getting the install from: disk, exe, whatev)

P core 2 duo @2.93 (over-clocked, but even when i dont OC it, it still happens)
6 gig DDR2 @800 (tried each stick independently, an ran a RAM checker (ubuntu 10 install disk) and it all green-lit)
Ubuntu 11 x64 (tried both the 32 and 64 flavors of wine, all after complete removal)
ATI X1600 (trying to save up for a new Nvidia...checked the drivers, and linux uses the latest ones...)


Will work for game company as Level Designer.......plz?
Derringer81 Wednesday 4 May 2011 at 1:41

interesting side note: i just tried to install it through the right click -> open with wine...and it logged me out!!


could it be an issue with wine maybe?


Will work for game company as Level Designer.......plz?
Precision Thursday 5 May 2011 at 0:51

I already have problem during dvd disk detection. Then I change default script to read a correct fstab where in my cdrom system is a /mnt/cdrom. After changes I use a local script key!
Derringer81 Monday 9 May 2011 at 20:29


@ precision - can you link a how-to page?


Will work for game company as Level Designer.......plz?
Derringer81 Sunday 15 May 2011 at 21:03

OK.....i dunno what happened, but a fresh OS install and everything works......


Will work for game company as Level Designer.......plz?
MasterGvhu Monday 25 July 2011 at 15:23

Hi there,

I am experiencing the same problems as JSW above...

I use Ubuntu 11.04 with Unity, POL 3.8.8 and tried to install Fallout 3 using the scripted installation. I get the same DXSETUP.exe-Error during the installation of DirectX components, although POL already installed DirextX before... And after trying to start the Fallout 3 configurator I get the same Program Error message.

So, I wondered if there is already an advancement in finding a solution for this problem?

Thanks in advance...
Вы находитесь здесь: Index > PlayOnLinux > Fallout 3