Вы находитесь здесь

Форум

guild wars

Автор Replies
christian Saturday 20 October 2007 at 13:05
christianAnonymous

Bonjour, j'utilise wine , playonlinux avec guild wars depuis 3 mois sans problèmes, et depuis le 16 octobre je ne peus plus accéder a GW car j'obtiens un message me disant ( impossible de trouver le fichier archive c:\gw\gw.data ) j'ai désinstallé wine pol gw, et réinstallé le tout sans succès, puis j'ai installé le tout avec wine 0.9.46 ancienne version car le problème me semblait consécutif a la mise a jour , ça a marché impecablement après avoir testé le jeu j'ai stopé mon pc et a la relance j'ai de nouveau eu le message primitif impossible donc de jouer a GW .
mon os est ubuntu 7.10
wine 0.9.47
playonlinux1.8
et donc Guild Wars
j'espère que vous pourrez me dire ce qu'il se passe , et je vous en remerci d'avance
christianpinchinch:
Aymeric P. Saturday 20 October 2007 at 22:25
Aymeric P.
Admin

Salut,
Ce qu'il ce passe c'est que fichier Gw.dat pert les droits d'écriture et de lecture pour le créateur et obtient les droit de lecture uniquement pour le groupe, j'ai eu le problème hier soir (ça semble pour moi résolu, mais ça reste à confirmer).
D'abord il faut lui redonner les droits a ce fichier, pour ça 2 solutions, je préférè celle par le terminal car ça permet de rétablir les droits a tous les fichiers de GuildWars
chmod -R 666 $HOME/.PlayOnLinux/wineprefix/GuildWars/drive_c/GW/

Ensuite lance POL depuis une console comme ceci :
playonlinux --run GuildWars -image
Ainsi GW sera mis a jours (/!\ peut faire jusqu'à 3 Go à télécharger)
Chez moi ça a suffit, mais le problème vient peut être de wine ou GW.
si le problème revient il faut que tu regarde dans le dossier $HOME/.PlayOnLinux/wineprefix/GuildWars/drive_c/GW/ si le fichier Gw.tmp fait dans les 7Mo (enfin quasiment la taille de Gw.exe), rétablit les droits puis remplace le fichier Gw.exe par ce fichier (en oubliant pas de remettre les droits d'exécution au .exe et essaye à nouveau.
Sinon essaye de changer la version de wine.

Pense a fournir le résultat de t'es test

Edited by MulX


Former member.
goku Sunday 21 October 2007 at 21:31
goku

Bonjour à tous. Cette nouvelle version béta 2 est tout bonnement superbe. Bravo ! et encore bravo !

Ce petit post pour signaler une réaction bizarre des jeux avec Wine 0.9.47. Notamment Guild War. Lors de la mise à jour du fichier Gw.dat ce dernier se retrouve en lecture seule pour le groupe et rien d'autre. Du coup la mise à jour bloque et Guild War ne se lance pas.

Chose géniale, la possibilité d'assigner une ancienne version à Guild War en quelques clics et le tour et joué. Guild War se lance à nouveau.

Oblivion et Morrowind, eux, n'ont rien dit et se lance sans broncher. Steam n'a rien voulu savoir mais je n'ai pas été plus loin avec lui pour le moment.

Voilà. Conclusion, sur une Mandriva 2008.1 (et oui je suis en Cooker) pour Guild War utilisez la version 0.9.46 de Wine pour le moment.

Amicalement Emmanuel

Quote from helijah

Voilà une autre solution

Edited by goku


Windows de Microsoft.

Mac de Apple.

Linux du monde entier.
christian Monday 22 October 2007 at 9:48
christianAnonymous

bonjour , ceci pour vous dire que j'ai suivi les conseils de mulx mais l'installation a foirée aussi je vais remettre ça.
a bientot pour des nouvelles
chris
christian Monday 22 October 2007 at 13:16
christianAnonymous

bonjour , l'intallation est de nouveau foireuse car si j'ai désinstallé GW je ne peus plus la réinstaller , réponse de pol a l'installation de GW ( l'installation a échouée car il semble que GW est déja installé
Or dans le fichier GW.data ou tout fichiers GW il n'y a rien Octets = 0.
Je vais donc désinstallé wine et réinstaller la précédente version comme vous me le suggérez.
a bientot pour les nouvelles
chris
Quentin PÂRIS Monday 22 October 2007 at 20:36
Quentin PÂRIS
Admin

A priori désinstall tout, install PlayOnLinux v2 et Guild Wars marchera.
christian Tuesday 23 October 2007 at 13:41
christianAnonymous

j'ai forcé wine 0.9.46 et réinstallé GW et c'est extra donc je vous remercie pour vos conseils ,je viens de voir le conseil de tinou si j'ai des problèmes je suivrai son conseil , merci encore a tous , affaire pour moi résolue, a bientot.
chris
lateo Wednesday 24 October 2007 at 1:48
lateo

oups j'étais pas le seul à avoir ce problème! dsl de pas avoir posté + tôt!

alors si, ça fonctionne avec la 0.9.47.
j'ai modifié le script de lancement (voir dans /home/ton_login/.PlayOnLinux/configurations/installed/) comme suit et hop :

#!/bin/bash
cd "/home/lateo/.PlayOnLinux/wineprefix/GuildWars//drive_c/GW/"
chmod 755 Gw.*
#wine ""Gw.exe -dsound"" $@
wine Gw.exe $@

c'est un peu bourrin de chmoder à chaque fois mais ça le fait ; et pis voilà chuis un bourrin et j'assume ;-)
certains auront remarqué que l'option "-dsound" n'est plus nécessaire

voili voili.

Edited by lateo

Aymeric P. Wednesday 24 October 2007 at 17:56
Aymeric P.
Admin

certains auront remarqué que l'option "-dsound" n'est plus nécessaire

Quote from lateo


Tu as de la chance, chez moi je suis obliger de couper complètement le son (bon plus avec les nouveaux driver ATI j'ai tout qui crash, même les jeux natifs, mais ça c'est autre chose)

Former member.
lateo Wednesday 24 October 2007 at 18:28
lateo

mulx> ah c pas drôle ça.

jusque la 0.9.40 j'avais que la musique,
depuis la 0.9.41 j'ai tous les sons,
depuis la 0.9.44 (la meilleure release pour GW à ce jour je pense) les options graphiques à fond,
et enfin depuis la 0.9.47 je peux me passer de cette option.

'faut que je reteste teamspeak, la dernière fois que j'ai testé j'avais plus de son du tout dans le jeu.

edit: une bonne nouvelle et une mauvaise :
- la bonne c'est que TS+GW ça marche si tu installe alsa-oss et lance TS avec.
- la mauvaise nouvelle c'est que ma "soluce" était temporaire et ne marche plus depuis la dernière màj Donc retour ) la 44 et donc retour de l'option -dsound

Edited by lateo

Baron Greldinard Thursday 25 October 2007 at 17:07
Baron GreldinardAnonymous

Bonjour,

je suis tout nouveau en ce qui concerne linux mais j'ai réussi a installer GW avec POL !!!

ça marche d'enfer avec tout au taquet !!

Cependant il a fallut que j'assigne Wine 0.9.46 a l'installation parce que GW ne souhaitait pas se mettre à jour et il va falloir que je réassigne toutes les commandes parceque apparement GW croit que j'ai un clavier QWERTY c'est génant

quelqu'un aurait il une solution moins longue que la refonte manuelle de tous les raccourcis clavier !!! : \
Problème obsolète depuis assignation de win 0.9.49 + POL 2.0.2 tout marche en azerty

Edited by Baron Greldinard


asus m2n32 sli deluxe wifi édition
7950 GT 512 DDR msi
Athlon 64 x2 4600+
1Go corsair
2 seagates barracuda 250 Go
Ubuntu Gutsy
Aymeric P. Thursday 25 October 2007 at 19:48
Aymeric P.
Admin

hélas non il n'y a pas de solution connu pour remettre les touches dans l'ordre a part le faire a la main dans les options, le plus étrange dans cette histoire c'est que le chat fonctionne en Azerty ....

Former member.
Baron Greldinard Friday 26 October 2007 at 11:54
Baron GreldinardAnonymous

ok merci

asus m2n32 sli deluxe wifi édition
7950 GT 512 DDR msi
Athlon 64 x2 4600+
1Go corsair
2 seagates barracuda 250 Go
Ubuntu Gutsy
Вы находитесь здесь: Index > PlayOnLinux > guild wars