Вы находитесь здесь

Форум

[POL] Erreur au lancement

Première installation : Erreur python

Автор Replies
ercete Tuesday 20 November 2007 at 21:43
ercete

Bonjour à tous, je suis sous gentoo et je teste PlayOnLinux pour la première fois.
N'ayant pas trouvé d'ebuild pour gentoo, j'ai commencé à la main.
Aucune dépendance excepté kdialog) ne semble requise.

Pourtant j'obtiens cela au lancement :


rct@courgette ~/PlayOnLinux $ ./playonlinux
Traceback (most recent call last):
File "/home/rct/PlayOnLinux/python/attendre.py", line 24, in ?
wxversion.select("2.8"
File "/usr/lib/python2.4/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found

PlayOnLinux v2.0
----------------
Checking python : [ Ok ]
which: no lynx in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/bin:/usr/qt/3/bin:/usr/games/bin)
Traceback (most recent call last):
File "/home/rct/PlayOnLinux/python/message.py", line 23, in ?
wxversion.select("2.8"
File "/usr/lib/python2.4/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found



Et pour info voici les versions de python (et ce qui s'y rapproche de près ou de loin) installées chez moi

python-updater 0.2
python 2.4.4-r5
PyQt 3.17
cddb-py 1.4
dbus-python 0.80.2
id3-py 1.2
numeric 23.7
pycairo 1.4.0
pycrypto 2.0.1-r6
pygobject 2.12.3
pygtk 2.10.6
pyid3lib 0.5.1
pyogg 1.3-r1
pyopengl 2.0.0.44
pyrex 0.9.4.1
python-fchksum 1.7.1
pyvorbis 1.4-r1
pyxml 0.8.4
qscintilla 1.5.1
sip 4.5.2-r
Aymeric P. Tuesday 20 November 2007 at 21:58
Aymeric P.
Admin

Salut,
effectivement il n'y a pas d'ebuild pour gentoo, je verrais pour en faire une (sauf si tu veux te lancer dedans )
Concernant les dépendances, kdialog & zenity ne sont plus utilisé
sous gentoo, il faut que tu installe (enfin normalement) :
x11-libs/wxGTK
wine
bash
unzip
wget
www-client/lynx
xterm
media-gfx/imagemagick
python

Il y en a peut être d'autre a installer ...
Il te faudra peut être modifier USE si tu n'as pas prévu le support de gtk ...
Sinon j'ai prévu de tester POL sur une vieille machine, (là elle finit de compiler xserver-xorg âpres 5 jours acharné), donc les ebuilds si je doit les faire, faudras être patient

Former member.
ercete Tuesday 20 November 2007 at 22:02
ercete

Merci MulX

A part Lynx, tout semble installé et a jour...
Je vais traquer un peu les USE

ercete Tuesday 20 November 2007 at 22:03
ercete

PS : si tu es sous gentoo, peux tu me poster le résultat de

emerge -av x11-libs/wxGTK wine bash unzip wget www-client/lynx xterm media-gfx/imagemagick python

histoire de comparer efficaccement, merci
ercete Tuesday 20 November 2007 at 22:11
ercete

Je vais de l'avant :

voici les nouvelles erreurs :


rct@courgette ~/PlayOnLinux $ ./playonlinux
Traceback (most recent call last):
File "/home/rct/PlayOnLinux/python/attendre.py", line 24, in ?
wxversion.select("2.8"
File "/usr/lib/python2.4/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found

PlayOnLinux v2.0
----------------
Checking python :                     [ Ok ]
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Traceback (most recent call last):
File "/home/rct/PlayOnLinux/python/message.py", line 23, in ?
wxversion.select("2.8"
File "/usr/lib/python2.4/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found
Traceback (most recent call last):
File "/home/rct/PlayOnLinux/python/mainwindow.py", line 23, in ?
wxversion.select("2.8"
File "/usr/lib/python2.4/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found"
wxversion.VersionError: Requested version of wxPython not found


Je vais chercher cette histoire de GLX...
ercete Tuesday 20 November 2007 at 22:34
ercete

Bon, j'ai résolu les problèmes de GLX mais j'ai toujours des "Requested version of wxPython not found" en pagaille.

Pour info la version installée est la suivante : dev-python/wxpython-2.6.4.0

Voilà, status = blocked pour le moment...
Aymeric P. Tuesday 20 November 2007 at 23:14
Aymeric P.
Admin

Non je ne suis pas sous gentoo, je tourne sous une ubuntu (modifier d'accord), et j'ai une gentoo qui s'installe sur un vieux PC (toute les autres distrib sont trop lourde pour la pauvre bête)
Et la sur la gentoo je viens juste de finir l'installation de windowmaker (ça fait 6 jours que je vois des i386-pc-linux-gnu défiler ), et je viens de me rendre compte que je n'avais pas firefox (ni de logiciel web console) (donc avant de penser à POL ...)

En plus je crois que je vais devoir remerger le monde (j'ai changer USE pas mal de fois pendant les merging des différents paquet ... donc je suis pas sur que tous le monde soit content (genre X11 avec "qt kde -gtk" ; et wmaker avec l'inverse "-qt -kde gtk"...)

Sinon, il semble que le problème que tu as viens avec wxversion qui veux choisir une version qui n'existe pas :/

PS : @Tinou : je sais plus trop quand tu rallier que le noyaux linux été énorme, ben sous gentoo là il fait 2.3Mo (et j'ai pas fait un truc archi-optimisé)

Edited by MulX


Former member.
ercete Saturday 24 November 2007 at 14:58
ercete

Bon épisode 2 : je vais essayer d'upgrader/downgrader wxpython pour faire fonctionner le bousin !
mobidyc Sunday 25 November 2007 at 16:41
mobidycAnonymous

je penses avoir trouvé ton problème (j'ai le meme)

il s'agit du package wxGTK qui existe en version 2.6.4.0-r1 sous gentoo.
(à l'instar de l'opensuse de mon frangin qui a wxGTK en version 2.8.6).

je connais rien a python donc, je sais pas si changer la version requise dans POL suffit pour faire tourner ce dernier.

--
Mobidyc
mobidyc Sunday 25 November 2007 at 17:36
mobidycAnonymous

Hello,

pour les gentooistes, afin de vous éviter de chercher une version valide de wxGTK voici deux liens les concernants:
http://bugs.gentoo.org/show_bug.cgi?id=145884
et
http://overlays.gentoo.org/dev/dirtyepic/wiki/WikiStart

en bref, la version 2.8 devrait arriver début décembre.

--
Mobidyc
Вы находитесь здесь: Index > PlayOnLinux > [POL] Erreur au lancement