Вы находитесь здесь


Apps fail when .PlayOnLinux is symlink

Автор Replies
dbbolton Thursday 22 December 2011 at 21:15

I first installed Steam using POL in the standard location, "$HOME/.PlayOnLinux". However, I only had 2GiB free on my home partition, so I mv'ed it to my media partition and left a symlink like so
mv .PlayOnLinux /media/files
ln -s /media/files/.PlayOnLinux ~/.PlayOnLinux

I then did a "ls -l ~/.PlayOnLinux" to ensure sane permissions. When I tried to launch Steam from POL, it crashed. This did not happen before.

I rm-ed the whole directory and started over, keeping the same link-directory structure as listed above. This time Steam won't even install. POL complains that it can't find the Steam.exe binary.

Why doesn't it work when I move the directory and leave a symbolic link?
Quentin PÂRIS Thursday 22 December 2011 at 21:31
Quentin PÂRISAnonymous


It does not work because POL is using find command, which gives him the wrong path.

You might try to edit playonlinux/lib/Variables.py to change your home path
dbbolton Thursday 22 December 2011 at 21:34

Or better yet, perhaps the use of the find command should simply have the -L option to avoid the issue altogether.

From what I can gather, the workaround should be this
-- homedir = os.environ["HOME"]
++ homedir = "/media/files"

But I tried this and got the same error. What else do I need to change?

Edited by dbbolton

dbbolton Thursday 22 December 2011 at 21:52

I also did this
grep -in "find" /usr/share/playonlinux/*
and it gave no relevant results. Where is the find call coming from?
Quentin PÂRIS Friday 23 December 2011 at 11:06
Quentin PÂRISAnonymous

lib/scripts.lib mainly (I think)
draco31.fr Thursday 5 January 2012 at 8:34


I had the same problem of free space, and saw the bug #609.
( http://www.playonlinux.com/fr/issue-609.html )

As mentioned in the bug report, for me, the problem was not related to PlayOnLinux but related to the noexec option of the target partition (/media/files in your case).

You can see that you are in the same case by looking into the file /proc/mounts (more precise than the output of the 'mount' command or '/etc/mtab' on my Xubuntu 11.10 )

I hope this could help you.

Edited by draco31.fr

Вы находитесь здесь: Index > PlayOnLinux > Apps fail when .PlayOnLinux is symlink

This site allows content generated by members, and we promptly remove any content that infringes copyright according to our Terms of Service. To report copyright infringement, please send a notice to dmca-notice@playonlinux.com