Forum

Installing Windows Search for Outlook

Författare Svar
weisswurst Saturday 23 March 2013 at 15:06
weisswurstAnonymous

Hi!

I tried to install Windows Search 4 (http://www.microsoft.com/de-de/download/details.aspx?id=23) that I can search my mails in Outlook.

How do I install additional files to an exsiting POL Virtual Drive?
I tried to overwrite the installation on the drive with the "install unlistet programm" wizard. But the wizard doesn't continue after I select overwrite and next the dialog.
The dialog just stops to move forward...

Im running Ubuntu 1204 and POL 4.1.9 and try to search my mails in Outlook 2010.

Thx!

petch Saturday 23 March 2013 at 15:32
petch
Developer

Hi,

That's strange it works for me (after some moment looking for CDROMs I suppose).
By the way some light bug has been fixed in development version, it no longer asks you whether you want to overwrite or erase when updating a virtual drive, that didn't make sense.
Another way to do what I want, I think:
Configure button > select the virtual drive > Miscellaneous tab > Run an .exe in this virtual drive
weisswurst Saturday 23 March 2013 at 17:36
weisswurstAnonymous

Whops, it seems I just didn't wait long enough...
Sorry for that!

Unfortunately I still can't install KB940157 and thus don't search my mails :(

The installer logfile is a just stunning...

00:00.001: ====================================================================
00:00.088: INFO:    Opening log for preliminary WDSSetup.exe actions
00:00.130: Started: 2013/03/23 (Y/M/D) 15:11:41.909 (local)
00:00.172: Command line: 
00:08.995: INFO:    Closing down log for WDSSetup.exe logging

In POL log it seems that a Path is missing, but which?...

[03/23/13 17:27:29] - Running wine-1.5.16 /home/wurst/PlayOnLinux's virtual drives/Office2010/drive_c/WindowsSearch-KB940157-XP-x86-deu.exe (Working directory : /)
fixme:clusapi:GetNodeClusterState ((null),0x32eb84) stub!
fixme:advapi:DecryptFileA "c:\\\\b47dbe441d50a1985a5f9f52bd\\\\" 00000000
fixme:clusapi:GetNodeClusterState ((null),0x33ec04) stub!
fixme:advapi:DecryptFileA "c:\\\\c336065534dd1f6c3df29ccc\\\\" 00000000
fixme:setupapi:pSetupGetGlobalFlags stub
fixme:advapi:RegisterEventSourceA ((null),""): stub
fixme:advapi:RegisterEventSourceW (L"",L""): stub
fixme:advapi:ReportEventA (0xcafe4242,0x0001,0x0000,0xc00e1115,(nil),0x0003,0x00000000,0x33f220,(nil)): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0xc00e1115,(nil),0x0003,0x00000000,0x1522f0,(nil)): stub
err:eventlog:ReportEventW L"Windows"
err:eventlog:ReportEventW L""
err:eventlog:ReportEventW L"Path not found.\\r\\n"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub

I also tried the englisch version but it's not working too, with the same error...

Edit: I added a symlink from windows to Windows directory, but that's not helpful either..

Ändrat av weisswurst

petch Saturday 23 March 2013 at 18:39
petch
Developer

Edit: I added a symlink from windows to Windows directory, but that's not helpful either..

Quote from weisswurst

I don't get what that means...
weisswurst Saturday 23 March 2013 at 21:15
weisswurstAnonymous

Well the log file sais something about a path which cannot be found.
And it sais something about "Windows" (err:eventlog:ReportEventW L"Windows"")

The path to "windows" is:
~/PlayOnLinux's virtual drives/Office2010/dosdevices/c:/windows

So I thought maybe the installer for the search patch tries to find a windows directory which is spelled with an upper case W...

And because linux is case sensitive it won't find
~/PlayOnLinux's virtual drives/Office2010/dosdevices/c:/windows
if it is looking for
~/PlayOnLinux's virtual drives/Office2010/dosdevices/c:/Windows

So I made a link which is windows with upper case W but that didn't help.
It was just a wild guess
petch Sunday 24 March 2013 at 0:18
petch
Developer

Wrong guess then, Wine already takes care of case mapping, as part of Windows environment emulation.
http://wiki.winehq.org/CaseInsensitiveFilenames
(or since their wiki seems currently down, http://web.archive.org/web/20120902054014/http://wiki.winehq.org/CaseInsensitiveFilenames)