PoL / Wine wrong icon

Författare Svar
GameX Sunday 24 March 2013 at 18:36


I have a problem with Wine / PlayOnLinux that I've never managed to solve - back when I was on Ubuntu 11.10 (I use 12.04), I *believe* this bug (Maybe it's a bug) was fixed, but I'm not sure.

Why when I launch a Wine / PlayOnLinux program, I don't get the correct icon on the launcher?
Check this screenshot, I'm running "Digsby", with Wine 1.5.18 (From PlayOnLinux):

I get the generic Wine icon in the dash.  However, what's even weirder, is that "PDF X-Change Viewer" in the back of the screenshot does have the correct icon?

It's in the same Wine prefix, also running with Wine 1.5.18.

That's really weird.  On the screenshot, PDF X-Change Viewer have the correct icon.  After a logoff, I start PDF X-Change Viewer again, and I still get the generic Wine icon.

Anyone know why this happen ?

EDIT: Apparently, what I've tried is only working for a few programs, such as Word-Excel-PowerPoint (Installed with the PlayOnLinux installer), and PDF X-Change Viewer.  The bug happen again at logoff.. :S

I've tried to create shortcut from PlayOnLinux on desktop, then drag the shorcut in /usr/share/applications.  I can't get this working for the majority of my programs. :/

Please change to state of the topic as "non-solved" if possible. :(


Ändrat av GameX

Ronin DUSETTE Sunday 24 March 2013 at 20:53

Thats odd, because all of my icons on installers that have resources for things like that work fine. Which window manager are you using? I have used POL a lot on gnome (gnome-panel), kde, and xfce, and all of the icons show up as they should, and work.

In Unity, as the screenshot you have, are you talking about the icon that you click on to start the program, or the icon that shows when the app is running? I have noticed a lot of Wine apps that show the Wine logo when running in certain areas.

Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
GameX Sunday 24 March 2013 at 23:10

Thanks for your reply;

I use Nautilus 3.4.2 on Ubuntu 12.04 LTS, with Unity 3D.
My Wine system version is 1.5.26 and PlayOnLinux is 4.2.

The application in the Dash (I placed a launcher in /usr/share/applications with an icon) does have the correct icon:

But when it's started in the dash, it have a generic Wine icon.

Even when I create a custom launcher with the correct icon and the command :
/usr/share/playonlinux/playonlinux --run "PDF X-Change Viewer" %F

I drag the .DESKTOP file in my Unity launcher bar (At the left). The icon is correct. When I click on the icon, the application open an aditionnal Wine Generic icon (The correct icon is not used). Check this screenshot:
I've clicked on the icon of PDF X-Change Viewer in the launcher, but instead of setting the icon as "opened", it add a new generic Wine icon.

Weird.. :S
Thanks for your help!

EDIT: After a reboot (Due to a crash of Compiz), I've noticed Microsoft Word icon was displayed correctly (Just guessing, I asssume when I'll logoff, it'll revert back to a Wine icon).  However, Photoshop CS6 (Also installed with PoL) still has a Wine icon:

Ändrat av GameX