League of Legends not installing properly

Wasn't working well after updating PoL to 4.2

Författare Svar
izberion Saturday 30 March 2013 at 4:02

Hey guys, when I updated PoL to 4.2, every time I opened League of Legends, the configuring wine window would stay stuck there for a while. The game would eventually launch but not after a few minutes. I decided to just try reinstalling League.

That's where my problem comes in. I can get it to download, but when it goes to launch the set up, I get an error saying PoL crashed and then saying that it couldn't find rads_user_kernel.exe and asks if I installed to the default directory. 

The first time that happened, I had it installing to the default which was to the desktop of the virtual drive. I could run the setup manually and the game would launch, but the icon to launch the game wouldn't appear on the PoL main window with the rest.

I tried installing to the virtual drives C:/ and to Program Files. Both have given the same result. I can launch set up manually, but I'll have to launch the game manually as well.

The only work around is to launch the set up and game manually. Just thought you guys might want to know it might be the new version of PoL, but I can't be sure of it :P
petch Saturday 30 March 2013 at 10:25

This is so confusing, try to reinstall from scratch, keep default settings each time (all but "Launch the game" checkbox at the end of the installation that should be unchecked), and send an automated bug report.
If the installer doesn't suggest to send one at the end of the installation, you can force-send one using Tools > PlayOnLinux debugger > Install scripts > League of Legends > "Report a problem about League of Legends" button.
izberion Saturday 30 March 2013 at 17:38

Ok. I'll try installing again and have it send a report.

EDIT: Alright, I think I've found the problem. The game downloads properly, but the problem I was having was, the installer couldn't find the rads_user_kernel.exe. It's usually somewhere in the Riot Games folder, which gets installed into the c drive.

The problem was, the Riot Games folder ended up in my .wine c drive, not the League of Legends virtual drive. While the game was downloading, I moved it over to the virtual drive and the game installed just fine.

Ändrat av izberion

petch Saturday 30 March 2013 at 20:56

A very, very bad news. Probably the result of trying to switch Wine version to 1.5.24-LeagueOfLegendsShop after download, but still it shouldn't happen (and never happened during my tests).
I'm still expected a bug report with an installation log.

Ändrat av petch

izberion Saturday 30 March 2013 at 21:21

Oh sorry I never got a bug report. An error didn't come up after installing again. And I didn't switch the Wine versions after it downloaded. It was defaulted to 1.5.24-LeagueOfLegendsShop.
petch Saturday 30 March 2013 at 22:52

See above how to generate a bug report, I already described how to generate one.

And it wasn't clear, but I was talking about the script itself switching to 1.5.24-LeagueOfLegendsShop after having run the P2P phase using 1.5.12-LeagueOfLegendsShop (there's a problem with running Pando under Wine 1.5.24).
izberion Sunday 31 March 2013 at 0:30

Well I just tried submitting one with the method you mentioned, wrote it all out, and at the end it said "Sorry we need a detailed description"

So I'm not sure if it went through.
petch Sunday 31 March 2013 at 3:09


This is depressing, I thought I tested it well, yet I broke bug reporting in 4.2.
Without functional tests, without testers and without users trying beta versions and reporting issues (hence without explorative testing), I'm now convinced there no possibility for "bug free" releases, not even an approximation.
izberion Sunday 31 March 2013 at 7:08

Nothing is bug free.
petch Sunday 31 March 2013 at 11:57

Yes, that's why I used quotes, still the severity of the problems left after so much personal testing is depressing. There has to be better ways.