Forum

[BUG] Cannot emulate wine versions below 1.7

Författare Svar
jared Monday 22 December 2014 at 10:53
jaredAnonymous

So far, I have the following wine versions installed: 1.7.31, 1.6.2 and 1.5.28. Only 1.7.31 wine is able to run at all.

To reproduce

  1. Install Wine 1.7.31 and 1.5.28
  2. Configure a virtual drive to use 1.7.31
  3. Click on configure, then the Wine tab
  4. Click on Configure Wine
  5. The wine configuration menu should come up. This is correct behavior.
  6. Change the virtual drive to run on 1.5.28
  7. Repeat Steps 3-4. However, the wine configuration menu fails to appear.

Machine Details:

MacBook Pro (Retina, 13-inch, Mid 2014) OS X Yosemite 10.10.1

Running it in Debug mode, I notice that this line appears when running wine 1.5.28:

Application tried to create a window, but no driver could be loaded.

Make sure that your X server is running and that $DISPLAY is set correctly.

 

Ändrat av jared

Ronin DUSETTE Monday 22 December 2014 at 17:56
Ronin DUSETTE
Admin

Trying to run what?  What exactly are you trying to do? What version of POM? Have you tried making a virtual drive just with 1.5.28? 32 bit or 64 bit Wine? Are you changing anything else not listed? And finally, why are you creating a drive with one version, but switching to another?


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Monday 22 December 2014 at 22:31
petch
Developer

Reinstall XQuartz, newer versions of Wine do work because they no longer use XQuartz

Ronin DUSETTE Monday 22 December 2014 at 22:57
Ronin DUSETTE
Admin

Ooo. Really? When did that happen? I need to get a Mac in the house for testing. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
petch Monday 22 December 2014 at 23:14
petch
Developer

It was announced with the Wine 1.6 release, and I've spotted improvements and bugfixes with almost all the early 1.7.x releases, so picking higher versions may be recommended

Ronin DUSETTE Monday 22 December 2014 at 23:33
Ronin DUSETTE
Admin

Ah. I usually read all of the changelogs, but I must have skipped that one just because it was OSX. I will make sure to keep this in mind. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts