Forum

Photoshop CS2 does not run any more ...

Change of Notebook

Författare Svar
white_rabbit Saturday 28 March 2015 at 21:37
white_rabbitAnonymous

Hi.

I used a Toshiba-NB some days ago and installed Adobe Photoshop CS2 with playonlinux. Everything worked fine and I used Photoshop without any trouble.

Some days ago, I took the SSD-HDD and changed the Notebook from Toshiba to Lenovo (T520) with a wider screen. Everything else ran without problems but Photoshop/Playonlinux doesn't work any more!

The Splash-Screen of Photoshop appears ... and that's it. Some moments later Playonlinux crashes. I also tried to reinstall it ... i also removed ~/.wine and ~./playonlinux already ... I also tried a newer Wine-Verison (1.7.x within Playonlinux) ... BUT: nothing worked!!

I use Kubuntu 14.04.2 with Playonlinux Version: 4.2.2-1 and (System)Wine: Version: 1:1.6.2-0ubuntu4

Here is the debug-File:


[03/28/15 21:34:18] - Running wine- Photoshop.exe (Working directory : /home/user01/.PlayOnLinux/wineprefix/PhotoshopCS2/drive_c/Program Files/Adobe/Adobe Photoshop CS2)
err:shell:HCR_GetFolderAttributes should be called for simple PIDL's only!
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),1,3,(nil),0,(nil)) - stub!
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:wia:wiadevmgr_QueryInterface interface {00000003-0000-0000-c000-000000000046} not implemented
fixme:wia:wiadevmgr_QueryInterface interface {00000003-0000-0000-c000-000000000046} not implemented
fixme:wia:wiadevmgr_QueryInterface interface {00000019-0000-0000-c000-000000000046} not implemented
fixme:thread:start_thread Started native thread 00000040
fixme:thread:start_thread Started native thread 00000041
err:ntdll:RtlpWaitForCriticalSection section 0x7bcc7be0 "loader.c: loader_section" wait timed out in thread 0041, blocked by 0009, retrying (60 sec)
err:ntdll:RtlpWaitForCriticalSection section 0x7bcc7be0 "loader.c: loader_section" wait timed out in thread 0035, blocked by 0009, retrying (60 sec)
err:ntdll:RtlpWaitForCriticalSection section 0x7bcc7be0 "loader.c: loader_section" wait timed out in thread 0039, blocked by 0009, retrying (60 sec)
err:seh:raise_exception Unhandled exception code c0000194 flags 0 addr 0x7bc367d1
err:ole:CoReleaseMarshalData IMarshal::ReleaseMarshalData failed with error 0x8001011d

Any ideas what to do?

 

Ändrat av white_rabbit

Ronin DUSETTE Monday 30 March 2015 at 18:04
Ronin DUSETTE
Admin

 

Some days ago, I took the SSD-HDD and changed the Notebook from Toshiba to Lenovo (T520) with a wider screen. Everything else ran without problems but Photoshop/Playonlinux doesn't work any more!

So, you just took your HD from one computer and just slapped it in another? Did you reinstall your OS? Also, no need to use excalamtion points. It is considered yelling...

Also, you should upgrade POL to the newest version in our Download section. That one that you have is old. The system Wine doesn't matter, so just ignore that. POL uses it's own WineBuilds. 

If you did not reinstall your OS, you need to do that. Other than that, I am not sure what would have happened. A monitor change would not break your system. Simply tossing your HD from a previous install to a completely different computer (likely with dramatically different hardware) would cause all kinds of issues. 

 

The Splash-Screen of Photoshop appears ... and that's it. Some moments later Playonlinux crashes. I also tried to reinstall it ... i also removed ~/.wine and ~./playonlinux already ... I also tried a newer Wine-Verison (1.7.x within Playonlinux) ... BUT: nothing worked!!

Again, please don't use excalamation points... We see that it doesn't work... If you have already reinstalled it and deleted ~/.PlayOnLinux (again, system Wine is irrelevant at this point), then it is something with your OS. Reinstall your OS if you didn't do that FIRST (like, before anything. Fresh, clean install), and then make sure that your drivers are set up correctly. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
white_rabbit Wednesday 1 April 2015 at 13:54
white_rabbitAnonymous

Sorry for "!" -- but as Linux has most of the drivers in its kernel there's no need for a fresh/clean Installation.

Everything else is running fine. I had just these problems with PlayOnLinux. So there's just a very little chance for a new installation here.

But I will try it with the newest Software-version next.

Btw: Of course I also removed (--purge) and reinstalled POL with no success.

(When nothing worked I tried "Codeweavers CrossOver" (not free) -- it worked.)


 

Ändrat av white_rabbit

Ronin DUSETTE Wednesday 1 April 2015 at 18:09
Ronin DUSETTE
Admin

I don't know what to tell you, then. 

Ändrat av RoninDusette


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 1 April 2015 at 19:20
Ronin DUSETTE
Admin

I would try to install CS2 using the CS4 or CS6 installer in PlayOnLinux -> Install. In the Install Window, search for cs4 or cs6, and install that, and when the installer asks for the setup file, tell it to use the cs2 setup file, and see if that helps. 


Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
white_rabbit Wednesday 1 April 2015 at 21:06
white_rabbitAnonymous

YES -- that's it! Worked (again)! Thanks!