Forum

Lancement d'un jeu impossible

"Error in main"

Författare Svar
Ganymède Tuesday 10 October 2017 at 10:04
GanymèdeAnonymous

Bonjour à tou.te.s,

Je découvre tout juste, comme beaucoup, la merveille que construit petit à petit l'équipe de POM-POL. Mais du coup, je n'ai que trop peu de connaissances. Pardonnez d'avance si quelques questions stupides se profilent ici..

Avant tout, mes infos techniques : OSX Yosemite 10.10.5 // Play On Mac 4.2.12

J'ai tenté d'abord et sans succès d'installer manuellement "No Man's Sky". Après avoir longtemps navigué dans le flou et les erreurs de débutants, j'y suis parvenu sans problème (merci les archives trouvées ça et là).

Mais à présent qu'il est correctement installé, le jeu peine à se lancer. 

Vous verrez que, arrivé aux bornes de ma patience et dans un geste de désespoir, j'ai renommé le jeu "FORGODSAKE".. C'est sous ce nom qu'il apparaîtra dans mes captures d'écran et dans les erreurs que je citerais.

Lorsque je tente d'executer le jeu depuis PoM, un message d'erreur s'ouvre immédiatement m'indiquant que le jeu s'est "crashed" et m'invitant à consulter la boîte "Deboguer".

 

Une fois "Deboguer" ouverte, j'y lis ceci :
 

[10/10/17 09:36:43] - Running wine- icon.png (Working directory : /Users/Xanadu/Downloads)

Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!

wine: Mauvais format EXE pour Z:\Users\Xanadu\Downloads\icon.png.

 

Une foultitude de recherches Google (avec tous les termes présents dans le message d'erreur) me mènent vers quelques réponses mais aucune ne semble convenir. Ce message de la boîte "Déboguer" reste inchangé.

Je suis tombé sur ceci, qui m'a permi d'avoir d'autres termes clefs :

Hélas alors que j'essayais cette solution qui semblait si miraculeuse, mon terminal lâcha son impitoyable sentence :


/Library/LaunchDaemons/org.freedesktop.dbus-system.plist: No such file or directory

Et me plongeât dans un désepoir plus épais encore.

Bon, mais les indices donnés par les messages d'erreur ne m'ont pas permis de trouver de réponse concrête ils m'ont mené en revanche à l'installation des choses suivantes avec brew :

  • Dbus
  • XQuartz
  • Daemon 

Mais je ne suis même pas sûr que ça ait été utile, en tout cas rien n'a pu changer d'un poils.

Enfin, je suis allé dans les fichiers cachés à la recherche du Fameux "/Library/LaunchDaemons/org.freedesktop.dbus-system.plist" et en effet, nul dossier à ce nom dans la bibliothèque. "LaunchAgents" existe bien lui, mais ne renferme aucun fichier de ce nom.

Voilà pour moi, j'espère avoir été suffisamment précis et je vous remercie par avance, les gens !

 

 

Tutul Tuesday 10 October 2017 at 21:02
Tutul
Moderator

Aller chercher quelqu'un carrément par message privé XD

Cela dit tu semble avoir mal crée le lanceur du jeu dans POM, on dirait qu'au lieu d'avoir sélectionné le .exe tu as sélectionné le .png

 

PS : tu as de la chance, cela faisait 5 ans que j'était hors du projet ^^" tu me contacte la semaine ou je me reconnecte depuis un bail XD


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Ganymède Wednesday 11 October 2017 at 0:39
GanymèdeAnonymous

Ha ha, disons que j'ai tenté le tout pour le tout !

Merci fois mille de ta reponse aussi rapide qu'inespérée. Mais mon ange gardien semble un peu schizophrène...
Bienvenue chez toi by the way !

A présent que j'ai suivi tes conseils et réglé cette bêtise, un autre problème survient et nargue ma patience :

Le voici en image :

POM m'indique donc que mon disque virtuel est en 32b, alors que durant l'installation j'ai bien choisi le disque comme l'image suivante l'indique :



Voici ce que dit le Débogueur :

[10/11/1700:37:20]-Runningwine-2.18NMS.exe(Workingdirectory:/Users/Xanadu/Library/PlayOnMac/wineprefix/NOMANSKY/drive_c/Program Files/No Mans Sky/Binaries)


Une idée ?

Ganymède Friday 13 October 2017 at 18:17
GanymèdeAnonymous

(avant tout, comme les règles de bienséance l'exigent : pardonnez le double-post)

Hum, les problèmes se résolvent et s'accumulent :

J'ai réussi à intaller NMS sans embuches sur un disque virtuel 64b, j'ai ensuite tenté de le lancer mais un message est apparu en me spécifiant que "steam" n'etait pas en cours. (Pourtant le jeu ne fait pas état d'une dépendance à Steam)

J'ai donc téléchargé et installé Steam sur le même disque virtuel. J'y ai chargé NMS et au moment de le lancer stupeur : un écran rouge s'ouvre quelques seconde et se referme.

Aucun message d'erreur.

Je n'ai vraiment pas d'idée, la carte graphique ?

Tutul Wednesday 18 October 2017 at 22:18
Tutul
Moderator

Pourrais-tu lancer le programme via le menu de debug ? et poster ici le résulta de la console ?


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
Ganymède Monday 23 October 2017 at 5:04
GanymèdeAnonymous

Merci en moult pour ton aide, l'ami ! Hélas, tout est à présent desinstallé.

J'ai découvert la réponse par un chemin absolument évident mais que j'avais délaissé pour des voies plus étriquées. La configuration minimale du jeu et sa comparaison avec la mienne. J'y ai appris que ma carte graphique etait en effet complétement obsolète de ce point de vue "gamer".

Le combat était beau et élégant mais totalement vain. je ne le regrette pas !