Disabling shorcut within application

Författare Svar
R1L3 Sunday 24 December 2017 at 14:04


Hello forum,

I'm using MacOSX, and I have installed game World of Warcraft TBC on PlayOnMac and it works perfect. While I play the game I'm using keybinds like "alt + w" or "alt + tab" which is close to "alt + q" or "alt + F4".  One thing to point out is that "alt" in this game is binded to "cmd" modifier.

Issue is that sometimes while I'm playing the game I accidentally press "alt + q" or "alt + F4" and quit the application. 

I tried following solutions but none of this worked, perhaps if the reason is I miss some step, but:

  • Rebinding the keybinds "alt + q" and "alt + F4"  within Interface of the game is not available as a service at this version of the game :/
  • In BetterTouchTool, I made a new global keyboard shortcut +Q and defined no action
  • In Registry Editor Window, for the HKEY_CURRENT_USER/Software/Microsoft/Windows/Current Version/Explorer, I have created new DWORD with a name NoClose and value 1.

Can you please suggest me the way I can resolve this, so that I can intercept an event for keys "alt + q" and "alt + F4" ?


Ändrat av R1L3

R1L3 Sunday 31 December 2017 at 10:17

Is it possible to do something within windows or not ? - I found AutoHotkey app, can you confirm if this works ?

Ändrat av R1L3