Forum

Half-Life 1 Script Stuck

Doesn\'t detect setup has finished

Författare Svar
rickatnight11 Thursday 10 July 2008 at 15:45
rickatnight11

The Half-Life 1 script at http://www.playonlinux.com/repository/?script=6 has an issue where after it finishes running the setup.exe file from the disk it doesn't know it's finished. The script runs these two lines:

wine d:\setup.exe

POL_SetupWindow_detect_exit

That second one doesn't seem to be detecting that it's finished, because the PlayOnLinux installer just sits at the "Installation en cours" which means "Installation in progress" in French. Is this a bug with the script or an issue with POL's detection?


On a side note, there was an issue where the Setup.exe file wasn't running from the CD. This was due to a limitation of the 16-bit architecture it relied on. If anyone else has the same problem (it won't even load the actual HL1 setup, but just move on and act like it has finished installing) then let me know and I'll post the fix.
rickatnight11 Thursday 10 July 2008 at 15:52
rickatnight11

Just figured out the fix. If you get this problem, open up System Monitor and kill any running processes of winevdm.exe. That is the process that the Setup.exe program runs in. I don't know if this was just an isolated problem I was having, but hopefully this will help anyone else if they have the same problem.
Derringer81 Saturday 28 May 2011 at 20:12
Derringer81

I am having this problem, but on the process list, the only ones i have (that are close) are:

winedevice.exe on waiting channel Pipe Wait
wine server on waiting channel ep_poll

do i kill winedevice?

www.jgs-entertainment.com

Will work for game company as Level Designer.......plz?