Forum

Problème démarrage Playonlinux

Pas de problème d\' installation mais démarrage impossible

Författare Svar
Shakti Monday 4 August 2008 at 2:35
ShaktiAnonymous

Bonjour à tous et à toutes.
J' ai installé PlayOnLinux (en installant directement " playonlinux-3.0.8-1mdv2008.0.noarch.rpm", un .rpm adéquat à ma distribution, Mandriva 2008.0, sur www.rpmPbone.net) mais ce programme ne démarre pas chez moi et quand je le lance en ligne de commande j' obtiens le message suivant :

which: no ar in (/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/us
which: no cabextract in (/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local
Traceback (most recent call last):
File "/usr/share/playonlinux/python/message.py", line 20, in <module>
wxversion.select("2.8")
File "/usr/lib/python2.5/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found")
wxversion.VersionError: Requested version of wxPython not found


L' installation s' est déroulée sans problème ni message d' erreur mais j' ai quand même essayé de regarder aux paquetages et cherché à propos de "wxversion" et wxPython mais aucun des paquetages que 'j ai pu essayé d' installer ne m' a apporté la solution et, étant un newbie, je dois avouer ne rien comprendre à ce message d' erreur.

Au cas où, même si je ne suis pas sûr de voir le lien, précisons que je travailles sur sessions KDE.

Ce message d' erreur vous évoquerait-il quelque chose ?
Faut-il installer des plugins spécifiques ou autre chose pour corriger cela ?

Merci d' avance pour vos réponses.
Zoloom Monday 4 August 2008 at 4:24
ZoloomAnonymous

Oui ce message est tristement connu, il signifie que tu ne possède pas wxpython et wxversion.

J'ai trouvé ça :

http://dir.filewatcher.com/d/Mandrake/2008.0/i586/Development/Python/wxPythonGTK-wxversion-2.8.4.2-2mdv2008.0.i586.rpm.14854.html

J'ai l'impression que c'est un paquet unifié en fait (peut être la raison pour laquelle tu ne les a pas trouvé individuellement).

En espérant que ça puisse t'aider, sinon attend un mandrivien capable de t'aider...

Ändrat av Zoloom


Shakti Monday 4 August 2008 at 5:11
ShaktiAnonymous

Bonjour Zoloom et merci de ta réponse (qui a au moins le bon point de répondre à mes interrogations annexes) mais malheureusement elle ne m' avance en fait pas plus : ce paquet (wxPythonGTK-wxversion, version 2.8.4.2) est déja installé sur mon ordinateur.

En vérité, c' est le seul paquetage que j' ai cru identifié (et suis bien content que tu me confirmes que cela ne fut pas insensé, je m' attendais effectivement à trouver un paquet non groupé ne contenant que "wxversion") et ai donc installé en conséquence : malheureusement cela n' a pas fait disparaitre le message d' erreur (d' où ma crainte de pas avoir identifié le bon paquetage) et l' a en fait "étoffé" il me semble; je crois en effet me souvenir que 2 ou 3 lignes du message d' erreur déja cité sont apparues après l' installation de "wxpython-wxversion".

Zoloom Monday 4 August 2008 at 5:31
ZoloomAnonymous

Aïe. Quand les numéros de versions s'en mêlent...

Et le rpm en question ne t'as pas télécharger toutes les dépendances ?

Je viens de voir qu'il te manque le paquet cabextract aussi !

Essaye ça, en fait je crois que le soucis vient de wxPython (c'est la 2.6 alors que POL veut la 2.8) : http://downloads.sourceforge.net/wxpython/wxPython2.8-gtk2-unicode-2.8.8.1-fc7_py2.5.i386.rpm

Tiré du site officiel (je croise les doigts).

Ändrat av Zoloom


Shakti Saturday 20 September 2008 at 22:55
ShaktiAnonymous

Bonsoir.
Alors, déja je te remercies Zoloom car j' ai pu installer cabextract et résoudre cette partie du message d' erreur qui est devenu :
"which: no ar in (/usr/bin:/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/qt3//bin:/home/julien/bin:/usr/lib/qt3//bin)
Traceback (most recent call last):
File "/usr/share/playonlinux/python/message.py", line 20, in <module>
wxversion.select("2.8")
File "/usr/lib/python2.5/site-packages/wxversion.py", line 149, in select
raise VersionError("Requested version of wxPython not found")
wxversion.VersionError: Requested version of wxPython not found
"
J' essayes d' installer spécifiquement le paquetage que tu me proposes, Zoloom, mais je galères à cause des dépendances. Je sais pas si c' est du à une source inadéquate ou au fait que mes paquetages habituels sont .i586 mais urpmi ne résout pas automatiquement ces problèmes.

Ändrat av Shakti

Aymeric P. Friday 26 September 2008 at 16:29
Aymeric P.
Admin

Salut.
Essaye d'installer le rpm présent sur mon site ( http://www.mulx.net/rpm/ ) qui est un rpm contenant les dépendances.

Je vais refaire les paquets pour PlayOnLinux sur Mandriva (3.1)

Former member.
Shakti Saturday 27 September 2008 at 16:40
ShaktiAnonymous

Yihaaa !!!
Merci MulX pour ton aide : j' ai plus de messages d' erreur ni de dépendances non résolues lors du démarrage.
J' ai pas pu encore essayer playonlinux : le démarrage ne lance toujours pas le programme mais le problème semble maintenant venir d' une question de pilote pour l' affichage (j' utilises une ATI RADEON 9600, au début j' avais, comme pour google earth, un message d' erreur disant en gros que mon driver ne supporte pas visual00x4c ou un truc du genre que j' ai lu par ailleurs signifier un non-support du 24 bits, message que je n' ai plus depuis que j' ai installé "fglrx", "dkms-fglrx" et "x11-....-fglrx" mais toujours pas de succès au démarrage).
En tout cas, je n' ai plus de messages d' erreur et te remercies de ton paquetage de résolution des dépendances MulX.
Encore merci à toi et à Zoloom pour vos lumières.

Ändrat av Shakti