Forum

CSS acceleration 3D

Författare Svar
Sudo-taku Friday 15 January 2010 at 19:58
Sudo-taku

Processeur: AMD AhtlonX2 6000 +
memoire vive: 2X2Go G-skill (DDR2-800 PC2-6400 CL5)
écran 19" 16/10ème 1440x900 75Hz
carte graphique: ATI Sapphire HD 4850 series
Ubuntu karmic koala (64bits), mises a jours et connexion internet, ok


Bonjour,
j'ai installer ubuntu 64 bits (marre de WinXP 32bits), le pilote propriétaire fglrx ...
Ensuite j'ai découvert, Play on linux qui est compatible avec steam et ces jeux.
Jusque la tout va bien, téléchargement de CSS sur steam, installation de CSS dans play on linux.
Le jeux se lance, mais ne semble pas prendre en compte ma carte graphique, il tourne entre 30-40fps et il sacade, contre 150 fps stable sous WinXP avec une bonne qualité graphique.

J'ai vu aussi que direct X posait problème, je suis passé du 9 au 8.1 c'est mieux.
J'ai aussi essayer diverse versions de Wine proposer dans PlayOnLinux, qui sont citer dans le forum, la 0.9.60 est la plus stable mais de pas grand chose :D le jeux reste instable.

j'aimerais que quelqu'un m'explique, je sais modifier les fichier et je comprend vite la logique, mais il me faut les mot-clé, par exemple dans:
/home/(user)/.PlayOnLinux/Steam_games/css-in.reg
J'ai repérer que l'on pouvais paramétrer manuellement Wine pour ce jeux.

Il doit surement y avoir un moyen de lui faire accepter ma carte graphique ?

le fais que Ubuntu soit en 64bits, ne gène en rien ?

Sudo-taku Friday 15 January 2010 at 20:19
Sudo-taku

j'ai bidouiller un peut css-in.reg, c'est mieux je vais essayer de configurer dans CSS pour le gain fps parce que la c'est pas géniale, les 40-50fps me suffise pas, je vais me faire plomber a chaque fois :p

BlondVador Friday 15 January 2010 at 21:44
BlondVador
Moderator

j'ai bidouiller un peut css-in.reg, c'est mieux je vais essayer de configurer dans CSS pour le gain fps parce que la c'est pas géniale, les 40-50fps me suffise pas, je vais me faire plomber a chaque fois :p

Quote from Sudo-taku



Euh.. l'oeil humain ne peut pas distinguer plus de 24 FPS...

Sudo-taku Friday 15 January 2010 at 23:35
Sudo-taku

<HS-on>
En théorie ouais, mais si j'overclock mon cerveau ? :-°
<HS-off>

De toute façon tu a raison, mon écran tourne a 75 Hz, donc c'est inutile d'aller au dessus de 75 fps, non ?

sinon tu saurais me dire quel commande je peut utiliser dans css-in.reg ?
y a t-il un autre fichier plus important a regarder dans mon cas ?

Ändrat av Sudo-taku


Sudo-taku Saturday 16 January 2010 at 17:50
Sudo-taku

j'ai changer dans css-in.reg:
"DirectDrawRenderer"="opengl"
par:
"DirectDrawRenderer"="fglrx"
graphiquement c'est mieux, mais il semblerais que le reste, les sacade, les crash ne vienne pas de ma carte graphique mais plutôt du reste, mémoire vive et processeur .

donc je repose ma question, es-que, être sous linux 64bits change quelque chose pour wine et PlayOnLinux ?

Sudo-taku Saturday 16 January 2010 at 18:23
Sudo-taku

j'avais remis directX 9, j'ai remis en 8.1, donc plus de saccade, j'ai réussi a me connecter a un serveur pendant 3 seconde :D

Mais enfaite changer openGL par fglrx ne change rien.

le problème des crash du jeux persiste, UP s'il vous plait ! :incertain:

Ändrat av Sudo-taku


BlondVador Saturday 16 January 2010 at 20:36
BlondVador
Moderator

j'avais remis directX 9, j'ai remis en 8.1, donc plus de saccade, j'ai réussi a me connecter a un serveur pendant 3 seconde :D

Mais enfaite changer openGL par fglrx ne change rien.

le problème des crash du jeux persiste, UP s'il vous plait ! :incertain:

Quote from Sudo-taku


As-tu bien installé le jeu avec le script d'installation fournis par POL ?

Essaye d'utiliser Wine 1.1.35 pour CS:S et d'utiliser Alsa comme pilote audio.


Sudo-taku Sunday 17 January 2010 at 18:28
Sudo-taku

merci de me répondre,

oui, je l'avais installer avec le script d'installation fournis par POL, pour le version de Wine, j'ai essayer la version 1.1.35 mais le jeux se lance pas sous POL.
il n'y a qu'avec la version 0.9.60 de Wine que je peut espérer voir apparaître le jeux avant le crash.

alsa y est déjà par défaut et le son fonctionne.

BlondVador Sunday 17 January 2010 at 21:14
BlondVador
Moderator

merci de me répondre,

oui, je l'avais installer avec le script d'installation fournis par POL, pour le version de Wine, j'ai essayer la version 1.1.35 mais le jeux se lance pas sous POL.
il n'y a qu'avec la version 0.9.60 de Wine que je peut espérer voir apparaître le jeux avant le crash.

alsa y est déjà par défaut et le son fonctionne.

Quote from Sudo-taku


Dans ce cas, le problème est :

carte graphique: ATI Sapphire HD 4850 series

Citat


Les cartes ATI sont très mal supportées, surtout les cartes récentes.

Sudo-taku Monday 18 January 2010 at 17:50
Sudo-taku

D'accord, je m'en doutait au début, donc je suis loin de pouvoir désinstaller winXP de mon ordinateur :sad:

merci quand même