Can't launch steam games, they crash after ~6sec

Författare Svar
Denieru Sunday 21 November 2010 at 12:06


I've got a problem with ALL of my Steam games! I've tried HL2, TF2, Garry's Mod and CSS. But it just doesn't work! The dialog that says "Preparing Start of Garry's Mod" comes up and by profile picture's border become green so it says I'm in game, then the dialog dissapears, and after around 6 seconds it says I'm not in game.

I'm running PlayOnLinux and the problem started occuring after I upgraded to 3.8.6 yesterday.
This is the terminal output I get

I'm using wine 1.3.7 but I've also tried with 1.2.0. I run it in Win XP mode but I've also tried Win 7, doesn't get any better at all.

I also had a POL 3.8.3 deb and I tried downgrading, but it didn't work, for some reason POL didn't launch but upgrading to 3.8.6 again worked.


Ändrat av Denieru

Denieru Sunday 28 November 2010 at 10:50

Okay here's how to solve it:

Pull up winecfg then go to the Libraries tab. Add a new one with the name 'gameoverlayrenderer' and set it to disabled.