Forum

Instalation Orbiter2010

Probleme de lancement.

Författare Svar
maskimer Thursday 16 June 2011 at 15:33
maskimerAnonymous

Bonjours a tous

Voila cela ne fait que quelques jours que je connait wine et play on mac, j'ai naturellement essayé de faire fonctionner un simulateur de vol nommé Orbiter qui tourne a la base sur XP,VISTA.
Bien évidement je rencontre quelques problèmes c'est pour ça que je sollicite votre aide.

Tout d'abord j'ai connu wine et j'ai installé la v.1.1.44 avec winebottler. là déjà j'ai quelque soucis de compréhension de choses comme les préfixes, je ne comprend pas non plus la logique des emplacements( lorsque je crée un préfixe je ne le retrouve plus ) ... enfin bref c'est pas encore ça!

Ensuite j'ai connue POM v.2.4.5, j'ai donc actuellement wine et POM qui tournent

Ce que j'ai réussi a faire donc c'est d’installer mon programme ( en bidouillant je ne sais combien de fois j'ai crée une icône qui lance l'appli ), ça commence a tourner et au lancement de la fenêtre la vérification du directX dit: failled
j'arrive jusqu'au chargement de la fenêtre de simulation (qui déjà est a l'envers), ça charge très lentement et après j'ai un message qui me dit que l'appli doit fermer a cause d'un problème.

j'ai un gros message de la console a ce moment là, et je sais pas trop ou regarder, j'ai vue une ligne :

###ERROR### Command '/Applications/Wine.app/Contents/Resources/bin/wine /Users/maskimer/Orbiter2010/orbiter.exe' returned status 53.
Task returned with status 15.


??

Orbiter c'est un simu freeware qui tourne avec :

Windows 98/2000/XP/Vista
1.2 GHz Pentium or equivalent processor
512 MB system RAM
DirectX 7 or newer
DirectX compatible graphics card with 64 MB of memory
Approx. 120 MB free hard disk space for minimum installation.

http://orbit.medphys.ucl.ac.uk/download.html

je tourne sur macbook pro I7 2.66GHz

On peut soit le déziper dans un dossier et utilisé directement le fichier .exe dans le répertoire d'origine soit alors l'installer avec un fichier .msi (sous window naturellement)

c'est la deuxième méthode que j'ai utilisé pour arriver a ce résultat en l'installant avec POM

J'espère que mon explication sera clair, merci d'avance pour vos réponses

Ändrat av maskimer

Tutul Thursday 16 June 2011 at 15:59
Tutul
Moderator

1- Déjà, je te conseille de désinstaller wine et de ne garder que POM...
2- Après tu vas dans le gestionnaire de version de Wine (dans le menu Outils)
3- Et tu cherche la version 1.3.14 que tu installe (en cliquant sur ajouter)
4- Ensuite tu lance une installation manuel ( bouton Installer -> Installer une application non supportée ).
5- Ensuite tu sélectionne Installer une application sur un nouveau préfix et tu tape un préfix (le nom de ton programme par exemple)
6- Tu coche les deux propositions
7- Pour la version de Wine, tu sélectionne 1.3.14
8- Sur le panneau de configuration, tu vérifie que se soit bien Windows XP et tu vas également dans l'onglet Affichage où tu décoche le deuxième et le troisième paramètre (Permettre au gestionnaire blablabla...)
9- Tu cherche ton installateur et tu lance l'installation
10- Ensuite tu créé un raccourci avec le nom de ton jeu (tu devra chercher le programme de lancement du jeu et donner un nom pour le raccourci)
11- Normalement tu aura ton raccourci sur ton bureau et sur le menu de POM... Tu le teste et tu dis quoi :D

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
maskimer Thursday 16 June 2011 at 18:18
maskimerAnonymous

merci pour ton aide, j'ai suivit comme il faut tes conseils, mais malheureusement ça ne fonctionne pas.

j'ai donc suprimé wine et winebottler puis réinstallé POM,

Ensuite je suis la procédure ( version wine, config, instal..) et j'arrive a créer un raccourcis (avec le bon .exe ) mais celui ci ne fonctionne pas (c'est a dire que rien ne se passe)

j'ai fait plusieurs test en changeant le dossier source du programme de place dans le répertoire via l’installateur du programme et je suis arrivé a refaire se lancer la fenêtre d'initialisation du jeu qui me dit que j'ai toujours le même problème avec le directX.

Ensuite je lance la fenêtre de simulation, là ya du changement parce que maintenant l'image et les texte de chargement sont a l’endroit mais j'ai toujours le plantage final sans la console cette fois ci.

Y'a t'il d'autres solutions ou dois je me résoudre a installer bootcamp?

Merci encore
Tutul Thursday 16 June 2011 at 19:05
Tutul
Moderator

j'ai toujours le même problème avec le directX

Quote from maskimer

Dans le menu installer -> Autre -> PlayOnLinux Functions -> Tu choisi ton préfix -> Tu coche "POL_Install_d3dx9" ou "POL_Install_d3dx10" (le meilleur pour ton jeu) -> Tu suit ce que te dis POM...
Sinon, ouvre la console de POM et tape bash ton_nom_utilisateur/Library/PlayOnMac/Configurations
/installed/le_nom_du_raccourci_de_ton_jeu
et tu valide :sunglasses:

Lorsque le jeu va planter, wine vas afficher un rapport sur le bug, copie le ici !

Ändrat av Tutul


Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
maskimer Thursday 16 June 2011 at 21:08
maskimerAnonymous

Alors j'ai installé le direct x 10 et la du coup ça a réussit a charger, pas non plus de message d'alerte sur le direct X, par contre ça fonctionne mais alors ça lag énormément.

j'ai voulut changer de version de direct X en en essayant d'autre mais le résultat est plutôt médiocre vue que maintenant ça ne marche plus. Ça replante au milieu du chargement et j'ai pas de rapport sur le bug, juste une fenêtre qui me dit que le programme a rencontré un problème sérieux et doit fermer (comme au début), là je doit quitter X11 pour fermer la fenêtre.

Au bout d'un moment (lors de la mise a jours de la base de registre de wine ) j'ai aussi un message qui me dit qu'il me manque le client Gecko, elle me demande si je veux l'installé, je dit oui, j'ai même essayé de l'installer via play on linux dans POM car le message était redondant.

Dois je réinstaller avec le bon directX ?
Tutul Friday 17 June 2011 at 7:37
Tutul
Moderator

le client Gecko est constament demandé par Wine et certaine version de Wine ne peuvent plus trouver la version de Gecko qu'il utilise...
Ce n'est pas grave vu que c'est uniquement pour les application HTML !
Je te conseille de remettre DirectX 10 vu que ça fonctionnait et diminue tes option graphique pour voir si sa lag encore.

Gentils modérateur dans mes bon jours - Attention, à tenir hors de portée des enfants. En cas de contact, veuillez immédiatement rincer à l'eau clair. Peut provoquer des sueurs froide !
maskimer Friday 17 June 2011 at 21:17
maskimerAnonymous

ok merci beaucoup pour les infos

Je teste ça la semaine prochaine et je revient prévenir de la suite de mes déboires,
En attendant bonne continuation et encore merci.