Forum

Lancer Wow sur autre Display

Författare Svar
Fish Moon Monday 31 December 2007 at 14:41
Fish MoonAnonymous

Bonjour, bonjour,

voilà après bien des péripéties Wow est installé et fonctionne, mais j'ai un Fps trés treéééés lent.
Au passage j'ai un peu up ma config mais ça ne change rien

En suivant un tuto j'ai essayé de lancer Wow sur autre display avec ce fichier:

#!/bin/sh
X :3 -ac & # Lance une nouvelle session X sur le display 3
### ATTENTION pour les utilisateurd'ubuntu
###ici il faut remplacer la ligne par sudo X :3 -ac &

cd "/home/fish/.PlayOnLinux/wineprefix/WorldOfWarcraft" # se positionne dans ton repertoire d'install de WoW
sleep 2 # fait patienter le systeme 2 seconde pour etre sur que la session X est prete
DISPLAY=:3 /usr/bin/wine WoW.exe -opengl # Lance WoW en mode opengl a l'aide de wine sur le display 3


Le display s'initialise mais j'ai un message d'erreur:
wine: could not load L"c:\\windows\\system32\\WoW.exe": Module not found

Donc je présume que je n'ai pas la bonne commande pour lancé Wine/wow Si quelqu'un peux me venir en aide ce serait sympa.




On est le 31 donc Bon réveillon à tous !

PS: j'ai fait la modif dans la base de registre suivante :
1. Entrez la commande regedit dans une console, une fenêtre hideuse apparaît avec une liste de dossiers qui commencent tous par HKEY.
2. Allez dans HKEY_CURRENT_USER → Software → Wine.
3. Cliquez-droit sur le dossier Wine → Nouvelle → Clé
4. Nommez-le dossier (la clé) OpenGL
5. Cliquez-droit sur le dossier OpenGL → Nouvelle → Valeur Chaîne
6. Nommez cette chaîne DisabledExtensions puis double-cliquez dessus
7. Remplissez le champs "Données de la valeur" avec GL_ARB_vertex_buffer_object (Si vous ne voyez pas de différences essayez GL_ARB_vertex_buffer_object2)
Mais toujours pas mieux...

---------------------------------------------------------------------
Wine 0.9.44 - 0.9.51 assigné à Wow
Mandriva PowerPack 2008
Athlon XP 2400+
Ram 2Go (anciennement 1Go)
Geforce A7600 GT TDH (anciennement GeForce 4 Ti 4200)
tuxnux Monday 28 September 2015 at 15:35
tuxnuxAnonymous

cd /home/fish/.PlayOnLinux/wineprefix/WorldOfWarcraft/World\ of\ Warcraft

DISPLAY=:3 env WINEPREFIX="/home/fish/.PlayOnLinux/wineprefix/WorldOfWarcraft/usr/bin/wine WoW.exe -opengl

quand a l'option -opengl

tu edites /ou est World of Warcraft/WTF/Config.wtf

tu cherches SET gxApi "dx... "que tu remplaces par

SET gxApi "OpenGL"

ce qui permet de lancer wow.exe sans option

 

 

Ändrat av tuxnux

petch Monday 28 September 2015 at 17:13
petch
Developer

Pour lancer un programme géré par PlayOnLinux, on peut (sauf si on veut refaire son travail pour le fun) lancer un programme par

playonlinux --run "Nom du raccourci"