Blackscreen in OpenGL 32-bit games in amd64

Författare Svar
ric-ardo21 Monday 30 July 2012 at 3:39

I use PlayOnLinux 4.1.3 in Debian Sid amd64 with AMD propietary drivers.
When i play a OpenGL game, like Portal (I tried something OpenGL rendering games), appears a blackscreen but I can move the cursor and ear the menue music. DirectX games works fine.
I installed the packages of propietary drivers for AMD graphics cards

The problem sould be solved installing the 3D acceleration for 32 bits packages but the problem persists.

I tried the versions 1.4.1 and 1.5.9 of wine with no satisfatory results.
I installed vcrun 2005, vcrun 2008, vcrun 2010, dotnet35 (and d3dx9) but I think unnecessary for this game in particular.
Any help is welcome.
Thanks in advance and sorry if my english is bad.
petch Monday 30 July 2012 at 9:07


Just as a check, can you type

wine --version

in a terminal?
Not sure it could result in a black screen, but there have been a lot of changes in ia32-libs lately in Sid...

Ändrat av petch

ric-ardo21 Tuesday 31 July 2012 at 4:07

Hi, thanks for comment. Typin #wine --version appears:

[code=console]#wine --versionThis is the wine64-bin helper package, which does not provide wine itself,but instead exists solely to provide the following information aboutenabling multiarch on your system in order to be able to install and runthe 32-bit wine packages.
The following commands should be issued as root or via sudo in order toenable multiarch (the last command installs 32-bit wine):
  # dpkg --add-architecture i386  # apt-get update  # apt-get install wine-bin:i386
Depending on which Debian release is present on this system, the developmentversion of wine may be available, which if available can be installed with:
  # apt-get install wine-bin-unstable:i386
Note that this package (wine64-bin) will be removed in the process.  Formore information on the multiarch conversion, see:[/code]

I have not said before, recently I activated multiarch support and the version of packages ia32-libs and ia32-libs-gtk
are 20120102, for testing branch because update this packages creates dependency problems in this moment.

I will not uninstall wine64-bin. I don't know if the problem is caused by libfglrx-ia32, fglrx-glx-ia32 or ia32-libs.

Ändrat av ric-ardo21

ric-ardo21 Sunday 5 August 2012 at 23:47

Finally, I solved the probem (halfway).
Running these games with wine on the console works but with playonlinux the graphics not work.
legluondunet Tuesday 7 August 2012 at 15:43

I have an AMD graphic card and some games launch with black screen (Tomb Raider anniversary, Tom Raider Legend, Rayman origins). In POL, I made differents tests and this configuration works for me:
disable GLSL
choose Opengl for direct draw

If it's not enough, disable strict draw, multiple sampling, rendre mode too and try with different wine version.

Good luck!