Jedi Knight II Outcast

Författare Svar
legluondunet Sunday 5 August 2012 at 12:16


could someone tell me if he can run Jedi Knight II Outcast and what config it uses?

For my part, whatever I do, it does not work: crashes at startup. I think about open a bug on the website of Wine.

Thank you.

Jedi Knight 1.04 (or 1.02 is the same result)
Ubuntu 64bit
AMD Radeon 7850
Intel processor
Quentin PÂRIS Sunday 5 August 2012 at 13:32
Quentin PÂRISAnonymous

Please paste your debug log.

Next time, please post in the good forum. Thank you
legluondunet Sunday 5 August 2012 at 17:05

hello Quentin, this is a fresh error log:

[08/05/12 16:58:14] - Running wine-1.5.10 jk2sp.exe (Working directory : /home/legluondunet/.PlayOnLinux/wineprefix/JKII/drive_c/Program Files (x86)/LucasArts/Star Wars JK II Jedi Outcast/GameData)
wine: Unhandled page fault on read access to 0x6e696b6f at address 0x6e696b6f (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x6e696b6f in 32-bit code (0x6e696b6f).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:6e696b6f ESP:01e1eb88 EBP:01e1fd5c EFLAGS:00210206( R- -- I - -P- )
EAX:65765f67 EBX:00000000 ECX:01e1db50 EDX:01e1f0bd
ESI:00a862d8 EDI:ffffffff
Stack dump:
0x01e1eb88: 65765f67 78657472 5f4c4720 5f545845
0x01e1eb98: 63736572 5f656c61 6d726f6e 47206c61
0x01e1eba8: 58455f4c 65735f54 646e6f63 5f797261
0x01e1ebb8: 6f6c6f63 4c472072 5458455f 7065735f
0x01e1ebc8: 74617261 70735f65 6c756365 635f7261
0x01e1ebd8: 726f6c6f 5f4c4720 5f545845 64616873
=>0 0x6e696b6f (0x01e1fd5c)
1 0x00440f0b in jk2sp (+0x40f0a) (0x01e1fe70)
2 0x7b85cc0c call_process_entry+0xb() in kernel32 (0x01e1fe88)
3 0x7b8601ab in kernel32 (+0x501aa) (0x01e1fec8)
4 0x7bc717b0 call_thread_func_wrapper+0xb() in ntdll (0x01e1fed8)
5 0x7bc71a0d call_thread_func+0x7c() in ntdll (0x01e1ffa8)
6 0x7bc7178e RtlRaiseException+0x21() in ntdll (0x01e1ffc8)
7 0x7bc4c57e in ntdll (+0x3c57d) (0x01e1ffe8)
0x6e696b6f: -- no code accessible --
Module     Address               Debug info     Name (71 modules)
PE      400000- 1614000     Export jk2sp
PE     10000000-10020000     Deferred ffc10
ELF     792c6000-7b800000     Deferred
ELF     7b800000-7ba2c000     Dwarf kernel32
\\-PE     7b810000-7ba2c000     \\ kernel32
ELF     7bc00000-7bcc2000     Dwarf ntdll
\\-PE     7bc10000-7bcc2000     \\ ntdll
ELF     7bf00000-7bf03000     Deferred
ELF     7e0c8000-7e121000     Deferred
ELF     7e184000-7e1a2000     Deferred
ELF     7e1a2000-7e28a000     Deferred
ELF     7e2ad000-7e36d000     Deferred opengl32
\\-PE     7e2c0000-7e36d000     \\ opengl32
ELF     7e3b7000-7e3f4000     Deferred usp10
\\-PE     7e3c0000-7e3f4000     \\ usp10
ELF     7e40a000-7e410000     Deferred
ELF     7e410000-7e41b000     Deferred
ELF     7e41c000-7e424000     Deferred
ELF     7e495000-7e4bf000     Deferred
ELF     7e4bf000-7e4f3000     Deferred
ELF     7e4f3000-7e503000     Deferred
ELF     7e503000-7e50c000     Deferred
ELF     7e50c000-7e516000     Deferred
ELF     7e516000-7e51c000     Deferred
ELF     7e51c000-7e53d000     Deferred imm32
\\-PE     7e520000-7e53d000     \\ imm32
ELF     7e53d000-7e55e000     Deferred
ELF     7e55e000-7e692000     Deferred
ELF     7e692000-7e6a4000     Deferred
ELF     7e6a4000-7e6be000     Deferred
ELF     7e6be000-7e747000     Deferred winex11
\\-PE     7e6d0000-7e747000     \\ winex11
ELF     7e747000-7e75d000     Deferred
ELF     7e75d000-7e7f7000     Deferred
ELF     7e81a000-7e841000     Deferred msacm32
\\-PE     7e820000-7e841000     \\ msacm32
ELF     7e841000-7e8ef000     Deferred winmm
\\-PE     7e850000-7e8ef000     \\ winmm
ELF     7e8ef000-7e965000     Deferred rpcrt4
\\-PE     7e900000-7e965000     \\ rpcrt4
ELF     7e965000-7ea6b000     Deferred ole32
\\-PE     7e980000-7ea6b000     \\ ole32
ELF     7ea6b000-7eacd000     Deferred advapi32
\\-PE     7ea80000-7eacd000     \\ advapi32
ELF     7eacd000-7eb8b000     Deferred gdi32
\\-PE     7eae0000-7eb8b000     \\ gdi32
ELF     7eb8b000-7ecc9000     Deferred user32
\\-PE     7eba0000-7ecc9000     \\ user32
ELF     7ecc9000-7ed12000     Deferred
ELF     7ed12000-7ed16000     Deferred
ELF     7ed16000-7ed1d000     Deferred
ELF     7ed1d000-7ed35000     Deferred version
\\-PE     7ed20000-7ed35000     \\ version
ELF     7ed35000-7ed50000     Deferred openal32
\\-PE     7ed40000-7ed50000     \\ openal32
ELF     7ef75000-7ef82000     Deferred
ELF     7ef82000-7ef8e000     Deferred
ELF     7ef8e000-7efa8000     Deferred
ELF     7efa8000-7efb1000     Deferred
ELF     7efb1000-7efdd000     Deferred
ELF     7efdf000-7efe3000     Deferred
ELF     7efe3000-7efe7000     Deferred
ELF     7efe7000-7eff0000     Deferred
ELF     7eff0000-7eff9000     Deferred
ELF     f7440000-f7446000     Deferred
ELF     f7447000-f744c000     Deferred
ELF     f744c000-f75f1000     Deferred
ELF     f75f1000-f760c000     Deferred
ELF     f7630000-f7771000     Dwarf
ELF     f7773000-f7795000     Deferred
ELF     f7795000-f7796000     Deferred [vdso].so
process tid prio (all id:s are in hex)
00000008 (D) C:\\Program Files (x86)\\LucasArts\\Star Wars JK II Jedi Outcast\\GameData\\jk2sp.exe
     00000009 0 <==
0000000e services.exe
     0000001f 0
     0000001e 0
     00000018 0
     00000017 0
     00000015 0
     00000010 0
     0000000f 0
00000012 winedevice.exe
     0000001c 0
     00000019 0
     00000014 0
     00000013 0
0000001a plugplay.exe
     00000020 0
     0000001d 0
     0000001b 0
00000021 explorer.exe
     00000022 0

Thanks for your help.
Quentin PÂRIS Sunday 5 August 2012 at 18:52
Quentin PÂRISAnonymous

Why don't you use the Jedi Knight II script?
legluondunet Sunday 5 August 2012 at 23:53

Wrong alert, my cd install has a problem, thanks for your help.
legluondunet Tuesday 7 August 2012 at 12:14

Finally it's not a cd problem, it's an incompatibility with AMD radeon drivers, I currently use the 12.6 version with a radeon 7850. If I remove the catalyst drivers and use the open source one, I can launch the game but the performance are bad. It's definitely not a playonlinux bug, so I will report a bug on wine bugzilla.

PS: Quentin, I firstly used POL script and then manually, always the same issue.

Ändrat av legluondunet

legluondunet Thursday 9 August 2012 at 10:33

After tried a lot of solutions found all over the Jedi Knight crash threads on internet, I finally found one that works for me:

most games based on the Quake 3 engine have this error on newer graphic cards. The buffer overrun happens when the game engine asks the graphic driver for a list of supported OpenGL extensions. The faulty game engine doesn't allocate enough memory for the extension list

To fix it:
Backup the executable. Open the executable in a hex editor (I used Ghex). Find the string "GL_EXTENSIONS: %s" and change it to "GL_EXTENSIONS: %p".

Do this for jk2sp.exe and jk2mp.exe.

Start the game, single or multiplayer, no more crash!!!

I tried the same operation with the steam version but when I launch the game, I obtain an error message from steam: error code 51. Perrhaps a steam internal security that detects modified exe?...

Hope this help.

Ändrat av legluondunet