Das Forum

[Script] Civilization V

Teehee

Autor Antworten
Jump to the page: 1 - 2 - 3 - 4 - 5
alcorsepol Wednesday 24 July 2013 at 11:20
alcorsepolAnonymous

@DJYoshaBYD: If you have an icon that you can set for Civ V then I think you should do so, since the PNG error is currently present when installing with Steam (POL doesn't like som icons it seems?)


EDIT: oh and another thing!

When I edited your script and added the Steam support, it seems that I also undid one of your changes. The change from Civ5 to Civilization5 in the prefix changed. Thought I'd let you know :)

Editiert von: alcorsepol

purno Wednesday 24 July 2013 at 18:43
purnoAnonymous

In response to my earlier problem with starting Civ5: after a full uninstall including virtualdrive and a complete reinstall it works again.
So I'm not sure what happened, but very glad it works again ;)
steve723 Wednesday 24 July 2013 at 19:00
steve723Anonymous

I found I was able to change the dispalyed icon by right clicking on it.Select set the icon. then navagat to $HOME/.PlayOnlinux/wineprefix/Civ5/drive_c/Program Files/Steam/SteamApss/common/Sid Meier's Civilization V/. Select Ci5icon.ico. You stilll get the PNG error message when you click on it, but at least it looks right now.
Ronin DUSETTE Wednesday 24 July 2013 at 20:21
Ronin DUSETTE
Admin

I dont get the PNG error at all, but Im also not running an experimental version of Ubuntu, so that is why you get the error. Experimental libpng comes default in 13.04.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Wednesday 24 July 2013 at 21:02
steve723Anonymous

I wounder if the new wine version 1.6 that came out on July 18, 2013 would enable this game to work better? I was just reading the wine release email from Alexandre Julliard, that I subscribe to and thought that since there are so many changes that it might be worth trying for Civ5.
Ronin DUSETTE Wednesday 24 July 2013 at 21:14
Ronin DUSETTE
Admin

It has nothing to do with Wine. The error may stop showing up with the new version, yes, but it still doesnt change the fact that its a bleeding-edge package that isnt fully compatible. It has to do with you OS having a version of libpng installed that causes this error. 12.04 LTS does not come with this package, as its an experimental package, and this error is non-existant on LTS machines, from what I have seen (unless you are running bleeding-edge repo's).

1.6 is a great milestone, and if it makes the error stop coming up, great. That doesnt change the fact that you have an incompatible lib on your system. The error goes away, but issue is still there.

Feel free to install Civ5 and after the install, switch it to 1.6 and see if it makes a difference. But really, changing the script because an experimental version of Ubuntu throws an error is not proper form. The problem should be fixed in the OS, not the install script.

Again, feel free to test it and post the results, and I will see if its a viable solution.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 24 July 2013 at 21:26
Ronin DUSETTE
Admin

I checked the changelog for 1.6, and I dont see anything related to PNG specifically. Although, they said that they did add some new support for images, but only mentioned JPEG. Again, it may make the error go away, but it wont fix the problem. It will just be a bandaid.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Wednesday 24 July 2013 at 21:36
steve723Anonymous

I dont get the PNG error at all, but Im also not running an experimental version of Ubuntu, so that is why you get the error. Experimental libpng comes default in 13.04.

Quote from DJYoshaBYD


It dose not matter since the shortcut suceeds in launching the game. I just click ok to clear the error dialog box then run and the game launches. Its probly just a minor difference similar to wine fixme messages. If you notce from other game scripts such as Civ4, others use ubuntu 13.04 to. He uses Ubuntu xfc 13.04. Just pointing that out. Maybe PlayOnLinux 5 will support the new libpng?
Ronin DUSETTE Wednesday 24 July 2013 at 21:46
Ronin DUSETTE
Admin

Sigh. Like I said, its NOT a POL thing, its not (really) a wine thing. I understand that it just gives an error message. This is a libpng issue. Simply, the version on your system causes errors because its trying to do stuff that the rest of the system is not ready for, hence it being a testing package. I understand that 13.04 is listed as stable, but its still running experimental packages.

Do they have this error in civ 4? Also, he may have different repos than you, considering he is running XFCE (and you are not), which runs a different set of libraries. Its not that we dont support it. Its just throwing an error when using an EXPERIMENTAL, EDGING library. Hence the reason its moot in STABLE versions. I never said that using 13.04 is WRONG, I just stated dont expect a completely stable, bug free system, when compared to LTS versions.

From Ubuntu's website:

Furthermore, we define the LTS to be:

Enterprise Focused: We are targeting server and multiple desktop installations, where the average user is moderately risk averse.

Compatible with New Hardware: We will make point releases throughout the development cycle to provide functional support for new server and desktop hardware.

More Tested: We will shorten the development window and extend the Beta cycle to allow for more testing and bug fixing

and clearly state that it is not:

A Feature-Based Release: We will focus on hardening functionality of existing features, versus introducing new ones1, except for in the areas of Online Services and Desktop Experience2.

1. Exceptions for priority projects will be documented.
2. Because these two areas of development are relatively new, they still require new features to satisfy the original reasons for their creation

Cutting Edge: Instead of doing an automatic full package import from Debian unstable, we will do it from Debian testing1. The benefit we gain from not introducing new bugs and/or regressions outweighs the new features and/or fixes we often get from unstable.

1. We reserve the right to selectively pull in updates from unstable, if we believe the stability of the package in Debian is better than what is in the current Ubuntu archive.

Zitat



But what do I know, right? :)

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 24 July 2013 at 21:50
Ronin DUSETTE
Admin

Im using libpng12, which is what came by default on my system, and has not changed:

$ libpng12-config --version
1.2.46

Zitat


Since your system came with the newer version, you get the error. You can downgrade the package, but risk breaking other things that rely on the experimental libpng in your system. It is what it is; an error from an experimental package on your linux system.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Wednesday 24 July 2013 at 22:03
steve723Anonymous

Ok I think I will make some inquerys on the Kubuntu forums since I don't want to get off topic for Civ 5. Besides then I can ask the Ubuntu devs some questions.
Ronin DUSETTE Wednesday 24 July 2013 at 22:06
Ronin DUSETTE
Admin

Its not off topic if its an error that happens on this game's install.

Im sure they will be able to answer your technical questions.

My whole point was, that non-LTS releases are testing versions so that they can get 2 years of testing packages for the next release (next LTS is 14.04). If you want a stable system, its LTS or bust.

Hope you find the answer youre looking for.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
alcorsepol Wednesday 24 July 2013 at 22:36
alcorsepolAnonymous

I dont get the PNG error at all, but Im also not running an experimental version of Ubuntu, so that is why you get the error. Experimental libpng comes default in 13.04.

Quote from DJYoshaBYD


ah yeah that's a good point, and a logical explanation.
I'll go with that for now, less work for me ^^

I'm going to have a go at the SimCity script to see if I can get it more stable now ;-)
Ronin DUSETTE Wednesday 24 July 2013 at 22:39
Ronin DUSETTE
Admin

Sweet. The newest simcity (2013?)? That didnt even see that. I LOVE SimCity games. Im getting that *hit right now. :D

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
Ronin DUSETTE Wednesday 24 July 2013 at 22:41
Ronin DUSETTE
Admin

Im buying it right now and going to test it. Go ahead and start a thread about it (if we are talking about the same one), and I will post my results there in a bit.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Wednesday 24 July 2013 at 22:51
steve723Anonymous

The launch of Sim City 2013 was the worst in history. EA/Maxis really took a bad hit on that one. I know I was one of unfortunat victums that pre ordered it. I got a free game out of the mess. I should go back online and see if they ever fixed all the ridiculas bugs. The poor Devs, they make a great game only to have EA make the worst launch in history.

We need to find an appropreat thread for this.
Ronin DUSETTE Wednesday 24 July 2013 at 23:05
Ronin DUSETTE
Admin

Really? I wonder why. They probably do online activation or something (like AC2 on PC did. Everyone was pissed), where you have to be online and connected to their server to even play the game.

I have to check that out. Thanks.

And yes, this convo can continue in the thread for the script.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Thursday 25 July 2013 at 19:38
steve723Anonymous

Yesterday I ran the new signed script for Civ4 and the PNG errors went away. Maybe this Civ5 script should be updated. Maybe its because the icons came from the server instead of POL.
Ronin DUSETTE Thursday 25 July 2013 at 22:25
Ronin DUSETTE
Admin

Petch will have to update that, but like I said, its because of the icons not being the same (you still have a conflicting package). I really dont care anymore, though. If you get errors, you get errors.

Please:
Post debug logs & full computer specs in first post
No private messages for general help, use the forums
Read the wiki, Report broken scripts
steve723 Thursday 25 July 2013 at 23:51
steve723Anonymous

I accendentally deleted my Civ5 drive. My file manager shows that the directory still exists so, I was woundering if there is a way to get the drive back since the files still exist?