Das Forum

Problème d'installation Guild Wars

Autor Antworten
Karibou Friday 13 December 2013 at 18:12


J'ai voulu installer guild wars mais j'ai une erreur lors de l'installation:

Error in POL_Shortcut
Binary not found: Gw.exe
Have you installed the program to the default location?

Ce message apparait que ce soit via installation CD ou en DL
J'utilise 10.9 en OS, POM 4.2.1 et XQuartz 2.7.5

Voici ce que me donne le débug

 declare -x AMD64_COMPATIBLE="False"
declare -x APPLICATION_TITLE="PlayOnMac"
declare -x ARGVZERO="./playonmac.real"
declare -x Apple_PubSub_Socket_Render="/tmp/launch-lU2Pvm/Render"
declare -x DESKTOP="/Users/hugo/Desktop"
declare -x DONT_MONITOR="1"
declare -x DYLDPATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applideclare -x DYLD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/tools/lib/dyld:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Appdeclare -x EXECUTABLEPATH="/Applications/PlayOnMac.app/Contents/MacOS/./playonmac.real"
declare -x GECKO_SITE="http://www.playonlinux.com/wine/gecko"
declare -x GNUPGHOME="/Users/hugo/Library/PlayOnMac//gpg"
declare -x HOME="/Users/hugo"
declare -x IGNORE_ICON_DIR="false"
declare -x LANG="fr_FR.UTF-8"
declare -x LD_LIBRARY_PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/lib/:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicatiodeclare -x LD_PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/lib/:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/lib:/Applicationdeclare -x LOGNAME="hugo"
declare -x MACHTYPE="x86_64-apple-darwin13"
declare -x MAGICK_HOME="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/"
declare -x MD5_COMMAND="md5"
declare -x OLDPWD="/Users/hugo/Library/PlayOnMac/plugins"
declare -x OSX_SUB_VERSION="0"
declare -x OSX_VERSION="13"
declare -x OS_NAME="darwin"
declare -x OpenGL32="1"
declare -x OpenGL64="1"
declare -x PATH="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/PlayOnMacdeclare -x PATH_ORIGIN="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/wine/bin:/Applications/PlayOnMac.app/Contents/Resources/playonlinux/../unix/image_magick/bin:/Applications/Pldeclare -x PLAYONLINUX="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x PLAYONMAC="/Applications/PlayOnMac.app/Contents/Resources/playonlinux"
declare -x POL_ARCH="x86"
declare -x POL_COOKIE="8M9NlFPFvyTUk1qi1YE7"
declare -x POL_CURL="curl"
declare -x POL_DNS="playonmac.com"
declare -x POL_HOST=""
declare -x POL_ID="66332779"
declare -x POL_LANG="fr"
declare -x POL_OS="Mac"
declare -x POL_PORT="30000"
declare -x POL_SetupWindow_ID="10296"
declare -x POL_TERM="xterm"
declare -x POL_UPTODATE="TRUE"
declare -x POL_USER_ARCH="x86"
declare -x POL_USER_ROOT="/Users/hugo/Library/PlayOnMac/"
declare -x POL_WGET="wget --prefer-family=IPv4 -q"
declare -x PWD="/Users/hugo/Library/PlayOnMac"
declare -x PYTHONHOME="/Applications/PlayOnMac.app/Contents/Resources"
declare -x PYTHONPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x REPERTOIRE="/Users/hugo/Library/PlayOnMac/"
declare -x RESOURCEPATH="/Applications/PlayOnMac.app/Contents/Resources"
declare -x RLANG="fr_FR.UTF-8"
declare -x SCRIPTID="Guild Wars"
declare -x SETUPWINDOW_INIT="true"
declare -x SHELL="/bin/bash"
declare -x SHLVL="4"
declare -x SITE="http://repository.playonlinux.com"
declare -x SSH_AUTH_SOCK="/tmp/launch-TzC6mJ/Listeners"
declare -x TEXTDOMAIN="pol"
declare -x TEXTDOMAINDIR="/Applications/PlayOnMac.app/Contents/Resources/playonlinux/lang/locale/"
declare -x TITLE="Guild Wars"
declare -x TITRE="PlayOnMac"
declare -x TMPDIR="/var/folders/x3/6x3gqpcd2t56kmt2msdql8w00000gp/T/"
declare -x USER="hugo"
declare -x VERSION="4.2.1"
declare -x WGETRC="/Users/hugo/Library/PlayOnMac//configurations/wgetrc"
declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"
declare -x WINEPREFIX="/Users/hugo/Library/PlayOnMac//wineprefix/default"
declare -x WINE_SITE="http://www.playonlinux.com/wine/binaries"
declare -x __CF_USER_TEXT_ENCODING="0x1F6:0:91
declare -x __CHECKFIX1436934="1"

12/13/13 18:06:10 - [POL_SetupWindow_install_wine] Warning: Function deprecated
12/13/13 18:06:10 - [POL_Wine_InstallVersion] Message: Installing wine version path: 1.5.3, x86
12/13/13 18:06:10 - [POL_Wine_SelectPrefix] Message: Selecting prefix: GuildWars
12/13/13 18:06:10 - [POL_System_SetArch] Message: POL_ARCH set to x86
12/13/13 18:06:10 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.5.3
12/13/13 18:06:10 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.5.3)...
12/13/13 18:06:10 - [POL_Wine_PrefixCreate] Message: Prefix already exists
12/13/13 18:06:12 - [POL_SetupWindow_menu] Message: menu answer: Overwrite (usually works, no guarantee)
12/13/13 18:06:12 - [POL_Wine_PrefixCreate] Message: Overwrite Prefix
12/13/13 18:06:12 - [POL_Wine_PrefixCreate] Message: Setting version to 1.5.3
12/13/13 18:06:12 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.5.3
12/13/13 18:06:12 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name
12/13/13 18:06:12 - [POL_Wine] Message: Running wine-1.5.3 cmd /c echo %ProgramFiles% (Working directory : /Users/hugo/Library/PlayOnMac)
12/13/13 18:06:12 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
C:\Program Files

12/13/13 18:06:15 - [POL_Wine] Message: Wine return: 0
12/13/13 18:06:18 - [Set_Managed] Message: Setting wine managed: Off
12/13/13 18:06:19 - [POL_Wine] Message: Running wine-1.5.3 regedit /Users/hugo/Library/PlayOnMac//tmp/regkey.reg (Working directory : /Users/hugo/Library/PlayOnMac)
12/13/13 18:06:19 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
12/13/13 18:06:20 - [POL_Wine] Message: Wine return: 0
12/13/13 18:06:22 - [POL_SetupWindow_icon_menu] Message: icon_menu answer: Télécharger le programme
12/13/13 18:06:22 - [POL_SetupWindow_InstallMethod] Message: Install method: DOWNLOAD
12/13/13 18:06:22 - [POL_Download] Message: Downloading http://www.guildwars.com/downloads/gwsetup.zip
12/13/13 18:06:27 - [POL_Download] Message: Download MD5 matches
12/13/13 18:06:27 - [POL_Wine] Message: Running wine-1.5.3 GwSetup.exe (Working directory : /Users/hugo/Library/PlayOnMac/wineprefix/GuildWars/drive_c/GW)
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:systray:initialize_systray Could not create tray window
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
wine: Unhandled page fault on write access to 0x00415e80 at address 0x400003 (thread 0023), starting debugger...
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Unhandled exception: page fault on write access to 0x00415e80 in 32-bit code (0x00400003).
Register dump:
 CS:001b SS:0023 DS:0023 ES:0023 FS:101f GS:000f
 EIP:00400003 ESP:0072f0b8 EBP:ffffffff EFLAGS:00210296(  R- --  I S -A-P- )
 EAX:00730d43 EBX:00415e80 ECX:0041d980 EDX:7b872b86
 ESI:0072f0e8 EDI:00730000
Stack dump:
0x0072f0b8:  00730000 00415ebc 0072f3b4 0072f4dc
0x0072f0c8:  004089f8 fffffffe 00426bf0 0072f0e8
0x0072f0d8:  00000001 0072f50c 00000000 00000000
0x0072f0e8:  00010007 0072f05c 0072f05c 00000085
0x0072f0f8:  7ffdf000 7ffdf000 0072f777 42fd3106
0x0072f108:  0072f358 42fd46da 00090048 00000001
0203: sel=101f base=7ff90000 limit=00000fff 32-bit rw-
=>0 0x00400003 in gwsetup (+0x3) (0xffffffff)
0x00400003: addb    %al,0x0(%ebx)
Module    Address            Debug info    Name (23 modules)
ELF           0-82001000    Stabs           <wine-loader>
PE      400000-  42c000    Deferred        gwsetup
PE    401a0000-401a3000    Deferred        crtdll
PE    401e0000-401e4000    Deferred        version
PE    40590000-40594000    Deferred        advapi32
PE    40790000-40794000    Deferred        wsock32
PE    407b0000-407b4000    Deferred        ws2_32
PE    407e0000-407e4000    Deferred        iphlpapi
PE    42e80000-42e84000    Deferred        msvcrt
PE    42f20000-42f5a000    Deferred        user32
PE    430a0000-430a6000    Deferred        gdi32
PE    43190000-432e8000    Deferred        shell32
PE    433f0000-433f8000    Deferred        shlwapi
PE    43480000-434ae000    Deferred        comctl32
PE    435b0000-435b8000    Deferred        ole32
PE    43720000-43724000    Deferred        rpcrt4
PE    437c0000-437c8000    Deferred        oleaut32
PE    43990000-43994000    Deferred        uxtheme
PE    439d0000-439d3000    Deferred        imagehlp
PE    439f0000-439f4000    Deferred        dbghelp
PE    43ce0000-43ce4000    Deferred        psapi
PE    7b810000-7b867000    Deferred        kernel32
PE    7bc10000-7bc14000    Deferred        ntdll
process  tid      prio (all id:s are in hex)
00000008 (D) C:\GW\GwSetup.exe
    00000023    0 <==
    00000022    0
    00000021    0
    00000009    0
0000000e services.exe
    0000001f    0
    0000001e    0
    00000018    0
    00000017    0
    00000015    0
    00000010    0
    0000000f    0
00000012 winedevice.exe
    0000001c    0
    00000019    0
    00000014    0
    00000013    0
0000001a plugplay.exe
    00000020    0
    0000001d    0
    0000001b    0
00000024 explorer.exe
    00000025    0
12/13/13 18:06:29 - [POL_Wine] Message: Wine return: 5
12/13/13 18:06:29 - [POL_Shortcut] Error: Binary not found: Gw.exe\nHave you installed the program to the default location?

Merci a vous pour ce que vous faites

Editiert von: Karibou

Karibou Sunday 29 December 2013 at 17:02

Pas de solutions?
Quentin PÂRIS Monday 30 December 2013 at 22:02
Quentin PÂRISAnonymous

Essais avec wine 1.7.9
theodors Tuesday 31 December 2013 at 0:24


Si je peux me permettre, je ne sais pas de quel Guild Wars tu parles, mais le 2 est disponible pour mac pour un prix dérisoire quand on voit la qualité du jeu et l'absence d'un abonnement.
Je ne veux pas donner de leçon d'aucune sorte, mais pour ma part, et ayant joué à GW premier du nom pendant 2 ans, et ayant aussi un compte sur le 2, je te conseille vraiment d'investir dans le 2 directement et de la manière la plus légale possible, car tu ne le regretteras pas (si les MMORPG sont bien ton style de jeu).
Si tu parles bien du 1 (prophecies, factions, nightfall et la dernière extension dont je ne me rappelle plus du nom) tu vas vite être déçu du gameplay, des graphismes et bugs en tout genre et de la communauté de joueurs quasi exclusivement devenu des marchands ou des bots.
C'est un avis personnel, pour ma part je ne saurai pas t'aider dans ta quête moi-même ne sachant pas utiliser PlayOnMac correctement :)
Bien à toi,

Karibou Saturday 4 January 2014 at 15:41

Merci Quentin, j'essaierai quand j'en aurai l'occasion je te redis après
Merci theodors, mais j'ai déjà le 2. Juste un peu de nostalgie ;)
gusss54 Sunday 26 January 2014 at 19:22


Je rencontre le même problème lors de l'installation de rollercoaster tycoon 2 acheté sur gog.com. J'ai essayé le debug qui n'a rien donné. Après plusieurs installation sans résultats (lancement du jeu, j'ai le son mais un écran noir et je vois apparaitre quelques bandes de temps en temps). Je me suis rendu compte que la version utilisé de wine n'était pas la dernière (1.7.9). Comment faut il faire pour essayer avec la dernière version ?
Que puis-je faire d'autre ?

d'avance merci ;)