Das Forum

AOE 2 HD with Steam not starting

No error

Autor Antworten
Philastan Thursday 15 December 2016 at 17:09

Hi guys,

first of all: Thanks for the great work! Your application works like a charm.

But now to my problem. 

I play on a MacBook Pro (Retina 13 Zoll, early 2015), Intel Iris Graphics 6100 1536 MB, 16gb RAM.

Used Wineversion: 1.7.53-steam_crossoverhack.

Age of Empires itself is installed via Steam. But when I try to start the game a message pops up with something like "AOE starts" then it stops. Nothing more. I'd really like to post some errormessage or something, but nothing pops up. The game just don't start, Steam itself continues to work. Ah and BTW it did work before!

Yesterday I tried to copy my userfolder to another drive, didn't work so I relocated the userpath to the old one. This is the only thing I did, before my Age of Empires 2 HD didn't work anymore.

Any ideas? Need to fix this, so I can handle my AOE addiction :S






Editiert von: Philastan

Philastan Thursday 15 December 2016 at 21:25


Tested it on another MacBook. Same problem. So it seems not related to my userfolder thingy...

Philastan Thursday 15 December 2016 at 21:44

// was game related // can be closed

flavorofdp Wednesday 21 December 2016 at 20:22

Same!!! The new dlc rise of rajas won't run! Any ideas on how to fix this please let me know!!

Benen44 Wednesday 28 December 2016 at 19:05

I have the same problems


beankylla Monday 2 January 2017 at 10:46

I had the same problem.

Some update has redownloaded all the game files.

In order to make it work you must go into the directory where AOE2HD is instaled, and change the executable of the game into "launcher.exe" (beforehand remove / rename launcher.exe).

It should then work flawlessly.



perkh Tuesday 3 January 2017 at 18:57

Same issue here. Steam starts to run the game, but instantly stops. No error message.
I have followed beankylla's instructions above, but without success.

Thankful for more help!

MrSprinkles Wednesday 1 February 2017 at 1:13

Beankylla's solution was spot on for me cheers!


In case anyone is looking for the file beankylla is referring to, look in: /Users/<you>/Library/PlayOnMac/wineprefix/Steam/drive_c/Program Files/Steam/steamapps/common/Age2HD/

and rename AoK HD.exe to Launcher.exe.



rwp Sunday 23 April 2017 at 2:46

Beankylla's solution seems to work for me too.  I also had to switch my wine version to 1.8 steam crossoverhack because the 1.7.53 steam crossoverhack was causing some issues with steam...

But just to clarify the process a bit:

1. Right click on AOE2 in the steam game list
2. Click 'Properties'
3. Click 'Local Files'
4. Click 'Browse Local Files..'
5. You will see two files, 'AoK.exe' and 'Launcher.exe'
6. You need to rename 'AoK.exe' to 'launcher.exe' (I don't think caps matters), but you will first need to rename the original launcher file to something else (can't have two files with the same name)



EDITS: Actually didn't matter what wine version I used.  Also, while Beankyllah's solution got my AOE game running again, the game locks up when I try to start a new standard game and I have to force quit.  Anyone have any thoughts on how to fix this?

Editiert von: rwp

GrantWilson Wednesday 2 October 2019 at 8:46



I've the same issue. I tried to use the launcher.exe directly, but it gave the pop-up error message "SteamAPI_RestartApplfNecessary/() has been triggered". How to fix this error? Nothing worked, I tried everything I found on the forums: https://forums.ageofempires.com/t/game-wont-start/27228/view


Editiert von: GrantWilson