Das Forum

Internet Explorer 8 and DVR Active X (HiDvrOcx.cab)

black video (no video) in live streams

Autor Antworten
masimito Tuesday 8 February 2022 at 17:34


Internet Explorer 8 works as expected! But the only reason I need it is because my DVR uses ActiveX!

IE wont install the activex cab so I have to do it manually. I extracted HiDvrOcx.cab, getting the following files:

  • AudioPlayer.dll
  • HiDvrMedia.dll
  • HiDvrNet.dll
  • HiDvrOcx.inf
  • HiDvrOcx.ocx
  • hi_h264dec_w.dll
  • lib_VoiceEngine_dll.dll
  • Portuguese.dll
  • Russian.dll
  • SimplifiedChinese.dll
  • Spanish.dll

I used POL_Wine regsvr32 HiDvrOcx.ocx and got the following:

[POL_Wine] Message: Running wine-4.0.3 regsvr32 HiDvrOcx.ocx
regsvr32: Successfully registered DLL 'HiDvrOcx.ocx'
[POL_Wine] Message: Wine return: 0

For the rest of the DLLs I used:  "regsvr32 /n FILE.DLL", not sure if this is right, but "POL_Wine regsvr32 FILE.DLL" (with and without the /n switch) crashes.

There is an INF file, so I also tried: "POL_Wine rundll32 setupapi.dll,InstallHinfSection DefaultInstall 128 HiDvrOcx.inf"

[POL_Wine] Message: Running wine-4.0.3 rundll32 setupapi.dll,InstallHinfSection DefaultInstall 128 HiDvrOcx.inf
[POL_Wine] Message: Wine return: 0


and copied all the DLL files to windows/system32 directory.

I also tried the "emulate a virtual desktop" option with a higher resolution.

I also installed NVIDIA 32 bit compatibility drivers.

I also installed mesa-dri-drivers-21.3.4-1.el8.i686.

I also tried Internet Explorer 6 with the exact same results.

I also tried many Display options.

I also rebooted ...

But I always get black windows instead of live streams, the same goes for recorded streams. But my network monitoring applet shows activity

I also tried a live record from the DVR homepage and downloaded it. Playing it with ffplay shows the stream, so it seems the DVR Active X is working as expected but IE8 is just not showing the streams. Maybe I need an additional component? WM9? any codec? directx? the component list is huge.

Some screenshots:




Any help is really appreciated, I am so close to make it work.

Thank you.

PD. My system:

  • Centos Stream 8
  • playonlinux-4.4-2.el8.x86_64
  • winetricks-20191224-1.el8.noarch
  • NVIDIA driver version 390.147



Dadu042 Sunday 27 March 2022 at 23:29

Very old files ... frown

I sugges to try with a newer Wine (4.0.3 -> 6.0.1), then later to try with Crossover ( http://codeweavers.com/ ).