Das Forum

Star Wars : Knight Of The Old Republic

Autor Antworten
ryousuke Tuesday 27 November 2007 at 18:02

Wine version: 0.9.37
Distribution: Debian
Distribution version: SID (Unstable)
Graphics card: Nvidia, geforceFX 5700LE (version 256Mo)
Graphics card driver: 1.0-9755
- Everything works great, you have to install the 1.03 patch and disable the hardware mouse in the launcher SWKotor_Config.

Thx to GNU_Raziel for this test!

Editiert von: Salvatos

drakkar123 Saturday 8 August 2009 at 16:34

Version of wine : 1.1.26 and 1.1.18
Distribution : openSUSE
Version of the distribution : 11.1
Graphics card : Nvidia GeForce GTX 260
Drivers of the graphics card : 185.18.14
Comments : There seems to be a few errors in the install script for Star Wars: Knights of the Old Republic

1. The first issue I had was the POL install script was in a foreign language. I was able to fumble my way through the install though.

2. The POL script prompted for the CD-ROM drive mount point for the source CDs. The mount point the openSUSE auto-mounter uses for CD-ROMs is:
/media/<CDlabelname>. I selected the only option on the list: /media/KOTOR_1. Then the script copied the contents of CDROM1 to the hard drive. When it completed, I was prompted for CDROM2. After I put the second CD in and clicked next, another prompt came up almost immediately asking for CDROM3. The same thing happened for the rest of the CDs. After several tries, I finally worked around the problem after CDROM1 finished being read by creating a symbolic link named /media/KOTOR_1 pointing at /media/KOTOR_2. I had to do the same thing for /media/KOTOR_3 and so on, after each CD was read.

3. The third problem was an error in the shell script /home/username/.PlayOnLinux/configurations/installed/Star Wars : Knights of the Old Republic. The error caused the POL menu link to be broken. I was able to edit the script, and correct the problem by changing the line:

cd "/home/username/.PlayOnLinux/wineprefix/SWKotor/drive_c/Program\\ Files/LucasArts/SWKotOR"


cd "/home/username/.PlayOnLinux/wineprefix/SWKotor/drive_c/Program Files/LucasArts/SWKotOR"

4. The POL install script placed a pixmap file in /home/user/.PlayOnLinux/configurations/installed and in my KDE 3.5 startup menu called SWKotor_config.xpm..This also created erroneous shortcuts in the POL and KDE menus. I'm guessing that this was intended to create a link for the swconfig.exe app, because the other link created, was a direct link to swkotor,exe, bypassing the launcher.

Also worth noting, Wine Version 1.1.26 had a problem with no working audio in game after the intro videos. I'm currently running it now with wine 1.1.18. I could not get it to start with full screen. I tried 5 different versions of wine with the same results. After changing the entry "Fullscreen=0" and "Refresh=0" in my swkotor.ini file, wine version 1.1.18 works perfectly. It won't start in fullscreen, but after it is running, I am able to select fullscreen on the window titlebar, and it runs in fullscreen without problems (can also press ALT-F3 with KDE). I am even able to use the hardware mouse and in game movies, without problems.
NSLW Saturday 8 August 2009 at 19:14

Third problem is solved. The installation script should be translated for new so it uses new POL frontend, then there would be less problems.

Please try again now.

Editiert von: NSLW

ET Friday 28 August 2009 at 12:52

Version of wine : 1.1.28
Distribution : Debian
Version of the distribution : testing
Graphics card : GeForce Go 7900 GS
Drivers of the graphics card : 185.18.36-1+2.6.30-5
Comments : There seems to be a few errors in the install script for Star Wars: Knights of the Old Republic

First i tried to run the script from the instalation dialog and this faild with some errors like:
./PlayOnLinux/install: line 55: Use_WineVersion: command not found

I added:
[ "$PLAYONLINUX" = "" ] && exit 0
source "$PLAYONLINUX/lib/sources"

after the head-comments.

the next wehr some errors while copy the cds: file does not exist

i added


After Chosing the wine version:

Editiert von: ET

NSLW Wednesday 2 September 2009 at 17:31

gtludwig Friday 24 September 2010 at 16:22

I also installed this game and the script works flawlessly. My only question is that when I ran the configurator, it failed the video test and didn't recognized the installed video driver. I'm using a GeForce 9600GT with the x86_64 latest blob.
Jncocontrol Sunday 26 September 2010 at 7:15

Can we add support for KOTOR on Steam?
GNU_Raziel Wednesday 29 September 2010 at 18:20

I will add Digital Edition support as soon as possible, this will probably also work with steam version.
Jncocontrol Sunday 31 October 2010 at 2:40

I will add Digital Edition support as soon as possible, this will probably also work with steam version.

Quote from GNU_Raziel

You sir are awesome.
GNU_Raziel Friday 5 November 2010 at 18:03

It's done, it should now work with Digital Edition, enjoy :)
Jncocontrol Saturday 6 November 2010 at 23:36

I gave it a try today, Said something about "File not found".
GNU_Raziel Saturday 6 November 2010 at 23:40

can you give more infos ? Whitch version did you tried ? dvd ? steam ? other digital edition ?
Try launching POL in a terminal to have more error output, i need more data to fix the problem.
Jncocontrol Monday 8 November 2010 at 0:42

Well i started up POL, Click install, Went to Knights of the old republic, Clicked Apply, Then the error poped up.
GNU_Raziel Monday 8 November 2010 at 10:35

Neanie Wednesday 20 July 2011 at 17:17

It goes nicely through the steps to change cd. but forgets to actually start the installer.
I suspect the problem is the executable bit. I can only start the installer on wine command line and not directly with open with.