Das Forum

League of Legends: fix in-game shop icons

Howto using LoL Linux Tools

Autor Antworten
Jump to the page: 1 - 2 - 3
petch Thursday 31 January 2013 at 17:24

If League of Legends runs on your computer, you probably noticed that some artifacts do not have an icon in the in-game shop ("red squares").

Until a better fix is found, here's a workaround; You'll need to have [b]git[/b] installed:
- clone LoL Linux Tools:
$ git clone git://github.com/A-Metaphysical-Drama/LoL-Linux-Tools.git
- enter the git repository and adjust LoL install path:
$ cd LoL-Linux-Tools
$ sed -i -e "s@lol_path = './'@lol_path = '$HOME/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends'@" config.py
Now run the replacement of icons with versions supported by Wine:
$ python lol_linux.py texture_patch
League of Legends - Linux Tools
Downloading DATA.tar.gz Size: 245kb
    245760  [100.00%]
Unpacking Archives, please wait...
Saving Backups, please wait...
Replacing Files, please wait...
Repacking Archives, please wait...
Checking New Archives, please wait...
Moving Archives, please wait...
Cleaning up, please wait...
Patch applied Successfully!
It takes several minutes, but you should now have all icons working.

PS. You cannot do that just after LoL installation, it must have been updated first.

This procedure has since been automated, just install the beta script "League of Legends : ingame shop icons fix" from Patches category.

Editiert von: petch

LamerTex Thursday 31 January 2013 at 18:59

It works without problem for me, thank you :)
STormDevil Friday 8 February 2013 at 17:26

Are there any other steps to be done before patching with LLT?
Any special PoL settings?

I tried patching several times with no results - red squares are still there.

However, if I run it with repair option, I receive a lot of Bad File: DATA/... entries

Any suggestions would be appriciated
petch Friday 8 February 2013 at 17:37

I've found instructions to fix the issue (not sure from where, maybe http://euw.leagueoflegends.com/board/showthread.php?t=957851), tried them, it worked, so I shared my finding. Actually I just noticed that xpander already mentionned that tool in those forums: http://www.playonlinux.com/en/topic-9844-League_of_Legends_Problem.html

Anyway, for any support, better check with the author.

Editiert von: petch

STormDevil Friday 8 February 2013 at 18:39

Thanks petch, I'll give it one more try
petch Sunday 24 February 2013 at 22:06

Since it seems this situation is here to stay, I made a patch script out of it:
nullguy Sunday 7 April 2013 at 19:39

It worked, thanks!
Though you should warn users that this patch will use about ~3-5 gigabytes of space while processing.
petch Sunday 7 April 2013 at 19:46

Thanks, updated the script description.
Romen Sunday 28 April 2013 at 21:42

I get an error all the time :(
[code=console]tomek@Formula:~/LoL-Linux-Tools$ python lol_linux.py texture_patchTraceback (most recent call last): 
File "lol_linux.py", line 27, in <module>
    from config import *
   File "/home/tomek/LoL-Linux-Tools/config.py", line 21
    lol_path = '/home/tomek/PlayOnLinux's virtual drives/League_of_Legends/drive_c/Program Files/League of Legends'                                        ^
SyntaxError: invalid syntax[/code]

EDIT: Looks like I had to use the "real" path. (.PlayOnLinux/wineprefix/)

Editiert von: Romen

petch Monday 29 April 2013 at 0:06

Use the install script, don't bother running it manually anymore:
Install button > check "Testing" checkbox > Patches > "League of Legends: ingame shop icons fix"
nullguy Sunday 5 May 2013 at 12:58

Install script from PlayOnLinux does not work at all, it downloads the files and nothing happens after.
I've reinstalled LoL recently, and after that running script manually doesn't work. It says that patch applied successfully, but red squares are still in game.
I had hard disk failure though, and some system files were corrupted, that might have caused this issue.
EDIT: I get this in terminal - /home/myusername/.PlayOnLinux//install: line 56: Default: command not found
What to do?
petch Sunday 5 May 2013 at 13:45

Ah, it seems $POL_TERM only exists since PlayOnLinux 4.1.2
I modified the script to default to xterm, but it needs testing (time to reinstall LoL once again :p)
nullguy Sunday 5 May 2013 at 14:42

Now it gives this at start
[POL_Bash] Message: POL GPG : Good signature - League of Legends: ingame shop icons fix
/home/myusername/.PlayOnLinux//install: line 23: POL_SetupWindow_SetID: command not found
And this after downloading:

/home/myusername/.PlayOnLinux//install: line 57: Default: command not found

EDIT: My PlayOnLinux version is 4.1.1, should i try to update it to 4.2.1?

Editiert von: nullguy

nullguy Sunday 5 May 2013 at 15:09

With 4.2.1 it works exactly same as manual version, still no result.
Guess it's a problem with my system.
petch Sunday 5 May 2013 at 16:55

The line now goes like this:
SHELL=/bin/bash ${POL_TERM:-xterm} -e "./lol_linux.py texture_patch || read -p 'Press enter to continue'"

Since you're now using 4.2.1 on a Debian based distribution, $POL_TERM should contain x-terminal-emulator; What does update-alternatives --config x-terminal-emulator display?
petch Friday 10 May 2013 at 23:26

I disabled the script until a copy of http://www.darkwind.it/misc/DATA.tar.gz is found...
petch Saturday 11 May 2013 at 12:40

Fixed, using a DATA.tar.gz from my own harddrive :)
Meanwhile the original file is back, but for safety we'll keep using a local copy.
Veterini Monday 20 May 2013 at 12:28

Le script ne fonctionne pas chez moi...

PlayOnLinux debbuging tool (v4.1.1)
Debugging: League of Legends: ingame shop icons fix

Warning. This is a PlayOnLinux script logfile. It does not contains everything that happened in your program virtual drive (wineprefix)
Please do not use this logfile on winehq forum, this logfile is not interesting for wine debugging.

Date: 05/20/13 12:12:38

> uname -a
  Linux yamaneko-laptop 3.2.0-4-amd64 #1 SMP Debian 3.2.41-2 x86_64 GNU/Linux
> lsb_release -a
> wine --version (Be careful, this version might not be the version used
in the script. Read the content of this file for more information)
> glxinfo \\| grep rendering
  direct rendering: Yes
> glxinfo \\| grep renderer
  OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
> OpenGL libs
> export
  declare -x AMD64_COMPATIBLE="True"
declare -x APPLICATION_TITLE="PlayOnLinux"
declare -x DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-Y7aSy9AWWl,guid=4b731b06325e6df04c741b055199e18f"
declare -x DESKTOP="/home/yamaneko/Bureau"
declare -x DESKTOP_SESSION="xfce"
declare -x DISPLAY=":0.0"
declare -x DYLDPATH_ORIGIN=""
declare -x DYLD_LIBRARY_PATH=""
declare -x GECKO_SITE="http://www.playonlinux.com/wine/gecko"
declare -x GLADE_CATALOG_PATH=":"
declare -x GLADE_MODULE_PATH=":"
declare -x GLADE_PIXMAP_PATH=":"
declare -x GNOME_KEYRING_CONTROL="/home/yamaneko/.cache/keyring-ddYnRH"
declare -x GNOME_KEYRING_PID="4386"
declare -x GNUPGHOME="/home/yamaneko/.PlayOnLinux//gpg"
declare -x HOME="/home/yamaneko"
declare -x IGNORE_ICON_DIR="false"
declare -x LANG="fr_FR.UTF-8"
declare -x LD_LIBRARY_PATH=""
declare -x LD_PATH_ORIGIN=""
declare -x LOGNAME="yamaneko"
declare -x MACHTYPE="x86_64-pc-linux-gnu"
declare -x MAIL="/var/mail/yamaneko"
declare -x MD5_COMMAND="md5sum"
declare -x OLDPWD="/home/yamaneko/.PlayOnLinux/plugins"
declare -x ONLY_ONCE="1"
declare -x OS_NAME="linux"
declare -x PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
declare -x PATH_ORIGIN="/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
declare -x PLAYONLINUX="/usr/share/playonlinux"
declare -x POL_ARCH="x86"
declare -x POL_ID="2181837"
declare -x POL_LANG="fr"
declare -x POL_OS="Linux"
declare -x POL_SetupWindow_ID="4143"
declare -x POL_TERM="Default"
declare -x POL_USER_ROOT="/home/yamaneko/.PlayOnLinux/"
declare -x POL_WGET="wget -4 -q"
declare -x PWD="/home/yamaneko/.PlayOnLinux"
declare -x PYTHON="python"
declare -x REPERTOIRE="/home/yamaneko/.PlayOnLinux/"
declare -x SESSION_MANAGER="local/yamaneko-laptop:@/tmp/.ICE-unix/4528,unix/yamaneko-laptop:/tmp/.ICE-unix/4528"
declare -x SETUPWINDOW_INIT="true"
declare -x SHELL="/bin/bash"
declare -x SHLVL="3"
declare -x SITE="http://repository.playonlinux.com"
declare -x SSH_AGENT_PID="4507"
declare -x SSH_AUTH_SOCK="/tmp/ssh-uYXQFlObcpIP/agent.4466"
declare -x TERM="linux"
declare -x TEXTDOMAIN="pol"
declare -x TITLE="League of Legends: ingame shop icons fix"
declare -x TITRE="PlayOnLinux"
declare -x UBUNTU_MENUPROXY="0"
declare -x USER="yamaneko"
declare -x VERSION="4.1.1"
declare -x WGETRC="/home/yamaneko/.PlayOnLinux//configurations/wgetrc"
declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"
declare -x WINEPREFIX="/home/yamaneko/.PlayOnLinux//wineprefix/default"
declare -x WINE_SITE="http://www.playonlinux.com/wine/binaries"
declare -x WorkingDirectory="/home/yamaneko"
declare -x XAUTHORITY="/home/yamaneko/.Xauthority"
declare -x XDG_CONFIG_DIRS="/etc/xdg"
declare -x XDG_DATA_DIRS="/usr/local/share:/usr/share"
declare -x XDG_MENU_PREFIX="xfce-"
declare -x XDG_SESSION_COOKIE="5dd786d1c17c3609f3af97d900000cd0-1369039245.857301-1029985281"

05/20/13 12:12:44 - [POL_Wine_SelectPrefix] Message: Selecting prefix: LeagueOfLegends
05/20/13 12:12:44 - [POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.5.24-LeagueOfLegendsShop, x86
05/20/13 12:12:44 - [POL_Wine_SetVersionEnv] Message: "/home/yamaneko/.PlayOnLinux//wine/linux-x86/1.5.24-LeagueOfLegendsShop" exists
05/20/13 12:12:44 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name
05/20/13 12:12:44 - [POL_Wine_SetVersionEnv] Message: Setting wine version path: 1.5.24-LeagueOfLegendsShop, x86
05/20/13 12:12:44 - [POL_Wine_SetVersionEnv] Message: "/home/yamaneko/.PlayOnLinux//wine/linux-x86/1.5.24-LeagueOfLegendsShop" exists
05/20/13 12:12:44 - [POL_Wine] Message: Running wine-1.5.24-LeagueOfLegendsShop cmd /c echo %ProgramFiles%
05/20/13 12:12:44 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
C:\\Program Files

05/20/13 12:12:45 - [POL_Wine] Message: Wine return: 0
05/20/13 12:12:48 - [POL_Download] Message: Downloading http://files.playonlinux.com/LoL-Linux-Tools-master.zip


La dernière ligne indique le début d'un téléchargement, mais rien ne se lance apparemment.
Une idée ?
Deleted oups, say crap
petch Monday 20 May 2013 at 19:23

(this is the english forum by the way)
I fixed a bug in the script that prevented it from really switch from http://www.darkwind.it/misc/DATA.tar.gz, but I'm not sure if that could be the reason for what you're experiencing...