The forum

Steam stuck on updating

Super Street Fighter IV Arcade Edition Steam Version

Author Replies
doaN Friday 28 February 2014 at 5:59

Hey guys!

Trying to install SF IV.
Everytime I tried, steam is stuck when it needs to update the first time (around 70%-90%).

I read about Steam is broken with older wine versions. Is it the cause ?
And I saw that SF IV need a special wine's version: "1.5.4-xliveless3-rawinput3"

Thanks for help
petch Friday 28 February 2014 at 7:21

doaN Thursday 6 March 2014 at 3:20

hi petch and thanks.

Do I still need the xliveless3-rawinput3 version with a wine version 1.7.+ ?

petch Thursday 6 March 2014 at 3:42

I'm not sure, my best guess would be: rawinut no (I think it's now standard), xliveless yes
se99paj Thursday 6 March 2014 at 12:27

Don't know if this is relevant, but I'm just moving over to Linux for gaming and I'm also trying to get Steam installed for the first time.

I've installed POL, and installed Steam straight from the POL options, but when I run Steam I get an error regarding SteamConfigServers not being available and Steam closes.

Not many results for SteamConfigServers on Google, I did notice that 1.7+ is required and changed in POL but this didn't help.

I'm new to POL so this could be related or I could just be installing Steam in the wrong way.
se99paj Thursday 6 March 2014 at 22:44

For info - just found a few other people on the Steam forums that are having a similar issue as me, sure the problem is on the Steam end and is nothing to do with POL.

Looks like I picked the wrong time to start messing around with Steam and Linux
twotwenty Friday 7 March 2014 at 8:56

I am having the same issue using wine1.7.13 or 1.7.*

no SteamConfigServers
I use ubuntu12.04 64bit and 4.2.2 POL

I get the same issue when trying to install in wine with a 32bit prefix

winetricks did install it and it worked in a 64bit prefix but installing .net wasd not possible so I could not install skyrim
twotwenty Friday 7 March 2014 at 9:13

I was able to fix my issue by
clicking the congfigure botton used teh wine tab and uninstalled the non working steam
downloading the steam installer .exe from the steam website then running that installer using the configure button on the steam prefix in POL
in the misculaneos tab you can run .exe in this virutual drive

doaN Sunday 9 March 2014 at 7:27


How do I use a xliveless version ?
Do I need winetricks ?

petch Sunday 9 March 2014 at 10:33

It's not a component it's a patch, so having it for Wine 1.7.x would require a build request.

I don't know the details of what version of xliveless patch to use, as I don't play anything having DRM on it (including no Steam game).
petch Sunday 9 March 2014 at 11:17

The current way of requesting a custom build is to fill a feature request in the bug tracker, with a link to the patch and any relevant informations for building, specially if not standard.

See for example